Results 1 to 5 of 5

Thread: Ubuntu Won't boot after installing ATI Proprietary Drivers.

  1. #1
    Join Date
    Mar 2018
    Beans
    2

    Ubuntu Won't boot after installing ATI Proprietary Drivers.

    Hello. First of all, i'm using an old ATI GPU (Radeon HD 5450). I Tried installing the drivers on 16.04, but they aren't supported, causing me to not be able to find fglrx on the default Repos. I Downgraded to Ubuntu 14.04, and after following the Tutorial Here And Restaring My pc freezes on the boot screen. i can't access the Terminal with ALT+CTRL+F1 too. I Reinstalled Ubuntu 14.04 about 6 Times today already, trying to download fglrx from their website and running it and i still got the same problem.
    Linux is the only operating system i can use ATM. And it's so sad that i can't play my games properly on it.
    Seriously though, Any help will be really, really, appreciated.
    Thanks

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Ubuntu Won't boot after installing ATI Proprietary Drivers.

    Which 14.04 version?
    The latest version cannot run the drivers since it uses the same hardware and kernel stack that 16.04 uses.
    To install the drivers on 14.04 you need this version
    http://old-releases.ubuntu.com/releases/14.04.1/
    (even though the page says 14.04.2 the version you would be getting is 14.04.1 which uses the original hardware stack for 14.04.
    that hardware stack is what will work.)
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Mar 2018
    Beans
    2

    Re: Ubuntu Won't boot after installing ATI Proprietary Drivers.

    I'm using the latest version of 14.04.
    Is it possible to downgrade from it?

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,379
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Ubuntu Won't boot after installing ATI Proprietary Drivers.

    russianmoney; Yepper ^^ .

    *downgrade* your trusty to the original trusty 3.13 kernel and xorg :
    Code:
    sudo apt install --install-recommends linux-generic xserver-xorg-core xserver-xorg xserver-xorg-video-all xserver-xorg-input-all libwayland-egl1-mesa
    reboot into grub and choose to boot the 3.13 kernel .

    Now if all is good remove the unwanted HWE stack:
    Code:
    sudo apt purge linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial
    verify once more that grub is happy
    Code:
    sudo update-grub
    All good ?? Now you can install the FGLRX driver.

    ain't no step for a stepper
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  5. #5
    Join Date
    Jun 2007
    Beans
    13,755

    Re: Ubuntu Won't boot after installing ATI Proprietary Drivers.

    Quote Originally Posted by russianmoney View Post
    Linux is the only operating system i can use ATM. And it's so sad that i can't play my games properly on it.
    Why can't you use the default open source radeon driver? It used to work fine on my HD4550.
    fglrx/Catalyst is a dead end.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •