Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Play .swf File

  1. #1
    Join Date
    Mar 2018
    Beans
    5

    Play .swf File

    I'm relatively new to Ubuntu and have tried everything to try and play some .swf files that I have. I installed the flash plugin by downloading the .tar.gz file from adobe's flash site and putting it in firefox's plugin folder.
    Code:
    sudo nautilus
    is how I was able to write to it. I went to /usr/share/mime/packages and modified the freedesktop.org.xml such that "vnd.adobe.flash.movie" is now "x-shockwave-flash". I cannot seem to find GNU Gnash (or just gnash) in the Ubuntu Software Store.
    I changed the .xml file by doing the following:
    Code:
    sudo su
    cd /usr/share/mime/packages
    cp freedesktop.org.xml freedesktop.org.xml.old
    I modified this one by using VSCode.
    Code:
    update-mime-database /usr/share/mime/
    After this I still can't seem to find a way to play my .swf files. I've been searching for a solution for about a week now and would appreciate any help.
    ~~Thanks!
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2018
    Beans
    140

    Re: Play .swf File

    You probably should be able to open it from your browser. Of course you need the Flash plugin for Firefox. There is no need to install it from Adobe.

    You can install it with this command from the terminal:

    Code:
     sudo apt install flashplugin-installer
    Then restart your browser.

    If you have Chrome installed you already have working Flash as it comes with its own Pepper Flash plugin.

  3. #3
    Join Date
    Mar 2018
    Beans
    5

    Re: Play .swf File

    I've already done this command in the terminal as well. It prompts to use sudo apt-get remove to remove it. I did uninstall and reinstall but nothing seems to have changed. Is there anything else that might make flash files not play?

  4. #4
    Join Date
    Mar 2018
    Beans
    5

    Re: Play .swf File

    Firefox DOES play flash files when it is ON THE WEB like from comdotgame.com etc. It just can't seem to play the .swf files downloaded on my computer.
    Attached Images Attached Images
    Last edited by zackarycw; March 6th, 2018 at 06:46 AM.

  5. #5
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Play .swf File

    Or you can install "swfdec-gnome" should work for most .swf files.
    I haven't used this for a couple years now but give it whirl.
    This package is a transitional package for upgrading to Gnash
    It can be safely removed when Gnash is installed
    Last edited by 1fallen; March 6th, 2018 at 02:57 AM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  6. #6
    Join Date
    Aug 2013
    Beans
    4,395

    Re: Play .swf File

    You can play .swf files in Firefox by doing the following(flash plugin has to be installed first of course)

    In your home directory create a new document called .mime.types (note the "." in front, this is a hidden file). In it put only one line
    Code:
    application/x-shockwave-flash       swf swfl
    (Edited: This is a lot cleaner than messing with freedesktop.org.xml )

    Then logout and log back in (may not be necessary)

    Next, you need to edit FF's config for it to play local .swf files. Open firefox, type about:config in the url, when the warning comes up click you accept the risks. Then in the search type plugins
    locate the string
    plugins.http_https_only
    click on value and change it to false.

    Restart Firefox for it to take effect.

    Now right click on your .swf file in Properties > Open with choose Firefox as the default. Now click on it an it would play in Firefox.

    Edited: Now setting plugins.http_https_only to be false means disabling a FF security feature, so do it at your own risk. You can mitigate it a bit by going to Tools > plugins and set flash's setting to "ask to activate" so you have to give it explicit permission to play a file.
    Last edited by monkeybrain20122; March 6th, 2018 at 06:12 AM.

  7. #7
    Join Date
    Mar 2018
    Beans
    5

    Re: Play .swf File

    OMG THIS WORKED. All I needed was the plugins.http_https_only thing toggled, other step didn't seem to do much. THANK YOU SO MUCH!!!!!!! This is my first time on this forum, is there a way I can set this issue to solved? THANK YOU!!

  8. #8
    Join Date
    Mar 2018
    Beans
    5

    Re: Play .swf File SOLVED

    Use method described earlier in thread or configure freedesktop.org.xml accordingly then go to FF about:config and toggle plugins.http_https_only . Thank you monkeybrain20122 and others for solution. (re-logging was not necessary here)
    Attached Images Attached Images
    Last edited by zackarycw; March 6th, 2018 at 06:44 AM.

  9. #9
    Join Date
    Jan 2018
    Beans
    140

    Re: Play .swf File

    Quote Originally Posted by zackarycw View Post
    This is my first time on this forum, is there a way I can set this issue to solved? THANK YOU!!
    Edit the title in the first post of this thread.

  10. #10
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Play .swf File

    Or read Thread Tools drop down menu at top right of this page.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •