Results 1 to 8 of 8

Thread: Error: Unable to correct problems, you have held broken packages

  1. #1
    Join Date
    Sep 2011
    Beans
    98
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Error: Unable to correct problems, you have held broken packages

    Hello,

    I've recently installed Ubuntu 16.04.4 (64-bit) while previously I was using 16.04.1 (32-bit).

    It was a clean install and things are generally working fine. However, for some packages I am getting this error e.g., if I try to install VLC from default repositories I get this

    Code:
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                    libgles1
           Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                    libgles2
    E: Unable to correct problems, you have held broken packages.
    Similarly if I try to install Wireshark

    Code:
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wireshark : Depends: wireshark-qt but it is not going to be installed or
                          wireshark-gtk but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    There are other packages as well which are important to me but are failing to be installed because of this problem. I suspect that these packages have not yet been updated with the underlying Ubuntu distribution i.e., 16.04.4

    Any suggestions / help please?

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Error: Unable to correct problems, you have held broken packages

    What does
    Code:
    sudo apt update
    show?
    Any errors or fail to fetches?
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Sep 2011
    Beans
    98
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: Error: Unable to correct problems, you have held broken packages

    Nah, no errors in there whatsoever. Here is the output:

    sudo apt update
    Hit:1 http://ppa.launchpad.net/gns3/ppa/ubuntu xenial InRelease
    Hit:2 http://ppa.launchpad.net/maarten-bae...ecorder/ubuntu xenial InRelease
    Hit:3 http://sa.archive.ubuntu.com/ubuntu xenial InRelease
    Hit:4 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu xenial InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.

  4. #4
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Error: Unable to correct problems, you have held broken packages

    Odd, you seem to be hitting a only a single Ubuntu repo.
    What are your sources?
    run
    Code:
    cat /etc/apt/sources.list
    and post the results.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  5. #5
    Join Date
    Sep 2011
    Beans
    98
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: Error: Unable to correct problems, you have held broken packages

    @deadflowr, Thanks for the prompt reply. Here is the output:

    Code:
    cat /etc/apt/sources.list
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    
    # newer versions of the distribution.
    deb http://archive.ubuntu.com/ubuntu xenial main restricted
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu xenial universe
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial universe
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://archive.ubuntu.com/ubuntu xenial multiverse
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial multiverse
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb-src http://sa.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu xenial partner
    # deb-src http://archive.canonical.com/ubuntu xenial partner
    
    # deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    # deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    # deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
    Last edited by deadflowr; March 5th, 2018 at 09:23 AM. Reason: switched to code tags from quote

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Error: Unable to correct problems, you have held broken packages

    You need to enable -updates and -security repos.
    Those should contain the updated packages you need,
    https://help.ubuntu.com/community/Re...tu#Updates_Tab
    Look in Software Sources.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Sep 2011
    Beans
    98
    Distro
    Ubuntu Gnome 16.04 Xenial Xerus

    Re: Error: Unable to correct problems, you have held broken packages

    @deadflowr, Wow! You rock. Bang on.

    I had not thought that disabling updates resources would create this problem. Thank you very much its fixed and all good now.

    (Y)

  8. #8
    Join Date
    May 2015
    Beans
    2

    Re: Error: Unable to correct problems, you have held broken packages

    @deadflower many thanks! that really solved the big pain

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •