Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: transmission-daemon won't start as a service

  1. #11
    Join Date
    Mar 2018
    Beans
    2

    Re: transmission-daemon won't start as a service

    I've just published the issue in the Transmission Github.
    I hope that we can find a solution for this.

    https://github.com/transmission/transmission/issues/537



    EDIT:
    I solved the problem. But installing a previous version: 2.84
    I had a PPA repository for the transmission, and this version have a problem with the user and the init.d

    I remove the transmission.list from the /etc/apt/sources.list.d
    After that, I unistall the transmission with purge, and install again from Ubuntu repository.

    Before doing that remember to make a copy of your config file:
    /etc/transmission-daemon/settings.json


    I hope this solve your problem.
    Last edited by auveele; March 5th, 2018 at 06:33 PM.

  2. #12
    Join Date
    Mar 2018
    Beans
    4

    Re: transmission-daemon won't start as a service

    Quote Originally Posted by auveele View Post
    I've just published the issue in the Transmission Github.
    I hope that we can find a solution for this.

    https://github.com/transmission/transmission/issues/537



    EDIT:
    I solved the problem. But installing a previous version: 2.84
    I had a PPA repository for the transmission, and this version have a problem with the user and the init.d

    I remove the transmission.list from the /etc/apt/sources.list.d
    After that, I unistall the transmission with purge, and install again from Ubuntu repository.

    Before doing that remember to make a copy of your config file:
    /etc/transmission-daemon/settings.json


    I hope this solve your problem.
    Downgrading is only a temporary solution and not a true resolution of the problem. I am staying on version 2.92 which is before the problem began. The issue is with 2.93.

  3. #13
    Join Date
    Mar 2018
    Beans
    1

    Re: transmission-daemon won't start as a service

    I case someone would like to go back to version 2.92. Here is a way to do it that worked for me:

    Code:
    # remove transmission and ppa
    sudo apt purge transmission*
    sudo add-apt-repository --remove ppa:transmissionbt/ppa
    sudo apt update
    # get packages
    wget http://mirrors.kernel.org/ubuntu/poo...le-4_amd64.deb
    wget http://security.ubuntu.com/ubuntu/po...u3.1_amd64.deb
    wget http://security.ubuntu.com/ubuntu/po...u3.1_amd64.deb
    wget http://security.ubuntu.com/ubuntu/po...ntu3.1_all.deb
    # install them
    # first libevent
    sudo dpkg -i libevent-2.1-6_2.1.8-stable-4_amd64.deb
    sudo dpkg -i transmission-common_2.92-2ubuntu3.1_all.deb
    sudo dpkg -i transmission-cli_2.92-2ubuntu3.1_amd64.deb
    sudo dpkg -i transmission-daemon_2.92-2ubuntu3.1_amd64.deb
    # check if transmission-daemon is running
    sudo systemctl status transmission-daemon.service
    # copy your settings
    # change user to your actual user name
    sudo systemctl stop transmission-daemon.service
    sudo cp /home/user/.config/transmission-daemon/settings.json /etc/transmission-daemon/
    sudo systemctl start transmission-daemon.service
    Last edited by santiagosnchez; March 5th, 2018 at 09:47 PM. Reason: wrong path for settings.json

  4. #14
    Join Date
    Nov 2013
    Beans
    1

    Re: transmission-daemon won't start as a service

    I solved this issue creatting this file:

    /etc/systemd/system/transmission-daemon.service.d/override.conf

    with this content:
    [Service]
    User=
    Type=
    Type=simple
    User=debian-transmission
    Group=debian-transmission

    then you must execute this in order to reload systemd config:
    $systemctl daemon-reload

    and finally you must execute:
    $systemctl start transmission-daemon.service

    After that transmission 2.93 works perfectly.

  5. #15
    Join Date
    Feb 2014
    Beans
    140

    Re: transmission-daemon won't start as a service

    Perfect, it has fixed it here for me also. Not sure I should mark the thread solved. The issue raised on the transmission GitHub page has been closed, with no work-around, but this intervention fixes the issue by saying "ignore a setting in the config file provided by the developer." Not an Ubuntu specific issue though.

  6. #16
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: transmission-daemon won't start as a service

    Quote Originally Posted by m-dw View Post
    Not an Ubuntu specific issue though.
    +1 No it's not a Ubuntu specific issue: Also affects Fedora, Arch, CentsOS Debian is all I saw so far!
    So far it seems to be a systemd permission problem. Regards
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  7. #17
    Join Date
    May 2007
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: transmission-daemon won't start as a service

    Yep. Me too.

  8. #18
    Join Date
    Aug 2017
    Beans
    1

    Re: transmission-daemon won't start as a service

    Hi,

    I have found the problem and posted the solution on github https://github.com/transmission/tran...ment-370660548.

    basically there are 3 options to solve the issue:
    1. build your own from source and do not forget to install libsystemd-dev before building.
    2. wait for the PPA maintainer to do the above and build a new version.
    3. change the type in /etc/systemd/system/transmission-daemon.service from "notify" to "simple"


    have a great day,
    Tal

  9. #19
    Join Date
    Mar 2018
    Beans
    4

    Re: transmission-daemon won't start as a service

    Quote Originally Posted by talz1979 View Post
    Hi,

    I have found the problem and posted the solution on github https://github.com/transmission/tran...ment-370660548.

    basically there are 3 options to solve the issue:
    1. build your own from source and do not forget to install libsystemd-dev before building.
    2. wait for the PPA maintainer to do the above and build a new version.
    3. change the type in /etc/systemd/system/transmission-daemon.service from "notify" to "simple"


    have a great day,
    Tal
    Thank you for taking the time to detail the possible fixes. That definitely helps! I changed the service to "simple" for now until the PPA maintainer updates the package with a fix.

  10. #20
    Join Date
    Nov 2013
    Beans
    4

    Thumbs up Re: transmission-daemon won't start as a service

    Quote Originally Posted by jfabaf2 View Post
    I solved this issue creatting this file:/etc/systemd/system/transmission-daemon.service.d/override.confwith this content:[Service]User=Type=Type=simpleUser=debian-transmissionGroup=debian-transmissionthen you must execute this in order to reload systemd config:$systemctl daemon-reloadand finally you must execute:$systemctl start transmission-daemon.serviceAfter that transmission 2.93 works perfectly.
    Thank you so much!!! This fix my problem.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •