Results 1 to 5 of 5

Thread: VICE C64 Emulator not launching

  1. #1
    Join Date
    Dec 2017
    Location
    The Oort Cloud
    Beans
    53
    Distro
    Ubuntu 18.04 Bionic Beaver

    Question VICE C64 Emulator not launching

    Hi Folks,

    I just tried downloading the VICE Commodore 64 emulator from the USC. It downloaded fine (SNAP) and it now appears in my main menu, but it cannot be launched. I tried rebooting and still nothing happens - go GUI appears, nothing. Am I missing something obvious or is there an issue?

    Thanks!

    MikeG
    Lenovo Ideapad Laptop (81CW) - Linux User #624832
    Pentium CPU 4415U (2.30GHz Quad x86 : 64bit), 4g RAM
    Intel HD Graphics 610 Kabylake GT1 (1366x768, 14" LCD)
    Western Digital 500g HDD, Ubuntu 18.04 LTS

  2. #2
    Join Date
    Apr 2005
    Location
    My dreams
    Beans
    3,529
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: VICE C64 Emulator not launching

    It isn't working here either, I get this in the terminal:
    Code:
    >>~> vice-jz.x64
    Detecting ISA HardSID boards.
    Could not open '/dev/port'.
    Bad system call (core dumped)
    Feel free to file a bug report on its github page, hopefully it will be seen.

    The version of vice in the 16.04 repos is really old, so a snap version that actually works would obviously be preferable.

  3. #3
    Join Date
    Dec 2017
    Location
    The Oort Cloud
    Beans
    53
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: VICE C64 Emulator not launching

    Thanks, I thought it might just be me because I am running Gnome-Flashback as my desktop. I'm not a member of Github, so it won't let me post a bug report.
    Lenovo Ideapad Laptop (81CW) - Linux User #624832
    Pentium CPU 4415U (2.30GHz Quad x86 : 64bit), 4g RAM
    Intel HD Graphics 610 Kabylake GT1 (1366x768, 14" LCD)
    Western Digital 500g HDD, Ubuntu 18.04 LTS

  4. #4
    Join Date
    Apr 2005
    Location
    My dreams
    Beans
    3,529
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: VICE C64 Emulator not launching

    Quote Originally Posted by galacticstone View Post
    I'm not a member of Github, so it won't let me post a bug report.
    I guess one of us could try contacting the packager directly, you wanna?

  5. #5
    Join Date
    Dec 2017
    Location
    The Oort Cloud
    Beans
    53
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: VICE C64 Emulator not launching

    I had thought about that, but I wasn't sure if that was poor protocol or not - pestering a developer via email because I can't play games. LOL.
    Lenovo Ideapad Laptop (81CW) - Linux User #624832
    Pentium CPU 4415U (2.30GHz Quad x86 : 64bit), 4g RAM
    Intel HD Graphics 610 Kabylake GT1 (1366x768, 14" LCD)
    Western Digital 500g HDD, Ubuntu 18.04 LTS

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •