Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.04

  1. #1
    Join Date
    Apr 2010
    Beans
    18

    Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.04

    I have a, to me, mysterious problem. I hope somebody can help, thanks in advance.

    I put all my output of the wireless info script in this pastebin, I hope I did it correctly: https://pastebin.com/NfMivT1k

    The problem in a nutshell: since a few weeks my wireless suddenly has bad reception most of the time

    I have a Lenovo S540 laptop. It contains a Intel Corporation Wireless-N 7260 card. It has been running fine for over a year. A few weeks ago reception has drastically reduced and became very sensitive to the distance to the wifi signal. I.e.: from my house I used to pick up 8-9 wifi networks and was able to use my own wifi throughout the house. Now I only pick up my own wifi network. Connection speed is fine when I remain within +/- 4 metres of the router. When I go further it quicky drops to zero. Important note: sometimes (about 2-5% of the time I would guess) it works fine as it used to. So it is still able to work properly, but does not do so most of the time. I have not discovered a pattern on when it works well and when it does not

    I had this before, then was able to solve it up until now by replacing the wireless card
    I have had the same / a very similar problem before. About 1.5 year ago the same happened with the Intel Corporation Wireless 7260 card that was originally in the laptop. I did not find any solution then either, so I chose to replace the card by ordering a new one. (Same type number, only the version that also supported 5G.) That one worked fine up until the current (identical) problem.

    I have tried all the diagnostics / solutions that I could think of, but no success

    1. I updated all my packages on Ubuntu 16.04.
    2. I tried to see whether it was a kernel problem: so I downgraded to a 4.8 kernel and upgraded to a 4.13 kernel (from 4.10.0.26) but neither gave improvement.
    3. I tried with a Ubuntu 17.10 live USB-stick: no improvement.
    4. I checked the card itself to see if there was a loose hardware connector: could not see one.
    5. It does not seem to be a problem in my wifi network: other devices like my phone still function the same and see all kinds of other wifi networks.


    Anyone with a suggestion?
    I would be very grateful. If you need any additional info, let me know. Thanks a lot!

  2. #2
    Join Date
    Jul 2006
    Location
    Here
    Beans
    11,175

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    have you tried restarting your router?

  3. #3
    Join Date
    Apr 2010
    Beans
    18

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    Yes, I have. It unfortunately gave no improvement. I am reasonably sure it is not a problem of my router/network specifically: the laptop with the problem can also not find the wifi of my neighbors anymore, which it could a while ago. In addition: other devices like my phone can still connect flawlessly to my own wifi and spot those of the neighbors.

  4. #4
    Join Date
    May 2014
    Location
    /home
    Beans
    6,016
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    I would disable power management on the wifi using
    Code:
    sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
    Then reboot

  5. #5
    Join Date
    Apr 2010
    Beans
    18

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    Hi Jeremy, thanks for the suggestion! I disabled the power management as you said. It has not solved the problem. I still have poor reception a large part of the time. (It feels that I do have normal reception more often after disabling power management. Say 20% of the time instead of 5%. But I am not sure, it might also be my imagination.)

    Any other suggestions? I hope there is more to try. Thanks in advance.

  6. #6
    Join Date
    Apr 2010
    Beans
    18

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    The problem has persisted in the previous week. It has gotten to a very annoying point where I am starting to consider buying a new laptop just because of this. Is there anyone with another suggestion? Or a suggestion for a another place to ask for help? Thanks a lot!

  7. #7
    Join Date
    May 2014
    Location
    /home
    Beans
    6,016
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    I would change the Network Manager settings to disable/ignore IPv6 and disable the firewall

  8. #8
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    Hi the wireless report is showing very weak signal.
    how far are you from the router ?
    Please re-seat the wireless card and verify antenna connections
    are secure and corrosion free.

    #Wireless report line..430
    Code:
    wlp4s0    Scan completed :
    
     Cell 01 - Address: <MAC 'Tommie5G' [AC1]>
    
                         Channel:100
    
                         Frequency:5.5 GHz (Channel 100)
                         Quality=33/70  Signal level=-77 dBm
    #Wireless report line..452
    Code:
    Cell 02 - Address: <MAC 'Tommie' [AC2]>                     Channel:6
                         Frequency:2.437 GHz (Channel 6)
    
                         Quality=25/70  Signal level=-85 dBm
    #Set IPv6 to Ignore..
    Code:
    sudo sed -i '/ipv6/{n;s/.*/method=ignore/}' /etc/NetworkManager/*/Tommie5G'
    sudo sed -i '/ipv6/{n;s/.*/method=ignore/}' /etc/NetworkManager/*/Tommie'
    sudo systemctl restart network-manager.service
    Thanks.
    Last edited by Hadaka; March 10th, 2018 at 12:55 AM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  9. #9
    Join Date
    Apr 2010
    Beans
    18

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    Quote Originally Posted by jeremy31 View Post
    I would change the Network Manager settings to disable/ignore IPv6 and disable the firewall
    Do you mean the per network settings? I have set IPv6 to "Ignore" for my home wifi network. I am not sure how to disable the firewall. It is greyed out in the Network Manager settings of my home wifi network. Is that enough?

    The changes do not seem to make a difference unfortunately.

  10. #10
    Join Date
    Apr 2010
    Beans
    18

    Re: Intel 7260 suddenly slowed down connection after 1+ year of fine operation on 16.

    Quote Originally Posted by Hadaka View Post
    Hi the wireless report is showing very weak signal.
    how far are you from the router ?
    Please re-seat the wireless card and verify antenna connections
    are secure and corrosion free.
    Indeed, this is exactly the problem. My wifi suddenly has much weaker signal reception then before. It only functions properly within a few meters of my router. (Or any other router in a place I visit.) Further away then a few meters or with a wall in between I totally lose reception. This has not been the case before, but it started a while ago, see my earlier replies in this thread.

    Regarding: checking the wireless card connections. I have checked, they look ok. I have not been able to completely reseat it, because one of the screws of my laptop casing did not come off properly. I will try that after removing that screw entirely. I am not sure whether that will work though: when I had a similar problem a few years back (see my earlier replies in this thread) it did not work. But I will try when I remove the screw.

    Quote Originally Posted by Hadaka View Post
    #Set IPv6 to Ignore..
    Code:
    sudo sed -i '/ipv6/{n;s/.*/method=ignore/}' /etc/NetworkManager/*/Tommie5G'
    sudo sed -i '/ipv6/{n;s/.*/method=ignore/}' /etc/NetworkManager/*/Tommie'
    sudo systemctl restart network-manager.service
    Thanks.
    I have tried this as you and Jeremy suggested, but it does not seem to make a difference. I have noticed also that the problem is not only with my home wifi network / router. It also applies to networks / routers of friends or places I visit for work. So it does not seem to be a network specific problem.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •