Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Cannot Install Pulse-Eight cec software for use with mythtv

  1. #11
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,170

    Re: Cannot Install Pulse-Eight cec software for use with mythtv

    Installed from:
    https://launchpad.net/~pulse-eight/+..._filter=xenial


    Code:
    ~$ sudo add-apt-repository ppa:pulse-eight/libcec
    
    https://github.com/Pulse-Eight/libcec
    more details available at http://libcec.pulse-eight.com/
     More info: https://launchpad.net/~pulse-eight/+archive/ubuntu/libcec
    Press [ENTER] to continue or ctrl-c to cancel adding it
    
    gpg: keyring `/tmp/tmpolm916cf/secring.gpg' created
    gpg: keyring `/tmp/tmpolm916cf/pubring.gpg' created
    gpg: requesting key 5F6EB4BE from hkp server keyserver.ubuntu.com
    gpg: /tmp/tmpolm916cf/trustdb.gpg: trustdb created
    gpg: key 5F6EB4BE: public key "Launchpad PPA for Pulse-Eight" imported
    gpg: Total number processed: 1
    gpg:               imported: 1  (RSA: 1)
    OK
    
    ~$ sudo apt-get update
                 Reading package lists... Done
    
    ~$ sudo apt install libcec
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      libcec4 libp8-platform2
    The following NEW packages will be installed:
      libcec libcec4 libp8-platform2
    0 upgraded, 3 newly installed, 0 to remove and 46 not upgraded.
    Need to get 267 kB of archives.
    After this operation, 785 kB of additional disk space will be used.
    Do you want to continue? [Y/n] 
    Get:1 http://ppa.launchpad.net/pulse-eight/libcec/ubuntu xenial/main i386 libp8-platform2 i386 2.1.0.1~xenial [20.1 kB]
    Get:2 http://ppa.launchpad.net/pulse-eight/libcec/ubuntu xenial/main i386 libcec4 i386 4.0.2.1~xenial [218 kB]
    Get:3 http://ppa.launchpad.net/pulse-eight/libcec/ubuntu xenial/main i386 libcec i386 4.0.2.1~xenial [28.1 kB]
    Fetched 267 kB in 4s (56.6 kB/s)
    debconf: unable to initialize frontend: Dialog
    debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
    debconf: falling back to frontend: Readline
    Selecting previously unselected package libp8-platform2:i386.
    (Reading database ... 170805 files and directories currently installed.)
    Preparing to unpack .../libp8-platform2_2.1.0.1~xenial_i386.deb ...
    Unpacking libp8-platform2:i386 (2.1.0.1~xenial) ...
    Selecting previously unselected package libcec4:i386.
    Preparing to unpack .../libcec4_4.0.2.1~xenial_i386.deb ...
    Unpacking libcec4:i386 (4.0.2.1~xenial) ...
    Selecting previously unselected package libcec.
    Preparing to unpack .../libcec_4.0.2.1~xenial_i386.deb ...
    Unpacking libcec (4.0.2.1~xenial) ...
    Processing triggers for libc-bin (2.23-0ubuntu10) ...
    Setting up libp8-platform2:i386 (2.1.0.1~xenial) ...
    Setting up libcec4:i386 (4.0.2.1~xenial) ...
    Setting up libcec (4.0.2.1~xenial) ...
    Processing triggers for libc-bin (2.23-0ubuntu10) ...
    
    ~$ apt policy libcec
    libcec:
      Installed: 4.0.2.1~xenial
      Candidate: 4.0.2.1~xenial
      Version table:
     *** 4.0.2.1~xenial 500
            500 http://ppa.launchpad.net/pulse-eight/libcec/ubuntu xenial/main i386 Packages
            100 /var/lib/dpkg/status
    
    ~$ apt policy libcec4
    libcec4:
      Installed: 4.0.2.1~xenial
      Candidate: 4.0.2.1~xenial
      Version table:
     *** 4.0.2.1~xenial 500
            500 http://ppa.launchpad.net/pulse-eight/libcec/ubuntu xenial/main i386 Packages
            100 /var/lib/dpkg/status
    I only have a 32bit version of 16.04 to play with, but it installed without issue. Maybe clean everything out, go back to default and try again.

  2. #12
    Join Date
    Jun 2007
    Location
    Sheffield, England
    Beans
    41
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Cannot Install Pulse-Eight cec software for use with mythtv

    Thanks for your reply cruzer001 but it is libcec-dev that has the dependency issue. I have literally just solved it though, details below. I hadn't seen your reply as it was on the next page which I hadn't noticed.

    I have been looking at buying the Pulse Eight CEC adapter for over a year but was waiting until I had rebuilt my system. That done, I bought one in January, applied the PPA, tried installing the required routines and got a dependency error - wrong version on one of the modules. Having got nowhere with this issue I started looking at the myththtv packaging on Git Hub but all it said was libcec-dev as a dependency. So I started wondering if myhthtv 0.29 would be the way to go and I googled "what version mythtv with ubuntu 18.04". Whilst it mentioned libcec-dev, it didn't mention a version, but it was listed as a hyperlink. So I clicked on it and it came up with the package details and it showed as version 4.01. I realised then that it is included in 18.04. So I searched for "what version mythtv with ubuntu 16.04" and it is version 3.01 which is lower than the one on the Pulse Eight PPA, and is available as standard. So

    1) Completely Removed the packages libcec4, cec-utils and libcec4-dev using Synaptic Package Manager
    2) Unticked the Pulse-Eight PPA on Software & Updates "Other Software" tab and exited, choosing "Reload" to update the software cache
    3) Used Synaptic Package Manager to install libcec, libcec-dev and cec-utils
    4) Rebooted and hey presto

    I haven't come across anything that says that these routines are available in xenial. Everything I've seen points to using the PPA.. Just have to delete the PPA from Software & Updates

    Thanks to all who helped with this. Other input is always useful as it provides food for thought and often helps point you in the right direction
    Last edited by PaulRSte; February 28th, 2018 at 04:56 AM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •