Results 1 to 2 of 2

Thread: AWS-CLI fails with certificate error

  1. #1
    Join Date
    Feb 2018
    Beans
    1

    AWS-CLI fails with certificate error

    Amazon CLI fails with SSL certificate error:

    aws s3 ls

    [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:777)


    I tried using different version of aws-cli and the certifi package for both python 2 and 3, however non of them work and all so far have produced the same error shown above.

    awscli/artful,artful,now 1.11.139-1 all [installed]
    python3-certifi/artful,artful,now 2017.4.17-2 all [installed,automatic]

    I also trying installing via pip and pip3

    pip3 list
    awscli (1.11.139)
    certifi (2017.4.17)

    Any pointers on how to get this working

  2. #2

    Re: AWS-CLI fails with certificate error

    Please see "aws configure" section at https://docs.aws.amazon.com/cli/late...p-welcome.html
    Windows assumes the user is an idiot.
    Linux demands proof.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •