Results 1 to 3 of 3

Thread: Ubuntu 16.04 cannot connect to Wi-Fi, Centrino Wireless-N 2200 (BGN)

  1. #1
    Join Date
    Feb 2018
    Beans
    2

    Question Ubuntu 16.04 cannot connect to Wi-Fi, Centrino Wireless-N 2200 (BGN)

    Hi,

    I have a lenovo Z580. I just erased previous windows os and installed a fresh ubuntu 16.04 LTS. But the wifi cannot connect. Can anyone help?

    network-info.txt can be found here. https://paste.ubuntu.com/=tbJKW9zvHN/

    Thanks,
    Leon

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,982
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Ubuntu 16.04 cannot connect to Wi-Fi, Centrino Wireless-N 2200 (BGN)

    You have a wireless card nightmare right here:
    SSID BSSID MODE CHAN FREQ RATE SIGNAL BARS SECURITY ACTIVE *
    Network-Invalid-2.4 <MAC 'Network-Invalid-2.4' [AC2]> Infra 1 2412 MHz 54 Mbit/s 100 ▂▄▆█ WPA2 no
    66666 <MAC '66666' [AC5]> Infra 6 2437 MHz 54 Mbit/s 100 ▂▄▆█ WPA2 no
    66666-guest <MAC '66666-guest' [AC6]> Infra 6 2437 MHz 54 Mbit/s 100 ▂▄▆█ WPA2 no
    66666-guest <MAC '66666-guest' [AC4]> Infra 6 2437 MHz 54 Mbit/s 82 ▂▄▆█ WPA2 no
    pixelspring <MAC 'pixelspring' [AC1]> Infra 1 2412 MHz 54 Mbit/s 75 ▂▄▆_ WPA1 WPA2 no
    xfinitywifi <MAC 'xfinitywifi' [AC9]> Infra 11 2462 MHz 54 Mbit/s 74 ▂▄▆_ -- no
    -- <MAC '' [AC12]> Infra 11 2462 MHz 54 Mbit/s 70 ▂▄▆_ -- no
    -- <MAC '--' [AN8]> Infra 11 2462 MHz 54 Mbit/s 69 ▂▄▆_ WPA1 WPA2 802.1X no
    Pikachu_wifi_2.4 <MAC 'Pikachu_wifi_2.4' [AC8]> Infra 11 2462 MHz 54 Mbit/s 64 ▂▄▆_ WPA2 no
    Vinu-Home-2.4 <MAC 'Vinu-Home-2.4' [AC7]> Infra 8 2447 MHz 54 Mbit/s 60 ▂▄▆_ WPA2 no
    DIRECT-4Hdchen23 <MAC 'DIRECT-4Hdchen23' [AN11]> Infra 6 2437 MHz 54 Mbit/s 57 ▂▄▆_ WPA2 no
    -- <MAC '' [AC13]> Infra 1 2412 MHz 54 Mbit/s 52 ▂▄__ -- no
    66666 <MAC '66666' [AC3]> Infra 6 2437 MHz 54 Mbit/s 32 ▂▄__ WPA2 no
    GOOGLE_plus <MAC 'GOOGLE_plus' [AC11]> Infra 11 2462 MHz 54 Mbit/s 32 ▂▄__ WPA1 WPA2 no
    GOOGLE_plus <MAC 'GOOGLE_plus' [AC17]> Infra 11 2462 MHz 54 Mbit/s 32 ▂▄__ WPA1 WPA2 no
    HP-Print-A3-Officejet Pro 8620 <MAC 'HP-Print-A3-Officejet Pro 8620' [AC10]> Infra 11 2462 MHz 54 Mbit/s 32 ▂▄__ WPA2 no
    -- <MAC '' [AC14]> Infra 8 2447 MHz 54 Mbit/s 30 ▂___ -- no
    ET <MAC 'ET' [AC15]> Infra 11 2462 MHz 54 Mbit/s 25 ▂___ WPA2 no
    GOOGLE <MAC 'GOOGLE' [AN19]> Infra 11 2462 MHz 54 Mbit/s 22 ▂___ WPA1 WPA2 no
    You have a crowded environment and several access points with the same name. I suggest that you undertake several steps. First, I recommend that your regulatory domain be set explicitly. Check yours:

    Code:
     sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:

    Code:
    sudo nano /etc/default/crda
    Change the last line to read:

    Code:
     REGDOMAIN=IS
    Proofread carefully, save and close the text editor.

    In your message log, we see:
    wlp3s0: deauthenticated from <MAC '66666' [AC5]> (Reason: 2=PREV_AUTH_NOT_VALID)
    That means, roughly, that the password you have in your system is not valid for this instance of the access point 66666. Maybe it was the password for the other 66666.

    Let's remove all the other connection information and start fresh. From the terminal:
    Code:
    sudo rm /etc/NetworkManager/system-connections/*
    The command 'rm' for remove is permanent; proofread carefully before you press Enter.

    Next, let's bind Network Manager to the strongest of the access points 66666. Please run:
    Code:
    sudo iwlist scan
    Find out the MAC address for the access point. Here is a disguised sample from my machine:
    Code:
    wlp3s0    Scan completed :
              Cell 01 - Address: 99:2B:B0:DC:45:99
                        Channel:149
                        Frequency:5.745 GHz (Channel 149)
                        Quality=58/70  Signal level=-52 dBm  
                        Encryption key:on
                        ESSID:"GBR5"
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                                  36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=000002bbe8887c1f
                        Extra: Last beacon: 740ms ago
    Now bind Network Manager to that and only that access point, like this: https://askubuntu.com/questions/4255.../425617#425617 While you are adding the details, select the Wireless Security tab and fill in the double-checked WPA2 password.

    Restart NM:
    Code:
    sudo service network-manager restart
    Any improvement? It may take a reboot.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Feb 2018
    Beans
    2

    Re: Ubuntu 16.04 cannot connect to Wi-Fi, Centrino Wireless-N 2200 (BGN)

    Tried several times, finally made it works. Thank you so much!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •