Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: MPD (Media Player Daemon) configuration - no audio

  1. #11
    Join Date
    Sep 2013
    Beans
    68

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by ivanovnegro2 View Post
    Once I had a problem setting up mpd as its own service like in your case and I had problems with the sound because mpd was not in the audio group.

    See what is in the audio group:

    Code:
    cat /etc/group | grep audio
    You can add mpd to it:

    Code:
    sudo usermod -aG audio mpd

    User "mpd" already is a member of the group "audio".

  2. #12
    Join Date
    Jan 2018
    Beans
    140

    Re: MPD (Media Player Daemon) configuration - no audio

    Do you have any error messages or terminal output when starting mpd? It could be useful.

  3. #13
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by goodstuff9 View Post
    User "mpd" already is a member of the group "audio".
    See if you can follow this: https://wiki.archlinux.org/index.php..._configuration
    I found "minidlna" to be a bit easier to setup.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  4. #14
    Join Date
    Sep 2013
    Beans
    68

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by ivanovnegro2 View Post
    Do you have any error messages or terminal output when starting mpd? It could be useful.
    Well, not sure if I'm doing this correctly......

    First in a terminal I run mpd --kill

    I can see that mpd is not running at this point.

    Then, I run mpd

    No other output appears in the terminal.

    I do see that mpd is running.

  5. #15
    Join Date
    Sep 2013
    Beans
    68

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by 1fallen View Post
    See if you can follow this: https://wiki.archlinux.org/index.php..._configuration
    I found "minidlna" to be a bit easier to setup.
    When I read through the archlinux instructions, it seemed to me that I was already following those instructions that were applicable to Ubuntu.

  6. #16
    Join Date
    Jan 2018
    Beans
    140

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by goodstuff9 View Post

    Then, I run mpd

    No other output appears in the terminal.
    Then there is no error to report.

    I think I am out because I only configure mpd to run as local user.

  7. #17
    Join Date
    Nov 2017
    Beans
    3

    Re: MPD (Media Player Daemon) configuration - no audio

    Quote Originally Posted by goodstuff9 View Post
    When I read through the archlinux instructions, it seemed to me that I was already following those instructions that were applicable to Ubuntu.
    goodstuff are you running MPD as a system service, or a user service? Following these instructions, I set MPD up as a user service and placed my mpd.conf in ~/.mpd. My audio output looks like this:
    audio_output {
    type "pulse"
    name "Pulseaudio"
    }
    I don't bind it to any address.

    On my remote client (I use ncmpcpp), I point it to the lan address of my server:
    ##### connection settings #####
    #
    mpd_host = 192.168.1.123
    #
    mpd_port = 6600
    #
    mpd_connection_timeout = 5
    MPD can be kind of tedious, but once you get everything working right, it the best player around.

  8. #18
    Join Date
    Jan 2018
    Beans
    140

    Re: MPD (Media Player Daemon) configuration - no audio

    Pvanryn posted a great link and there is this I would like to paraphrase from the Ubuntu documentation if setting up as a system service:

    Bugfix: Giving MPD proper permissions

    Unfortunately, by default MPD does not have the proper permissions to access PulseAudio, the default audio setup on most new Ubuntu systems. If MPD plays for you without these steps, then that's great, but if you can play your songs but no sound is emitted, try the following steps.
    What we need to do is add the user mpd to the groups pulse and pulse-access so that it can access the audio system.
    $ sudo usermod -aG pulse,pulse-access mpd
    MPD starts new pulseserver

    Unfortunatly MPD tries to start its own pulseaudio server. So if you still unlucky you could try:

    Code:
    audio_output {
      type    "pulse"
      name    "MPD"
      server  "localhost"   # optional
    # sink    "remote_server_sink"  # optional
    }
    Then you need to allow access. You should install paprefs


    Code:
    sudo apt-get install paprefs
    Then run it (e.g. alt+f2 and enter paperfs). Click the Network Server tab, then check the Enable network access to local sound devices box, and finally check the Don't require authentication box. At this point make sure to restart the pulseaudio daemon.


    Code:
    sudo service pulseaudio restart
    Now you should see MPD in Sound settings Application tab and hear music.

    But like Pvanryn I also recommend and use a user configuration for mpd. It is easier setting up the permissions.

  9. #19
    Join Date
    Feb 2018
    Beans
    7

    Re: MPD (Media Player Daemon) configuration - no audio

    I think the main question you have to answer is the one about which set of speakers is the sound going to be using and then depending on which computer/audio card that is associated with could influence the method of connectivity. Depends whether you want sound as mentioned in the OP to come from the same computer with mpd running, which I think would be much easier (then you are not really streaming anything and just accessing the daemon and playing music from a server).

    There is also this solution for access to the pulseaudio server (over the network)
    https://help.ubuntu.com/community/MP...ew_pulseserver

    If you haven't installed paprefs it probably would help

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •