Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: nVidia driver half-working, LUbuntu 17.10

  1. #11
    Join Date
    May 2016
    Beans
    9

    Re: nVidia driver half-working, LUbuntu 17.10

    I have the same Nvidia 960m in an MSI laptop and I use 387.26 which works perfectly for me. This is on 16.04 with the 4.10 kernel.

    By the way, kernel 4.13 kills the Nvidia optimus driver completely. I just ended up fixing it all and reverting my kernel. I've been tweeting about it @DorianDotSlash

  2. #12
    Join Date
    Jan 2018
    Beans
    13

    Re: nVidia driver half-working, LUbuntu 17.10

    root@antic-Inspiron-7559:/home/antic# ls -al /sys/bus/pci/devices/0000:00:02.0/driver
    ls: cannot access '/sys/bus/pci/devices/0000:00:02.0/driver': No such file or directory
    root@antic-Inspiron-7559:/home/antic#


    If we reach a dead-end, I'm going to try a previous release of LUbuntu.

  3. #13
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    12,806
    Distro
    Xubuntu Development Release

    Re: nVidia driver half-working, LUbuntu 17.10

    zeroth404; Hey ..

    As dorian7 advises, there are many issues currently with the latest kernels - patching for the vulnerabilities:
    https://wiki.ubuntu.com/SecurityTeam...treAndMeltdown

    Note that the nvidia drivers are affected. I worked the same issue on irc #ubuntu, last night, with resolution by installing the 390 version driver from our trusted PPA .

    Let's do the same and see what results in your case:
    Make sure secure boot is disabled in bios **
    Code:
    sudo apt update
    sudo apt full-upgrade
    reboot the machine so we are booting with any newly installed kernel.

    Now we purge the old nvidia driver. activate the PPA and install the 390 version driver:
    Code:
    sudo apt purge nvidia*
    sudo rm /etc/X11/xorg.conf
    sudo apt autoremove
    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt update
    sudo ubuntu-drivers autoinstall
    reboot once more and tell me
    all looks good now
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  4. #14
    Join Date
    Jan 2018
    Beans
    13

    Re: nVidia driver half-working, LUbuntu 17.10

    UEFI is and has been off.

    Code:
    root@antic-Inspiron-7559:/home/antic# apt full-upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
      gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 irssi
      libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37
    5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 15.3 MB/16.0 MB of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n]
    doesn't look like anything important is coming through.

  5. #15
    Join Date
    May 2016
    Beans
    9

    Re: nVidia driver half-working, LUbuntu 17.10

    Quote Originally Posted by Bashing-om View Post
    zeroth404; Hey ..

    As dorian7 advises, there are many issues currently with the latest kernels - patching for the vulnerabilities:
    https://wiki.ubuntu.com/SecurityTeam...treAndMeltdown

    Note that the nvidia drivers are affected. I worked the same issue on irc #ubuntu, last night, with resolution by installing the 390 version driver from our trusted PPA .

    .....snip.....
    Did 390 work for you? Do you have Nvidia optimus graphics? I put in the PPA and went with a newer 387.34 from 387.26 and it didn't fix my issues. I didn't want to touch 390 yet because it's very early in staging, and optimus is very picky.
    Last edited by dorian7; January 13th, 2018 at 08:51 PM. Reason: type-o

  6. #16
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    12,806
    Distro
    Xubuntu Development Release

    Re: nVidia driver half-working, LUbuntu 17.10

    @dorian7;
    Yes, in that instance installing 390 from our PPA did in fact work .. and yes was optimus - make sure there are no driver conflicts and BumbleBee is not a factor.

    @zeroth404; UEFI should be active IF you installed the operating system in EFI mode, but secure boot ( different !) should be disabled to allow the installation of additional trusted software ( nvidia) .
    continue on to the "autoinstall" and advise of results.

    maybe Yes !
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  7. #17
    Join Date
    Jan 2018
    Beans
    13

    Re: nVidia driver half-working, LUbuntu 17.10

    I tried the nvidia PPA and 390 just to see. no solution yet.

    Code:
    root@antic-Inspiron-7559:/home/antic# lsmod | grep vidia -i
    nvidia_uvm            753664  0
    nvidia_drm             40960  0
    nvidia_modeset       1089536  1 nvidia_drm
    nvidia              14311424  2 nvidia_modeset,nvidia_uvm
    drm_kms_helper        167936  2 i915,nvidia_drm
    drm                   356352  4 i915,nvidia_drm,drm_kms_helper
    ipmi_msghandler        40960  2 nvidia,ipmi_devintf
    root@antic-Inspiron-7559:/home/antic# grep EE /var/log/Xorg.0.log
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [     3.866] (EE) [drm] Failed to open DRM device for (null): -2
    [     3.867] (EE) Screen 0 deleted because of no matching config section.
    [     3.874] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    root@antic-Inspiron-7559:/home/antic# grep WW /var/log/Xorg.0.log
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [     3.787] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [     3.787] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [     3.787] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [     3.787] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [     3.787] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [     3.790] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
    [     3.866] (WW) Falling back to old probe method for modesetting
    [     3.867] (WW) Falling back to old probe method for vesa
    root@antic-Inspiron-7559:/home/antic# grep vidia -i /var/log/Xorg.0.log
    [     3.855] (II) Module glx: vendor="NVIDIA Corporation"
    [     3.856] (II) NVIDIA GLX Module  390.12  Wed Dec 20 06:08:47 PST 2017
    [     3.856] (==) Matched nvidia as autoconfigured driver 0
    [     3.856] (II) LoadModule: "nvidia"
    [     3.856] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
    [     3.860] (II) Module nvidia: vendor="NVIDIA Corporation"
    [     3.866] (II) NVIDIA dlloader X Driver  390.12  Wed Dec 20 05:44:24 PST 2017
    [     3.866] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [     3.866] (II) NOUVEAU driver for NVIDIA chipset families :
    [     3.874] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    root@antic-Inspiron-7559:/home/antic# dpkg -l | grep -i vidia
    ii  bbswitch-dkms                                 0.8-4ubuntu1                                               amd64        Interface for toggling the power on NVIDIA Optimus video cards
    ii  libcuda1-390                                  390.12-0ubuntu0~gpu17.10.2                                 amd64        NVIDIA CUDA runtime library
    rc  nvidia-384                                    384.111-0ubuntu0.17.10.1                                   amd64        NVIDIA binary driver - version 384.111
    ii  nvidia-390                                    390.12-0ubuntu0~gpu17.10.2                                 amd64        NVIDIA binary driver - version 390.12
    rc  nvidia-opencl-icd-384                         384.111-0ubuntu0.17.10.1                                   amd64        NVIDIA OpenCL ICD
    ii  nvidia-opencl-icd-390                         390.12-0ubuntu0~gpu17.10.2                                 amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                                  0.8.5                                                      amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                               390.12-0ubuntu0~gpu17.10.1                                 amd64        Tool for configuring the NVIDIA graphics driver
    root@antic-Inspiron-7559:/home/antic#
    I'm gonna try the autoinstall with this version. If that doesn't work I'll purging it, remove the PPA, and reverting to 384 and try the autoinstall again.

    I installed without UEFI, so no secure boot.

  8. #18
    Join Date
    Jan 2018
    Beans
    13

    Re: nVidia driver half-working, LUbuntu 17.10

    no difference with autoinstall 390. purged it, removed PPA, and tried autoinstall of 384

    Code:
    root@antic-Inspiron-7559:/home/antic# ubuntu-drivers autoinstall
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      libcuda1-384 nvidia-opencl-icd-384 nvidia-prime nvidia-settings
    The following NEW packages will be installed:
      libcuda1-384 nvidia-384 nvidia-opencl-icd-384 nvidia-prime nvidia-settings
    0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/84.6 MB of archives.
    After this operation, 362 MB of additional disk space will be used.
    Selecting previously unselected package nvidia-384.
    (Reading database ... 249384 files and directories currently installed.)
    Preparing to unpack .../nvidia-384_384.111-0ubuntu0.17.10.1_amd64.deb ...
    Unpacking nvidia-384 (384.111-0ubuntu0.17.10.1) ...
    Selecting previously unselected package libcuda1-384.
    Preparing to unpack .../libcuda1-384_384.111-0ubuntu0.17.10.1_amd64.deb ...
    Unpacking libcuda1-384 (384.111-0ubuntu0.17.10.1) ...
    Selecting previously unselected package nvidia-opencl-icd-384.
    Preparing to unpack .../nvidia-opencl-icd-384_384.111-0ubuntu0.17.10.1_amd64.deb ...
    Unpacking nvidia-opencl-icd-384 (384.111-0ubuntu0.17.10.1) ...
    Selecting previously unselected package nvidia-prime.
    Preparing to unpack .../nvidia-prime_0.8.5_amd64.deb ...
    Unpacking nvidia-prime (0.8.5) ...
    Selecting previously unselected package nvidia-settings.
    Preparing to unpack .../nvidia-settings_384.69-0ubuntu1_amd64.deb ...
    Unpacking nvidia-settings (384.69-0ubuntu1) ...
    Setting up nvidia-prime (0.8.5) ...
    Processing triggers for mime-support (3.60ubuntu1) ...
    Processing triggers for ureadahead (0.100.0-20) ...
    Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
    Setting up nvidia-settings (384.69-0ubuntu1) ...
    Processing triggers for libc-bin (2.26-0ubuntu2) ...
    Setting up nvidia-384 (384.111-0ubuntu0.17.10.1) ...
    update-alternatives: using /usr/lib/nvidia-384/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
    update-alternatives: using /usr/lib/nvidia-384/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf (x86_64-linux-gnu_egl_conf) in auto mode
    update-alternatives: using /usr/lib/nvidia-384/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
    update-alternatives: using /usr/lib/nvidia-384/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf (i386-linux-gnu_egl_conf) in auto mode
    update-alternatives: using /usr/share/nvidia-384/glamor.conf to provide /usr/share/X11/xorg.conf.d/glamoregl.conf (glamor_conf) in auto mode
    dpkg: error: version '-' has bad syntax: revision number is empty
    dpkg: error: version '-' has bad syntax: revision number is empty
    update-initramfs: deferring update (trigger activated)
    INFO:Enable nvidia-384
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
    Adding system user `nvidia-persistenced' (UID 114) ...
    Adding new group `nvidia-persistenced' (GID 125) ...
    Adding new user `nvidia-persistenced' (UID 114) with group `nvidia-persistenced' ...
    Not creating home directory `/'.
    Loading new nvidia-384-384.111 DKMS files...
    Building for 4.13.0-25-generic
    Building for architecture x86_64
    Building initial module for 4.13.0-25-generic
    Done.
    
    
    nvidia_384:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.13.0-25-generic/updates/dkms/
    
    
    nvidia_384_modeset.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.13.0-25-generic/updates/dkms/
    
    
    nvidia_384_drm.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.13.0-25-generic/updates/dkms/
    
    
    nvidia_384_uvm.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.13.0-25-generic/updates/dkms/
    
    
    depmod...
    
    
    DKMS: install completed.
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up nvidia-opencl-icd-384 (384.111-0ubuntu0.17.10.1) ...
    Setting up libcuda1-384 (384.111-0ubuntu0.17.10.1) ...
    Processing triggers for libc-bin (2.26-0ubuntu2) ...
    Processing triggers for initramfs-tools (0.125ubuntu12) ...
    update-initramfs: Generating /boot/initrd.img-4.13.0-25-generic
    root@antic-Inspiron-7559:/home/antic#
    rebooted, then this:
    Code:
    root@antic-Inspiron-7559:/home/antic# lsmod | grep vidia -i 
    nvidia_uvm            753664  0
    nvidia_drm             40960  0
    nvidia_modeset       1089536  1 nvidia_drm
    nvidia              14311424  2 nvidia_modeset,nvidia_uvm
    drm_kms_helper        167936  2 i915,nvidia_drm
    drm                   356352  4 i915,nvidia_drm,drm_kms_helper
    ipmi_msghandler        40960  2 nvidia,ipmi_devintf
    root@antic-Inspiron-7559:/home/antic# dpkg -l | grep vidia -i
    ii  bbswitch-dkms                                 0.8-4ubuntu1                                               amd64        Interface for toggling the power on NVIDIA Optimus video cards
    ii  libcuda1-384                                  384.111-0ubuntu0.17.10.1                                   amd64        NVIDIA CUDA runtime library
    ii  nvidia-384                                    384.111-0ubuntu0.17.10.1                                   amd64        NVIDIA binary driver - version 384.111
    ii  nvidia-opencl-icd-384                         384.111-0ubuntu0.17.10.1                                   amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                                  0.8.5                                                      amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                               384.69-0ubuntu1                                            amd64        Tool for configuring the NVIDIA graphics driver
    root@antic-Inspiron-7559:/home/antic# grep EE /var/log/Xorg.0.log
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [     3.846] (EE) [drm] Failed to open DRM device for (null): -2
    [     3.847] (EE) Screen 0 deleted because of no matching config section.
    [     3.854] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    root@antic-Inspiron-7559:/home/antic# grep WW /var/log/Xorg.0.log
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [     3.769] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [     3.769] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [     3.769] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [     3.769] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [     3.769] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [     3.772] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
    [     3.846] (WW) Falling back to old probe method for modesetting
    [     3.847] (WW) Falling back to old probe method for vesa
    root@antic-Inspiron-7559:/home/antic# grep nvidia /var/log/Xorg.0.log -i
    [     3.835] (II) Module glx: vendor="NVIDIA Corporation"
    [     3.835] (II) NVIDIA GLX Module  390.12  Wed Dec 20 06:08:47 PST 2017
    [     3.835] (==) Matched nvidia as autoconfigured driver 0
    [     3.835] (II) LoadModule: "nvidia"
    [     3.836] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
    [     3.840] (II) Module nvidia: vendor="NVIDIA Corporation"
    [     3.846] (II) NVIDIA dlloader X Driver  390.12  Wed Dec 20 05:44:24 PST 2017
    [     3.846] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [     3.846] (II) NOUVEAU driver for NVIDIA chipset families :
    [     3.854] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    root@antic-Inspiron-7559:/home/antic#

  9. #19
    Join Date
    Jan 2018
    Beans
    13

    Re: nVidia driver half-working, LUbuntu 17.10

    I'm thinking I should just install a kernel that is known to support 384.

  10. #20
    Join Date
    May 2016
    Beans
    9

    Re: nVidia driver half-working, LUbuntu 17.10

    Not sure if you'll be able to downgrade just the kernel, since 17.10 was released with kernel 4.13. You may have to install 16.04, and you can then upgrade the kernel up to at least 4.10, which does still work with Nvidia drivers up to nvidia-387.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •