Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: Grub doesn't work

  1. #21
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub doesn't work

    Do not know Mint and what versions it uses.
    But over the years I have used one grub from the current LTS to boot both older & newer Ubuntu versions.
    So I would think it would work.
    Many users re-install, but do not update MBR. The old version in MBR is looking for old install. So make sure to fully install grub.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  2. #22
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    At least, I did no harm. After the installation, I got the grub terminal. Then I did Boot-Repair. Restarted the computer and could load Ubuntu but not Mint. Code 26386694. I may need to learn to live with just Ubuntu, it is O.K. but not what I want. I do not know how to do this "Many users re-install, but do not update MBR. The old version in MBR is looking for old install. So make sure to fully install grub."
    Last edited by sheine; January 14th, 2018 at 07:42 PM.

  3. #23
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub doesn't work

    Normal install should fully update to that installs grub.
    Often if user has more than one install or more than one drive, or elects during install not it install grub to MBR, that is when issues develop.

    Best to ask on Mint forum, if issues are unique to Mint.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #24
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    I did a standard install of Mint which chose the place for grub. I assume that since I can still boot Ubuntu and the Mint grub was installed, Ubuntu was installed from this grub, otherwise the old grub from Ubuntu is still in control and where can it be. Where is MBR and how do I access it?

  5. #25
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub doesn't work

    You do not directly access MBR.
    When you install a BIOS based system, you tell it which MBR (never a partition) to install the boot loader part of grub.
    It defaults to sda which is normally the drive the BIOS defaults to to start the boot process.

    With different Linux installs, you can tell which is in MBR as that will then be first in boot menu.
    Other installs will be at bottom of grub's boot menu.

    How to restore the Ubuntu/XP/Vista/7/8/10 BIOS bootloader
    https://help.ubuntu.com/community/Re...ta/7Bootloader
    https://help.ubuntu.com/community/Gr..._Broken_System
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #26
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    I told Mint to install grub in sda. The first listed OS on starting is Ubuntu. From what you wrote, this means that Mint never installed its version of grub. How can I change this?

  7. #27
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub doesn't work

    I posted the links, but if Mint did not install its copy of grub, then Mint did not correctly install.
    One of last steps in install process is install of grub.
    Did you see any error messages during install?

    Links posted about are reinstalling grub if install is otherwise correct.
    But with Boot-Repair you have to use advanced mode, otherwise it just seems to find first install it sees and offers to reinstall that grub.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #28
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    I used advanced mode in Boot-Repair and installed the Mint grub with the warning that it might be too far out. It was. I am now back with only Ubuntu working, which is not too bad. I need to learn how to install an OS with its home folder on another partition.

  9. #29
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    Thanks to oldfred I now have a dual booting computer. I repartitioned with small primary partitions and the home folder in the extended partition. Everything went smoothly and both Mint and Ubuntu are booting.

  10. #30
    Join Date
    Jan 2005
    Beans
    158

    Re: Grub doesn't work

    Solved.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •