Results 1 to 4 of 4

Thread: Compiling linux 2.4 kernel

  1. #1
    Join Date
    Dec 2017

    Question Compiling linux 2.4 kernel

    Hello everyone!
    Now I am trying to compile Linux 2.4.32 kernel on my pc. According to readme inside the folder with the sources I should compile the kernel with gcc 2.95 (or something close to it, the max version is 4.1 I think). So the point is that I cannot even compile the gcc on my pc.

    Everything is going on VBox or on a laptop (if that matters), everytime it's a 64 bit system installed (didn't tried 32bit cuz thing it doesn't matter).
    The way I am compiling gcc is:
    linux32 ../configure --target=i386-pc-linux-gnu (here I need linux32 cuz of without it the configurator cannot get the x86 architecture)
    linux32 make OR linux32 make bootstrap (here actually I got errors)

    The errors are like "
    Makefile:1741: recipe for target collect.o failed" + "make[1]: *** [collect2.o] error 1
    " + same for 'all-gcc' OR same for 'cc1'+ 'bootstrap' if compiling through bootstrap version.

    So I hope someone has an idea how to figure that out... Maybe I am totally wrong and there is better to compile kernel another way...

    Anyways, ty for any advice!

  2. #2
    Join Date
    Jul 2008
    The Left Coast of the USA

    Re: Compiling linux 2.4 kernel


    Are you doing this as a pure learning experience, or do you plan to use that very old kernel?
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  3. #3
    Join Date
    Dec 2017
    Hello! Just for learning.

    I should notice that I googled lot's of tutors but with no success. I guess I am missing something or my way to compile the kernel is bad
    Last edited by vasa1; December 30th, 2017 at 12:40 PM. Reason: merged

  4. #4
    Join Date
    Dec 2017

    Re: Compiling linux 2.4 kernel

    For now tried out 32 bit Ubuntu 16.04 but still with no result... Still cannot compile gcc-2.95

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts