Results 1 to 2 of 2

Thread: Bluetooth Headset No Sound

  1. #1
    Join Date
    May 2012

    Bluetooth Headset No Sound

    I have been struggling with Bluetooth headsets in Linux for quite some time. Things just never work quite right. And even when they seem like they might, they stop working after some time.

    I have captured an OBS video of my current issue which is one that has seemingly plagued me across multiple Bluetooth headsets:

    My setup:
    Kernel: 4.13.0-19-generic
    My system is up to date


    1. When a Bluetooth headset is paired, and then turned off, after turning back on, it will not immediately connect. I have no choice but to go to the Bluetooth Settings and attempt to connect manually, which leads to the next issue...
    2. (Shown in video) When attempting to manually connect in the Bluetooth settings, I have to click the slider multiple times before it even attempts to connect (This has occurred on multiple Ubuntu versions and Arch Linux for me). On some Bluetooth headsets it simply won't connect (even though those headsets had already been paired) requiring me to un-pair and re-pair (often times this occurs after a reboot).
    3. (Shown in video, per se) Now, I had paired and connected the specific headset in the video above (Apple AirPods) even with the above issues, but sound would still come out fine once I got past those issues. As of two days ago, sound will no longer come out. When paired/connected to any other device (Apple and non-Apple alike), the headset works perfectly fine.

    Things I have tried:

    1. Reinstalled pulseaudio-module-bluetooth
    2. Tried script from
    3. Tried removing/re-pairing/re-connecting

    Almost every blog and podcast will now say that Bluetooth audio just works, but that is not my experience.

    Thanks for any and all help given!

  2. #2
    Join Date
    Sep 2011

    Re: Bluetooth Headset No Sound

    I see you got no answers. Did you get your problem fixed? I happen to have the same bluetooth device but different problem. Maximum volume is never good enough. It is always below my normal listening preference. Did you also encounter this, or only the no sound issue?
    As a reference I opened a thread too:

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts