Results 1 to 3 of 3

Thread: Login screen blues

  1. #1
    Join Date
    Mar 2013
    Beans
    135

    Login screen blues

    Using Ubuntu 14.04.
    2 days ago, while uninstalling a program, I accidentally deleted /usr/share/mime/packages.
    This caused compiz to segfault at libnux-graphics...
    It would prompt me with a weird login screen, all gray with a password textbox, and then it would crash and return me to login again.
    Yday i reinstalled shared-mime-info package from a terminal, and got my desktop back.
    However my login screen, remained this ugly gray screen.
    I've tried everything to change to back, overriding /usr/share/glib2.0/schemas, even tried unity-tweak, to no avail.

    1) Where is this ugliness coming from?
    2) How can I change it?

    TIA
    Nikos

  2. #2
    Join Date
    Mar 2013
    Beans
    135

    Re: Login screen blues

    Comparing processes under X and under login, they seem to point to:
    4 S gdm 4085 4082 0 80 0 - 142304 poll_s 23:45 ? 00:00:00 /usr/bin/gnome-session --autostart /usr/share/gdm/greeter/autostart
    1 S gdm 4088 1 0 80 0 - 6111 poll_s 23:45 ? 00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/gnome-session --autostart /usr/share/gdm/greeter/autostart

    -> ls /usr/share/gdm/greeter/autostart
    orca-autostart.desktop

    -> cat orca-autostart.desktop
    [Desktop Entry]
    Type=Application
    Name=Orca screen reader
    Exec=orca --disable main-window,splash-window --enable speech,braille
    NoDisplay=true
    AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-reader-enabled
    X-GNOME-AutoRestart=true
    X-Ubuntu-Gettext-Domain=gdm

    Certainly seems like this might be the cause, --disable main-window, splash-window, NoDisplay=true,
    but substituting gnome-background-panel.desktop for it in the directory, changes nothing
    At this point I'm at a loss

  3. #3
    Join Date
    Mar 2013
    Beans
    135

    Re: Login screen blues

    No help here
    But searching the web I found the solution. Seems I ended up with a broken gdm:

    From a console (<ctrl>-<alt>-F1) type:

    sudo dpkg-reconfigure lightdm

    and select lightdm from the menu

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •