Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: How can I stop Chrome asking for me to unlock the keyring?

  1. #1
    Join Date
    Oct 2017
    Beans
    11

    How can I stop Chrome asking for me to unlock the keyring?

    Every time I start Chrome, it asks me to unlock my Gnome Keyring. Not only once. I have to enter my password approx. 9 times for this message to disappear.

    Does someone have a similar problem?

    I use Chrome 62 on Ubuntu 17.10.

    Ideally I would love to get rid of this message completely!

    Thank you.
    Attached Images Attached Images
    Last edited by orschiro; November 9th, 2017 at 09:49 AM. Reason: Image Size

  2. #2
    Join Date
    Feb 2015
    Location
    Florida
    Beans
    Hidden!
    Distro
    Ubuntu Mate Development Release

    Re: How can I stop Chrome asking for me to unlock the keyring?

    You can try this fix as indicated in this thread, https://askubuntu.com/questions/7919...chrome-keyring

    I do believe you can also delete the default files for keyring in the Google Chrome folder that should get rid of the annoying pop up each time you open Chrome

  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,434
    Distro
    Ubuntu

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Switch to basic for the password store
    basic is chrome's builtin password storage, but it stores password's in plain text.
    This is why chrome defaults to using the Ubuntu keyring. They store password encrypted.

    To set it to default to use basic try this
    copy the google-chrome.desktop file from /usr/share/applications into your home folder applications folder:
    Code:
    cp /usr/share/applications/google-chrome.desktop ~/.local/share/applications
    then open gedit (you can open it dircly with the following command:
    Code:
    gedit ~/.local/share/applications/google-chrome.desktop
    in gedit Find each of the lines that begin with Exec and add --password-store=basic like so
    Code:
    Exec=/usr/bin/google-chrome-stable --password-store=basic %U
    then save and now when you launch chrome you should never be asked for your keyring.

    More on password store here:https://askubuntu.com/questions/5250...sswords-stored
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Oct 2017
    Beans
    11

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Thank you both very much!

    I will go with the solution explained by @deadflowr.

  5. #5
    Join Date
    Dec 2007
    Beans
    12,533

    Re: How can I stop Chrome asking for me to unlock the keyring?


  6. #6
    Join Date
    Oct 2017
    Beans
    11

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Thanks guys! I marked this thread as solved.

    The solution to modify the .desktop file and have it use the basic password storage works like a charm!

  7. #7
    Join Date
    Oct 2017
    Beans
    11

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Just saw that this is already extensively covered in the Arch Wiki [1].

    [1] https://wiki.archlinux.org/index.php...password_store

  8. #8
    Join Date
    Feb 2015
    Location
    Florida
    Beans
    Hidden!
    Distro
    Ubuntu Mate Development Release

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Glad to you were able to solve your issue

    Have a great day

  9. #9
    Join Date
    Oct 2017
    Beans
    11

    Re: How can I stop Chrome asking for me to unlock the keyring?

    > Have a great day

    Likewise, thank you for all your help!

  10. #10
    Join Date
    May 2010
    Beans
    1

    Re: How can I stop Chrome asking for me to unlock the keyring?

    Quote Originally Posted by orschiro View Post
    Every time I start Chrome, it asks me to unlock my Gnome Keyring. Not only once. I have to enter my password approx. 9 times for this message to disappear.

    Does someone have a similar problem?

    I use Chrome 62 on Ubuntu 17.10.

    Ideally I would love to get rid of this message completely!

    Thank you.
    In my case this problem was caused by me setting up automatic login when I did the install. When I then installed google chrome it asked me for a password for the default keyring and everytime I opened chrome I needed to enter the password. It took me a while but I finally figured out how to fix this issue correctly.

    1. Open google chrome and in settings signout of your google account. Close chrome.
    2. Disable automatic login for linux so you are required to enter your username and password when logging in.
    3. Reboot and make sure you are required to login with your username and password, if not go back and fix the issue. This will not work with auto login on.
    4. From the menu, open Passwords and Keys.
    5. Delete the default keyring.
    6. In the login keyring, delete the password for the default keyring.
    7. Reboot, signin, and then open google chrome.
    8. Go to setting and signin to chrome.

    After doing these steps, give chrome a few minutes to sync and all of your saved passwords, etc. that were stored in the default keyring should be restored into your login keyring and working correctly.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •