Results 1 to 3 of 3

Thread: 17.10 NFS GUI write issue (terminal rw fine)

  1. #1
    Join Date
    Jul 2008
    Beans
    19

    17.10 NFS GUI write issue (terminal rw fine)

    Dear all:

    I*just upgraded my ubuntu to 17.10. The process of upgrade was very smooth.

    Then, I ran into a very strange permission problem.

    I*use a synology NAS and mount nfs to that NAS regularly.

    However, after I*upgraded to 17.10, all the GUI applications only can access the mounted directory read only.

    Let me repeat this:

    all GUI applications, such as nemo / nautilus or any application that requires file access, is read-only, while my terminal can read/write without problem: rm, mv, etc.

    I suspect Ubuntu 17.10 did something differently than 17.04. but at this point i have no idea where to look for solution.

    any hint will be much appreciate.

    Because i am using a laptop, I don't put mount point at /etc/fstab. I mount it by issue a command
    sudo mount -t nfs 192.168.1.23:/volume1/download /media/user/nas/download

    this worked without issue in the past.

    no, the UID on NAS and UBUNTU are different. Ubuntu by default start UID with 1000, while synology doesn't allow me to change UID below 1024.

    Thanks in advance

  2. #2
    Join Date
    Mar 2007
    Beans
    91
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 17.10 NFS GUI write issue (terminal rw fine)

    Just saw your post; unfortunately I didn't find it when I posted the same issue yesterday. See https://ubuntuforums.org/showthread....235&p=13705851.

    I didn't really understand your point about uid. In my case, I changed my Ubuntu uid to match my network uid so no issue there.

  3. #3
    Join Date
    Oct 2005
    Beans
    8

    Re: 17.10 NFS GUI write issue (terminal rw fine)

    https://askubuntu.com/questions/1000...012455#1012455

    I reported the same issue here...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •