Results 1 to 7 of 7

Thread: No internet with Ubuntu, but internet with Windows.

  1. #1
    Join Date
    Oct 2017
    Beans
    5

    No internet with Ubuntu, but internet with Windows.

    I installed Ubuntu17 onto my Win7 laptop – connected to a LAN cable.
    Ubuntu is installed within VirtualBox.
    After install, Windows connects to the internet.
    Ubuntu does not.
    Connection is DHCP.
    This is my 3rd time installing onto same laptop.

    The network setting show I'm connected at 1000mbs.

    I actually had it connected (LAN cable) yesterday and was installing updates for Wi-Fi.
    So I know that it is possible to access the internet (wired) with this laptop/Ubuntu combo.
    But after updates installed, Ubuntu merely opened to a black screen…………

    So I uninstalled/re-installed.........and here we are.

    Thanks!

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    24,432
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: No internet with Ubuntu, but internet with Windows.

    Thread moved to Virtualisation for better support.

  3. #3
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: No internet with Ubuntu, but internet with Windows.

    Are you trying to use a bridged or NAT connection in your VM of Ubuntu?

    Assuming that your Windows host is connected there is no reason why a NAT connection should not work as far as I'm aware, as that in effect uses the Windows connection.
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  4. #4
    Join Date
    Oct 2017
    Beans
    5

    Re: No internet with Ubuntu, but internet with Windows.

    Quote Originally Posted by ajgreeny View Post
    Are you trying to use a bridged or NAT connection in your VM of Ubuntu?

    Assuming that your Windows host is connected there is no reason why a NAT connection should not work as far as I'm aware, as that in effect uses the Windows connection.
    Much Thanks for your reply!
    I'm pretty sure I've tried both.
    (Heck, I probably tried all of them!)

    And, like I'd mentioned, I WAS able to access the internet yesterday and was downloading updates.
    I don't recall changing any specific settings though.

    I was thinking of installing same (VBox & Ubuntu) onto my desktop.
    If that works (and I have connectivity) I'll see what those settings are and mimic on my laptop.

    It's been a frustrating 2 days......believe me.......

    Mike

  5. #5
    Join Date
    Oct 2017
    Beans
    5

    Re: No internet with Ubuntu, but internet with Windows.

    OK..................

    Successfully installed VirtualBox onto my 64-bit Windows 8.1 desktop.
    Tried to install Ubuntu.......no good.
    I have to enable virtualization.
    So I go into the BIOS and take care of that.

    Now I have to make sure that Hyper-V is enabled.
    But I don't have Hyper-V.
    This is Windows 8.1.........not Pro.
    So............that's that.

    This is really a pain.

    Mike
    Last edited by wildmanne39; October 13th, 2017 at 02:35 AM. Reason: Removed inappropriate language

  6. #6
    Join Date
    Oct 2017
    Beans
    5

    Re: No internet with Ubuntu, but internet with Windows.

    Found the answer!

    https://www.youtube.com/watch?v=2hEeYgE0pT0

    Thank-You, Youtube!

    Mike

    *EDITED TO ADD*

    As I didn't have Hyper-V on my desktop, I removed VirtualBox and used VMWare Player.
    That allowed me to install Ubuntu, but it did not resolve the internet access problem.
    The Youtube video resolved the internet problem.

    Mike
    Last edited by msmith40; October 13th, 2017 at 02:15 PM.

  7. #7
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: No internet with Ubuntu, but internet with Windows.

    Brilliant!
    I could not have helped with your Windows host as I no longer run Windows except as a guest in my Xubuntu host.

    Please mark as Solved from the Thread Tools menu at the top of the Thread.
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •