Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No 'at' symbol from keyboard

  1. #1
    Join Date
    Sep 2017
    Beans
    3

    No 'at' symbol from keyboard

    I cannot get my keyboard to give me the 'at' symbol. I've tried several settings - British, US etc. But all I get is " instead of the 'at' symbol. Any one have any ideas on how to fix this? TIA

  2. #2
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    9,105

    Re: No 'at' symbol from keyboard

    Well, xev and xmodmap used to be the way to reassign keys. I don't know if it still works.

  3. #3
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: No 'at' symbol from keyboard

    what does Alt Gr (the right alt) + v give you?
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    User friendly disk backup (suitable for older PCs): Redobackup Less friendly disk backup (works on new PC): Clonezilla

  4. #4
    Join Date
    Apr 2011
    Beans
    78

    Re: No 'at' symbol from keyboard

    I always have to use shift ". For some reason @ and " are switched. Should have added, I prefer it this way, it's easier for me.
    Last edited by robbie 348; September 13th, 2017 at 07:57 PM.

  5. #5
    Join Date
    Sep 2017
    Beans
    3

    Re: No 'at' symbol from keyboard

    Thanks for all the input. I'll try swapping the " and @ key trick. But I must say this is a pretty hokey way to run an operating system. I'm already having second thoughts about using the Ubuntu version of Linux. What a shame the alternatives are Win 10 and Apple. The DOS days were so much simpler and way more fun.

  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: No 'at' symbol from keyboard

    Hello!

    Yours is likely a rare problem. It is not a normal characteristic of Ubuntu, so there is no "hokey OS behavior" going on. This isn't an Ubuntu thing. If it were, the forums would be full of threads like this.

    Have you tried a different keyboard to rule out a hardware fault? Are you sure you are using the correct English locale for your keyboard?

    Cheers!
    Last edited by QIII; September 13th, 2017 at 06:03 PM.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    Sep 2017
    Beans
    3

    Re: No 'at' symbol from keyboard

    Quote Originally Posted by QIII View Post
    Hello! >Yours is likely a rare problem. It is not a normal characteristic of Ubuntu, so there is no "hokey OS behavior" going on. This isn't an Ubuntu thing. If it were, the forums would be full of threads like this. >Have you tried a different keyboard to rule out a hardware fault? Are you sure you are using the correct English locale for your keyboard? Cheers!
    Hullo and thank you for your response. I just tried the swapping " and @ keys trick and can confirm that this is what Ubuntu has done. Really this is most inconvenient, however it does mean that I can continue to explore this version of Linux but it really is hokey. I can't see myself living with this other than for a brief tryout period. My keyboard has been working just fine with Win 7 for many years and it is set for English UK in the Ubuntu system settings. This keyboard works fine in Win 7 and has done so for many years. (Including a few minutes ago where I checked the correct assignment of the keys). Yes Cheers, I appreciate you taking the time to help. You will have noted that at least one other person has the same problem with Ubuntu.
    Last edited by billydg; September 13th, 2017 at 06:27 PM.

  8. #8
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: No 'at' symbol from keyboard

    Point is: this is not characteristic of Ubuntu. A general characterization cannot be made based on two anecdotal instances. There are millions of Ubuntu users, yet we don't see an abundance of complaints about this issue here.

    There is no doubt that it is frustrating for you, but there is likely a real solution that does not involve keyboard mapping.
    Last edited by QIII; September 13th, 2017 at 06:30 PM.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  9. #9
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    9,105

    Re: No 'at' symbol from keyboard

    Anyhow, what is so hard about swapping two keys on a keyboard? Many people swap the Ctrl and CapsLock keys, or configure special characters that they need for their country or for special applications. You only need to do it once.

  10. #10
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: No 'at' symbol from keyboard

    from my experience it is really iportant what keyboard you select or what keyboard is recognised.

    there are also two things - one is keyboard (keyboard langauge and type) and one is lanugage of keyboard. hard ot explain, but basically there are two settings. so while i can have english keyboard langauge in windows 10 selected i can still use my slovenian keyboard as is. there is no @ on 2 or shift+2 here.

    i also switch keyboards sometimes on the win 7 laptop and there the layout would also switch. Y would become Z and @ is on shift+2 which makes it really difficult when searching for a specific sign. othewise i know the keyboard by heart so staring at compeltelly different letters than those being thrown on the screen doesn't really bother me.

    though sometime i would struggle with special characters. like when a game says use [ and ] to scroll throguh inventory i actually need to press Š and Đ... press Y to confirm is actually press Z for me in some apps.

    my point is you need to make sure the setup is correctly done. it's been a while, but i believe during install it recognises a keybaord and then ask the user to confirm it it is the correct one with an option of a small test field for the user to try it out.

    otherwise what keyboard model is it? i doubt it is poor hardwar4e support since keyboard method and keyboard have been arorund sicne the typewriters and various keyboard compatibility and standards were made with first Unix systems (long before DOS came on scene).
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    User friendly disk backup (suitable for older PCs): Redobackup Less friendly disk backup (works on new PC): Clonezilla

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •