Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

  1. #11
    Join Date
    Sep 2017
    Beans
    9

    Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    @mrgs Thanks. I will try to upgrade to 17.04.

  2. #12
    Join Date
    Sep 2017
    Beans
    9

    Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    I'm tired of Ubuntu's problems. With 16.04 LTS freshly installed on my PC, I was already having plenty of bugs with Linux Ubuntu. I got a suggestion to upgrade to 17.04 which they said that it contains the fixes to the bugs that 16.04 had. That's not true, I upgraded it to 17.04 and realized that it is also full of bugs. Let's start with the story.
    After upgrading 16.04 to 17.04 I reboot my PC since that was what I was asked to do by Command line interface terminal. After rebooting I see my login screen, but guess what my USB keyboard and USB mouse are not working now. So, I reboot continuously in order to solve the problem to no avail. After many tries, I pressed F6, F1, F2, F11 and Del keys when rebooting. PC shows a brief information about to press some keys in order to enter into BIOS system or UEFI or some other places where you can manage some pre-login things like the boot, etc.
    In some of those places I have encountered the list which was written, Ubuntu on the top, then Advanced Mode second and then Recovery mode, I forgot them, the list goes on. I think I entered into the Advanced mode and then into Recovery mode. There I saw some list, on it, were written some items like Network, System settings, Root or some other things, I'm sorry I don't remember exactly the names. Next, I was in the Command line interface terminal, I'm happy now to learn that my keyboard is working in the terminal. I have written some codes happily. I wrote lshw to list my hardware and there I realised that my network is Disabled. Not believing to my eyes I again typed lshw -C network, it was disabled. So, I googled my problem and I learned that I need to write touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf and reboot. After rebooting my Ethernet network, wired connection was working properly.
    Before fixing the connection, I was trying to fix my mouse and keyboard connection bugs. I typed apt update, apt upgrade and many other codes to no avail because I was not connected to the Internet, the system could not fetch some important things from the internet. Now my internet connection working I typed those codes continuously apt update, apt upgrade, --fix-missing and many other codes that I thought would be helpful for me.
    Then I reboot my PC. I entered now Ubuntu, not the Advanced mode, and I was directed to the login screen, but it was not the usual graphics screen, it was a screen like a terminal. There I entered my username and password and I was logged in, still not graphics mode.
    There I learned that I lacked the graphics may be, so I googled and wrote some codes that I think installed the graphics system. The codes as far as I remember were sudo apt dist-upgrade, sudo apt update, sudo apt upgrade, sudo apt install -y ubuntu-desktop*, sudo apt install xserver-xorg-input-all.
    After rebooting I was finally able to login to my graphical Ubuntu 17.04 where I can use my mouse, keyboard and internet connection. I'm now writing from that PC.
    Some notes: I haven't included sudo codes in the first terminal codes because I was root, you may need sudo if you are not root. I know, I have written some codes vaguely because I did not know if those codes would fix the bug or actually increase the problem more. After solving my problems I tried to remember some codes. Linux Ubuntu is full of bugs, no matter which release you use. I used this askubuntu forum and many other forums. Thanks for you, the great community. Without your help, it would have been very difficult for me. Now I'm considering to switch Arch Linux or FreeBSD. Not sure, though, how they will work for me. If I have many troubles there I think I will come back to Linux Ubuntu. I hope some knowledgeable developers fix my buggy codes above if there are any. I wanted to write this experience of mine so that some people encountering similar problems may find a helping hand here. Thank you, everybody.
    Edit on Sep 13, 2017 at 6:20 pm: See, there are many problems and bugs. I opened my command line interface terminal, it is not opening. I tried to open Vivaldi browser, same, it doesn't open, and Google Chrome doesn't open, Chromium doesn't open. I entered my System Settings -> Displays, I had to click on and tick the "Mirror Displays" checkbox. After that my CLI terminal, Google Chrome opened in Ubuntu 17.04.

    Edit on Sep 13, 2017 at 9:14 pm: This answer of mine was deleted by Thomas Ward in askubuntu.com.

  3. #13
    Join Date
    Sep 2017
    Beans
    9

    Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    Now, I'm writing from FreeBSD. Just installed it. Let's see, what happens. I wish I used Linux Ubuntu more, but there were some bugs involved.

  4. #14
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    12,754
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    I don't know who promised you that the bug was fixed in 17.04. I know that I didn't. We still don't know if it is.
    I don't know who encouraged you to upgrade. I know that I talked about a dual boot (you have probably already seen my opinion about upgrades in the link in my signature).

    Anyway, you did a fresh install and it helped. The install was FreeBSD though and not Ubuntu but congratulations with the working computer.

    We don't know if the solution was a) switching to BSD or b) to reinstall something from a clean slate. Feel free to use BSD but don't take this as a proof that Ubuntu is hopeless.
    Please help testing a new tool for hardware diagnostics.

  5. #15
    Join Date
    Sep 2017
    Beans
    9

    Thumbs up Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    Well, I know that problems persist everywhere no matter what you use. Even if I don't use Ubuntu personally now on my PC, one of my friends use it in his laptop. And I installed it in his laptop deleting the Windows. Ubuntu is good for beginners, and I was a beginner. And I want to a real geek Unix, GNU/Linux dev, admin or something like that. Any given day I was thinking of switching to some other distro that would challenge me. And this was opportunity to me to take and develop myself. Well after upgrading my Ubuntu I learned that there are some bugs and fixed them. Fixing them gave me some confidence. And about your signature, no I haven't seen that till now, and I see it now, and I haven't followed the safe way. And I'm blaming Ubuntu for that. Anyway, I'm planning to use Linux one day, by trying Arch, Gentoo, Kali and Slackware, hopefully. I know that they are very difficult to me for now, but I hope I will develop myself with the philosophy of Unix in FreeBSD. Thanks, Mrgaes.

  6. #16
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    12,754
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: Wired connection doesn't work after suspend in Ubuntu 16.04 LTS

    Good to see that you have the drive to experiment. If some of the other distros give problems we also have fora for them.
    Please help testing a new tool for hardware diagnostics.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •