Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

  1. #1
    Join Date
    Aug 2017
    Beans
    39

    Question Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Hi,

    So I installed Ubuntu 16.04LTS about 7-10 days ago and since then, when I turn the PC down, whether it's Win or Ubuntu, it takes a long time (up 2 mins and I can see errors on Win10 shutdown monitoring, but without app indication and I get unsafe shutdowns on my Ubuntu drive) until it shuts down (I see the ubuntu\win shutting down animation all this time).
    The Win10 is installed on Samsung 850 EVO (SSD) and Ubuntu is installed on Samsung 960 EVO (PCI-E NVMe), so it should be much much faster. Can you guys help me figure out why it happens and how can I fix it, please?

    Thanks in advance!

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Have you updated UEFI from vendor and firmware from Samsung?
    I had to non
    http://www.samsung.com/semiconductor...inux_64bit.zip
    http://askubuntu.com/questions/80882...msung-magician

    start to see where:
    systemd-analyze
    systemd-analyze blame
    systemd-analyze critical-chain
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Aug 2017
    Beans
    39

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Thanks for the reply!

    Well, this "Magician" (which works fine on Win10 and there it showed it has the latest firmware) doesn't even recognize the drives...

    I ran the systemd-analyze and that's the output:
    Screenshot from 2017-09-05 19-32-37.pngScreenshot from 2017-09-05 19-34-34.png

    But it shows booting times and not shutdown. Booting time is fine, atm.

  4. #4
    Join Date
    Aug 2017
    Beans
    39

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Anyone? please?

  5. #5
    Join Date
    Jan 2011
    Location
    Bournemouth UK
    Beans
    295
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    gauss-

    I have been tearing my hair out with this issue too, mine now SEEMS to be working ok. I have been tweaking this and that for days trying to sort it out. My system is similar to yours, I use a 250 EVO for win 10 and Mint 18.2 dual boot.

    There are handy tools for diagnosing slow boots, but none AFAIK for slow shutdowns.

    I have done so much tweaking I don't really know what fixed it eventually-or if it indeed is really fixed now. I trawled through many forums to get a fix, and it seems that every instance is system and hardware dependent-no two problems are the same, but the systems hang on shutdown, some forever like mine, others just take many minutes to shut down.

    Off the top of my head, things I remember trying:

    Disable usb3 legacy in bios.

    use this line for reboot..........."sudo killall mythbackend && swapoff -a && systemctl reboot" .......if you run mythtv and mysql

    try this command for shutdown as well.............."shutdown -P now"

    try this for your grub

    GRUB_DEFAULT="0"
    #GRUB_HIDDEN_TIMEOUT="0"
    GRUB_HIDDEN_TIMEOUT_QUIET="true"
    GRUB_TIMEOUT="6"
    GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
    GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
    GRUB_CMDLINE_LINUX=""


    That's all I can remember for now.

    Best of luck, Tony.

    gauss- just remebered, I disabled my swapfile as well in fstab. Modern systems with 16gb+ ram don't really need it now anyway.
    Last edited by vidtek; September 6th, 2017 at 05:44 PM. Reason: extra info & wrong command
    Asus Z270 i7 16gb ram 8.25tb GT960 TSB6205 Quad tuner 64-bit Kubuntu 19.04 Dingo & win 10 Be/FE mythtv 0.30
    Laptop Samsung NP R580 i5 nvidia linux ultimate & win 10 Homerun dual netwk tuner 55¨ Samsung ES8000

  6. #6
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Just before you shutdown can you see using top any processes still running?
    Do you have lots of foreign connections, like Internet connected backup drive that has to run or even extra flash drives or DVDs connected?
    Have you run full fsck on all Linux ext4 partitions. Should not be required, but who knows.

    Have you tried a safe forced shutdown and see if it says anything. Do not remember if anything shown if terminal open or not?

    Never force shutdown your system. Use Alt+SysRq R-E-I-S-U-B instead. (For newer laptops they don't bother adding the SysRq print to the key, but it's the same as the PrtScr key)
    Holding down Ctrl+Alt and SysRq (which is the Print Screen key) while slowly typing REISUB
    R-E-I-S-U-B to force shutdown
    A good way to remember it is, and S can be before E, but others should be in order
    Raising Skinny Elephants Is Utterly Boring ...or
    Reboot System Even If Ultimately Broken ...LOL.
    https://en.wikipedia.org/wiki/Magic_SysRq_key
    http://kember.net/articles/reisub-th...linux-restart/
    http://ubuntuforums.org/showthread.p...4#post12543274
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  7. #7
    Join Date
    Aug 2017
    Beans
    39

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Thanks for the advice!

    vidtek - what do you mean by "try this for your grub"? how\where do I change that?

    oldfred - what do you mean by "using top"?
    I do not have lots of foreign connections. No backup drives, no flash drives and no DVDs connected.
    I didn't run full fsck. Should I?
    Didn't try safe forcde shutdown. But I will and see if I get something different.
    I never forced shutdown the system, because there was no need (never froze or anything like that), is there a need to do this the REISUB way or is it possible to do it through the terminal?

    Thanks!

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Top is a terminal command to show what is running.
    top

    Htop is another versions, somewhat better, but you have to install it.
    sudo apt install htop
    htop

    control-q to quit above text screens.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #9
    Join Date
    Jan 2011
    Location
    Bournemouth UK
    Beans
    295
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    [QUOTE=gauss4563;13683843]Thanks for the advice!

    vidtek - what do you mean by "try this for your grub"? how\where do I change that?


    This is the file to edit - /etc/default/grub

    The recommended way is to do it via sudo using nano as the editor. The command would therefore be: sudo nano /etc/drfault/grub

    If you are coming from a windaz environment, the command line may be a little daunting though. You should have thunar or nautilus installed on a vanilla Ubuntu, so a more familiar way for you to edit your files
    would be to hold the alt key down while pressing the F2 key. In the box which appears type this: gksudo thunar or gksudo nautilus whichever you have installed. This will give you root (administrator) access to your file system. Then simply navigate to the file /etc/default/grub

    Before you do anything to the file, right-click on it and copy it to a safe location where you can retrieve it easily if the need arises.

    Right clicking on it should give you another menu with the option of a text editor. Choose that and edit away.

    Before doing this, try disabling your swap file, that is located in /etc/fstab (once again back it up first somewhere getatable).

    The line you want will look like this: UID=bb7bf42d-7858-4b9c-b135-a23212b43c24 none swap sw 0 0

    You will have a different number, every disc partition has a unique UUID number.

    I just re-read your original post and realise you have your windaz install on another disc. Try disconnecting that and see if your machine shuts down ok.

    Do the same in your windows system disconnect the ubuntu disc and see if that shuts down better. Always best to do the obvious stuff first!

    Cheers Tony.
    Last edited by vidtek; September 6th, 2017 at 05:29 PM. Reason: typo + another suggestion
    Asus Z270 i7 16gb ram 8.25tb GT960 TSB6205 Quad tuner 64-bit Kubuntu 19.04 Dingo & win 10 Be/FE mythtv 0.30
    Laptop Samsung NP R580 i5 nvidia linux ultimate & win 10 Homerun dual netwk tuner 55¨ Samsung ES8000

  10. #10
    Join Date
    Jan 2011
    Location
    Bournemouth UK
    Beans
    295
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Very Slow Shutdown With Dual Boot System (Win10 / Ubuntu 16.04)

    Quote Originally Posted by oldfred View Post
    Just before you shutdown can you see using top any processes still running?
    Do you have lots of foreign connections, like Internet connected backup drive that has to run or even extra flash drives or DVDs connected?
    Have you run full fsck on all Linux ext4 partitions. Should not be required, but who knows.

    Have you tried a safe forced shutdown and see if it says anything. Do not remember if anything shown if terminal open or not?

    Never force shutdown your system. Use Alt+SysRq R-E-I-S-U-B instead. (For newer laptops they don't bother adding the SysRq print to the key, but it's the same as the PrtScr key)
    Holding down Ctrl+Alt and SysRq (which is the Print Screen key) while slowly typing REISUB
    R-E-I-S-U-B to force shutdown
    A good way to remember it is, and S can be before E, but others should be in order
    Raising Skinny Elephants Is Utterly Boring ...or
    Reboot System Even If Ultimately Broken ...LOL.
    https://en.wikipedia.org/wiki/Magic_SysRq_key
    http://kember.net/articles/reisub-th...linux-restart/
    http://ubuntuforums.org/showthread.p...4#post12543274
    Oldfred-

    You have helped me in the past, something I have been meaning to ask you, I can never remember the above key sequence, I just do ctrl+alt+SysRq then hit the b key to kill everything, am I storing up problems do you think?

    Thanks, Tony.
    Asus Z270 i7 16gb ram 8.25tb GT960 TSB6205 Quad tuner 64-bit Kubuntu 19.04 Dingo & win 10 Be/FE mythtv 0.30
    Laptop Samsung NP R580 i5 nvidia linux ultimate & win 10 Homerun dual netwk tuner 55¨ Samsung ES8000

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •