Results 1 to 3 of 3

Thread: Can't boot with GRUB on Acer machine with Windows 10

  1. #1
    Join Date
    Jul 2017
    Beans
    2

    Can't boot with GRUB on Acer machine with Windows 10

    Hi, total beginner here.

    I'm trying to dual-boot Ubuntu 16.04.2 LTS on my Acer Aspire E5 with Windows 10. I finished installing Ubuntu, but cannot get GRUB to show up when restarting my machine. So far, I have not successfully booted my installed version of Ubuntu, only the temporary "Try Ubuntu" one from my USB.

    I followed these instructions: http://www.everydaylinuxuser.com/201...alongside.html

    Using EasyUEFI on Windows, I saw that Ubuntu and Windows were both in the list of boot options. I disabled Windows Boot Manager to see what would happen, and upon restarting my computer, I got the message: "Default boot device missing or boot failed". In the boot manager, there was no option to boot with Ubuntu or GRUB. (I was able to undo this after booting from the USB)

    I also went into the UEFI Firmwire settings and disabled "Secure Boot". I also looked at the "Boot priority order", and I didn't see any entry that said "Ubuntu." The top ones were "Windows Boot Manager", "HDD0", "HDD1".

    I ran Ubuntu's "boot-repair". Here is a pastebin with the output: http://paste.ubuntu.com/25039824/

    When I restart, it still goes straight to Windows. It looks like GRUB isn't being recognized by UEFI for some reason? Any help is greatly appreciated!

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't boot with GRUB on Acer machine with Windows 10

    You need to set a supervisory password and enable "trust" on the .efi boot files from inside UEFI.
    This is unique to Acer, but much better than some of the work arounds required for those that only want to boot Windows.
    Also make sure you have newest UEFI from Acer. Some older Acer threads suggested downgrading UEFI, but newer threads say newest UEFI works.
    Acer Trust Settings - details:
    https://ubuntuforums.org/showthread.php?t=2358003
    https://ubuntuforums.org/showthread....7#post13341757
    Acer E5-573G, downgrade UEFI, supervisor password & trust on Ubuntu efi boot files.
    http://askubuntu.com/questions/70691...1039248_706912
    Acer Aspire E15 will not dual boot, many details Trust settings in step 35
    http://askubuntu.com/questions/62741...-not-dual-boot
    Acer Cloudbook shows screen for selecting trust
    http://bernaerts.dyndns.org/linux/74...-cloudbook-431
    http://community.acer.com/t5/Predato...430392#U430392
    InsydeH20 setup utility
    Acer Very latest UEFI/BIOS works, downgrade not required:
    http://ubuntuforums.org/showthread.p...1#post13419141
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Jul 2017
    Beans
    2

    Re: Can't boot with GRUB on Acer machine with Windows 10

    Enabling "trust" on the .efi file worked perfectly. Thank you!!!

    For others reading, I followed step 35 here: https://askubuntu.com/questions/6274...-not-dual-boot

    I had to turn "Secure Boot" back on as well, otherwise the option "Select an UEFI file as trusted for executing" was disabled.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •