Results 1 to 5 of 5

Thread: How to start up with Bluetooth and Wi-fi disabled?

  1. #1
    Join Date
    May 2009
    Location
    Lytham St Anne's, England
    Beans
    119
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    How to start up with Bluetooth and Wi-fi disabled?

    Hi, all. I'm on 64-bit Ubuntu 16.04 LTS MATE.

    My computer has Bluetooth and Wi-fi hardware. But I want it to start up with those items disabled. How do I do this?

    Richard

  2. #2
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: How to start up with Bluetooth and Wi-fi disabled?

    You could try going to 'Sessions and Startup' and unticking Network and whatever bluetooth is enabled there. Restart and see if that works.

  3. #3
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: How to start up with Bluetooth and Wi-fi disabled?

    Hi, please post the output of...
    Code:
    lsmod
    lspci -nnk | sed -n '/Wireless/,/driver/ p'
    This will tell us what drivers are being used for Wireless and Bluetooth.
    We can blacklist the drivers and they will not start on "Startup or reboot"
    Thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  4. #4
    Join Date
    May 2009
    Location
    Lytham St Anne's, England
    Beans
    119
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: How to start up with Bluetooth and Wi-fi disabled?

    Here's the log.
    Attached Files Attached Files

  5. #5
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: How to start up with Bluetooth and Wi-fi disabled?

    Hi the command...
    Code:
    *lspci -nnk | sed -n '/Wireless/,/driver/ p'
    is one command only..the ' | ' is called a pipe and is part of the comand
    To disable your wireless and bluetooth please COPY and paste this long ONE line command.
    Code:
    echo -e "blacklist wl\nblacklist bluetooth" | sudo tee -a /etc/modprobe.d/blacklist-wl-bluetooth.conf
    * To remove the modules from the blacklist file and restore them to default use
    simply remove the blacklist file with..
    Code:
    sudo rm -rf /etc/modprobe.d/blacklist-wl-bluetooth.conf
    boot and the modules will be restored.

    Please do not post a file that has to be downloaded to view. "highlight,copy and past the file to your post'
    Thanks.
    Last edited by Hadaka; July 5th, 2017 at 05:37 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •