Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 LTS

  1. #11
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Beans
    150

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    Hi Everyone


    I did try to wake by Ubuntu server using 'WakeOnLANx2' wol client from my Windows 10 PC but it doesn't seem to wake up.

    I found the MAC address for my server computer from the output of 'ifconfig -a' command - the one with 6 sets of 2 character alpha numeric entries.


    Any suggestions to help me to get it wake up using wol?


    Best regards


    Deepak

  2. #12
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    Use ethtool on your server to check if WOL is set on the ethernet adapter:

    Code:
    sudo ethtool <nic>
    where <nic> = your ethernet device, it should show an output something like this:

    Code:
    sudo ethtool enp2s0
    [sudo] password for cariboo: 
    Settings for enp2s0:
    	Supported ports: [ TP MII ]
    	Supported link modes:   10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	Supported pause frame use: No
    	Supports auto-negotiation: Yes
    	Advertised link modes:  10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	Advertised pause frame use: Symmetric Receive-only
    	Advertised auto-negotiation: Yes
    	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
    	                                     100baseT/Half 100baseT/Full 
    	Link partner advertised pause frame use: Symmetric Receive-only
    	Link partner advertised auto-negotiation: Yes
    	Speed: 100Mb/s
    	Duplex: Full
    	Port: MII
    	PHYAD: 0
    	Transceiver: internal
    	Auto-negotiation: on
    	Supports Wake-on: pumbg
    	Wake-on: g
    	Current message level: 0x00000033 (51)
    			       drv probe ifdown ifup
    	Link detected: yes
    Note where it says:

    Code:
    Wake-on: g
    if you don't see the g then follow this wiki page here

  3. #13
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Beans
    150

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    Hi Cariboo


    I did check the output from the code "sudo ethtool enp3s0" and it did show "wake-on : g"

    But I am still not able to wake my computer. I was using Solar Wind WakeOnLAN software to do so but it doesn't seem to wake up.

    Do I need to change any settings on any system file or something?

    I will include the output fro the above command once I turn it on manually and run the command on it.

    P.S

    Here is the code and the output from it:-
    Code:
    agarwaldvk@MyHomeServer:~$ sudo ethtool enp3s0
    [sudo] password for agarwaldvk: 
    Settings for enp3s0:
    	Supported ports: [ TP MII ]
    	Supported link modes:   10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	                        1000baseT/Half 1000baseT/Full 
    	Supported pause frame use: No
    	Supports auto-negotiation: Yes
    	Advertised link modes:  10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	                        1000baseT/Full 
    	Advertised pause frame use: Symmetric Receive-only
    	Advertised auto-negotiation: Yes
    	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
    	                                     100baseT/Half 100baseT/Full 
    	Link partner advertised pause frame use: Symmetric
    	Link partner advertised auto-negotiation: Yes
    	Speed: 100Mb/s
    	Duplex: Full
    	Port: MII
    	PHYAD: 0
    	Transceiver: internal
    	Auto-negotiation: on
    	Supports Wake-on: pumbg
    	Wake-on: g
    	Current message level: 0x00000033 (51)
    			       drv probe ifdown ifup
    	Link detected: yes
    agarwaldvk@MyHomeServer:~$

    Also, I read somewhere that someone installed "tlp" on his 17.04 LTS installation and it worked after that. Do I need to install "tlp"?



    Best regards


    Deepak
    Last edited by agarwaldvk; June 23rd, 2017 at 01:05 PM.

  4. #14
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,686
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    For Wake-on-LAN you send a magic packet containing the MAC address of the NIC you want to wake up (in your case d8:50:e6:4e:71:42) to the broadcast address of the network it's on (in your case 192.168.1.255). To do this I use either wol from a Linux machine or Wake on Lan on my Android phone, depending on where I am.

    In a previous version of Ubuntu, I also needed to stop the NIC being turned off when the computer turned off. I don't know if that is still necessary. It was a long time ago, so I can't remember which file it was that I changed to do that, but I'll see if I can find out.

    EDIT: I believe that the change I made was to the halt script. I believe I changed NETDOWN=yes to NETDOWN=no in /etc/init.d/halt.
    Last edited by CatKiller; June 23rd, 2017 at 01:40 PM.
    None but ourselves can free our minds

  5. #15
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    13,293
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    There is a moral to this thread.
    Sometimes things are really easy. Sometimes, usually with less-friendly-hardware, things are harder. For many people, WoL "just works" by setting up the remote system and installing a client. Nothing more is needed. Then there are all the other situations which a full how-to attempts to cover. Of course, there are exceptions to everything and sometimes the last 1% have a hard time or skipped an earlier, required, step OR their hardware setup just isn't capable of supporting WoL. Everything in the process has to be setup AND it has to work correctly.

    * Does the OS work with suspend perfectly?
    * BIOS set for WoL?
    * OS set for WoL?
    * Network card configured for WoL?
    * Try a few different WoL clients. Sometimes sending 3 packets is needed over a few seconds.

    If all these things are done and it isn't working, start checking the log files for issues and start over. Sleeping on the issue could refresh some eyes when looking at the settings the next day too.

    Then there are some systems on which WoL never works. Nobody figures out why.

  6. #16
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Beans
    150

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    Hi CatKiller


    I did change the NETDOWN=no in both the files :-

    /etc/init.d/halt and
    /etc/default/halt


    but still nothing

    Do I need to install tlp?


    Best regards


    Deepak

  7. #17
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Beans
    150

    Re: How to set up "Wake on LAN" for my server computer running Ubuntu Desktop 16.04 L

    Hi Everyone


    I got it to work. Thanks for all the help provided. Please accept my most sincere apologies for giving the wrong information to you all in that the MAC address that I was using was incorrect - 2 of the characters got swapped.

    However, one other issue has cropped up - when I wake it up on LAN then I am not able to power it off using the Webmin interface that I normally use to turn it off (power it off) on my mobile. Any suggestions on what might be causing this. Is my setting on the two 'halt' files of 'NETDOWN=no' could be causing it?


    Best regards


    Deepak

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •