Results 1 to 7 of 7

Thread: Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

  1. #1
    Join Date
    Sep 2014
    Beans
    13

    Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

    Hello,

    I'm having trouble running scangearmp on Linux Mint 18.1 I'm using a Canon mg6320 and would like to get the scanner going. My understanding is that I have to use the scangearmp program provided by Canon.

    I've tried installing scangear (http://support-au.canon.com.au/conte...100470802.html) and scangear 2 (http://www.canon.ca/inetCA/en/servic...2&type=D&opt=1). I used alien to covert the tar to a deb and installed.

    When I type 'scangearmp' or 'scangearmp2' into the terminal, it says 'command not found'. Was hoping to check and see if anyone might have any ideas on how to get scangear working? Thank you for your time and advice.

    ~AB

  2. #2
    Join Date
    Apr 2005
    Beans
    2,336

    Re: Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

    sorry to hear of your troubles;

    so alien was to convert between rpm packages and debian I understood; so I wonder if it would carry out its job if you got it to work on a tar package; you could check what was installed with the command
    Code:
    dpkg -l scangear*
    ... you need to COPY that, and paste it into a terminal; you could tell us what the result is; if not much show, you could follow the advice below and see if it works any better

    _________

    for quite a few years now, Canon have supplied drivers in 3 formats for linux users: rpm packages; debian packages and source code. Mint uses Ubuntu; Ubuntu uses Debian so debian packages are used; so just use a debian package from canon

    for the MG6300 series drivers, I would start at the Canon Asia website http://support-asia.canon-asia.com/?personal and that takes me to here http://support-asia.canon-asia.com/c...100470702.html and you get scangearmp-mg6300series-2.00-1-deb.tar.gz

    ......... so that is a debian package ....... compressed into a tar.gz format; it is a 5yr old driver; if you were to click to download and select SAVE, it should end up in your Downloads folder; commands to install; one line at a time and hit ENTER after each paste would be:
    Code:
    cd Downloads
    Code:
    tar -zxvf scangearmp-mg6300series-2.00-1-deb.tar.gz
    Code:
    cd scangearmp-mg6300series-2.00-1-deb
    Code:
    ./install.sh
    and then to run it the command would
    Code:
    scangearmp
    and you could tell us which desktop of Mint you are using; so we can tell you about setting up a launcher; Mint has its own forums too https://forums.linuxmint.com/

    ______________________
    Incidentally, the open-source sane says it has full support for your MG6300 series device ..... if you type
    Code:
    lsusb
    in a terminal, it should give you
    Code:
    04a9:1765
    http://www.sane-project.org/sane-mfgs.html#Z-CANON so if you install xsane
    Code:
    sudo apt install xsane
    , it is a sophisticated front-end for sane ..... and it should ....... find your MG if you so wish to use another programme

  3. #3
    Join Date
    Sep 2014
    Beans
    13

    Re: Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

    Hi Pdc,

    Thanks for your advice.

    - this is the result I got from the dpkg -l command...

    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-==============-============-============-=================================
    ii scangearmp-sou 2.00-2 all Converted tgz package
    ii scangearmp2 3.20-2 all Converted tgz package

    -thanks for those instructions on installing the .deb. That worked like a charm and now I can run scangearmp.
    --In the hopes of learning a bit more, I was wondering if you might happen to have an idea why the converted packages didn't run? I'm running Linux Mint 18.1 Cinnamon. The scangear tarball from Canon Australia worked on another computer running Ubuntu Mate.

    -Also tried xsane, but got an error when it tried to connect to the MG-6320.

    Much appreciation again for your help. Glad to have this up and running.

    ~AB

  4. #4
    Join Date
    Apr 2005
    Beans
    2,336

    SOLVED: Scangearmp for Canon mg6320 now Working Well Linux Mint 18.1

    glad to hear it is all working

    I was wondering if you might happen to have an idea why the converted packages didn't run?
    ......... perhaps you run the command
    Code:
    dpkg -l scangear*
    again and we see how many versions of scangear you have installed now

    .... by the way, as you own the thread, you can go to thread tools and edit the title to say SOLVED:

  5. #5
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

    Moved to MINT.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  6. #6
    Join Date
    Apr 2005
    Beans
    2,336

    Solved: Canon mg6320

    thanks; very organised of you; I do hope Atulo can now find it here on the Mint forum!!

    The debian packages from canon seem to work for all systems that need debian packages

  7. #7
    Join Date
    Sep 2014
    Beans
    13

    Re: Scangearmp for Canon mg6320 Not Working in Linux Mint 18.1

    again and we see how many versions of scangear you have installed now
    Thank you for the advice Pdc,

    I ran the 'dpkg' command, and this is what I got...

    ||/ Name Version Architecture Description
    +++-==============-============-============-=================================
    ii scangearmp-com 2.00-1 amd64 ScanGear MP for Linux.
    ii scangearmp-mg6 2.00-1 amd64 ScanGear MP for Linux.
    ii scangearmp-sou 2.00-2 all Converted tgz package
    ii scangearmp2 3.20-2 all Converted tgz package

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •