Results 1 to 7 of 7

Thread: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

  1. #1
    Join Date
    May 2017
    Beans
    2

    Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Hi All,

    Disclaimer: I am new to the linux platform.

    Notes: Ubuntu is the only OS on the server, the boot mode is set to bios and not UEFI, the OS was installed straight after the RAID array was initialized, don't judge me for using RAID-5 this is a test box in a home lab.

    I built an Ubuntu Server using 16.04 LTS and installed KVM, Webvirtmgr and some other packages. Everything was running great for a few weeks. One night I safely powered off the server, unplugged it, relocated it and powered it on and received the following error:

    [IMG][/IMG]


    After testing all the hardware I then turned my attention to the OS. I booted via a live boot disc, ran boot-repair and was not presented with a recommended repair. The boot-repair summary can be found here https://paste2.org/Gn2tyNX3

    Could anyone please point me in the right direction as to where I could find the information that will help me resolve this issue?

    Thanks in advance!
    Last edited by obstruktion; May 19th, 2017 at 03:13 PM.

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Thread moved to Server Platforms for a better fit

  3. #3
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Please attach screen shots, not everyone has high speed Internet.
    You can easily attach with Forum's advanced editor and paperclip icon.

    Do not know RAID.

    But script did not see any drives other than disk label error on 1.2TiB sda?
    That is often related to corrupted partition table or conflicts between gpt & MBR.

    It says UEFI secure boot may be on. That has to be off for BIOS boot configuration to work.

    Are drives gpt partitioned or 35 year old MBR(msdos) partitioned?

    LVM inside partitions in addition to RAID?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #4
    Join Date
    May 2017
    Beans
    2

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Hi Oldfred,

    Thank you for your reply. My apologies for inserting the screenshot.

    The 1.2TiB sda is the RAID-5 array, it is comprised of 4x 450GB SAS drives.

    I have attached some screenshots of the BIOS config. I am unsure if the virtual disk is partitioned as gpt or mbr. I just followed the defaults when installing the OS as my goal was to start learning linux as is the same reason I was playing around with LVM.
    Attached Images Attached Images

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Someone that knows & understands hardware RAID can help.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    13,533
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    HW-RAID sorta "just works." FakeRAID (motherboard RAID) is a completely different animal.

    One of my 14.04 servers locked up last night and the boot was screwed. I booted off a live CD, at the boot menu, told it to boot off the first disk, then ran sudo update-grub. Then backed out cleanly and rebooted. All was fine.

    Using LVM over RAID is still a good idea. LVM is about flexibility. HW-RAID is about performance and HA. Those 2 together ARE a good thing.

    Looked at the boot-info.
    Doesn't look like things are working. No partitions or LVs shown on sda? Not good. This is the time when you want to have backups of everything, including the partition layout. You need to restore that, restore any LVM PEs, VGs, and LVs, then restore all the data. You've always heard that backups are a good thing. Here's your chance to use them.

    Without looking at the logs, it is impossible to guess what may have happened. I'd be paranoid about everything in the disk subsystem on the machine for the next few weeks. PERC, cables, drives - everything. If you don't already have backup religion, I'd get it. LVM is a great thing for that, thanks to LVM snapshots. Use snapshots as part of your backup procedures.
    Last edited by TheFu; May 19th, 2017 at 09:04 PM.

  7. #7
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu Server 16.04 LTS No boot device invalid mbr signature found

    Yes, I also agree that it doesn't look good when no partitions can be detected on your disk. It might have been an issue with the raid card, after you disconnected the power. Is this the first time you are unplugging the power cord lately? Could it be that your raid card is losing the config of the virtual disk when unplugged?

    If you want to, you can try detecting the partitions with something like testdisk. That tool is quite good detecting partitions, assuming they still exist and there are no major failures on the disk. If the partitions are detected correctly, testdisk can write them into new partition table.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •