Results 1 to 6 of 6

Thread: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

  1. #1
    Join Date
    May 2017
    Beans
    19

    17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

    My wifi isn't working (I can connect to my router but internet doesn't work), the logs are full of errors about lwlwifi and a microcode sw error.

    I was using ubuntu gnome and stock ubuntu 16.4 and 16.10 and everything was ok. Upgrading to 17.04 seems to have caused this error. Or so I thought.

    I reverted back to 16.10 and after an update the same problem occured.

    Is there any way to fix this? Or hw can I reprt a bug? I don't know what info is required.

    I have seen lots of peoople in google talking about wifi issues in 17.04 but none of the "fixes" fixed my problem. The only solution that works is install ubuntu 16.10 as installed by my laptop provider and turn off all updates - I doN't want to do this
    Last edited by sbdesign; May 9th, 2017 at 06:26 AM.

  2. #2
    Join Date
    May 2017
    Beans
    19

    Re: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000


  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

    Please note:
    Cell 01 - Address: <MAC 'mordor' [AC1]>
    Channel:6
    Frequency:2.437 GHz (Channel 6)
    Quality=54/70 Signal level=-56 dBm
    Encryption key:on
    ESSID:"mordor"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s
    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=0000001e59bc2da7
    Extra: Last beacon: 588ms ago
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (2) : TKIP CCMP
    Authentication Suites (1) : PSK
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (2) : TKIP CCMP
    Authentication Suites (1) : PSK
    Your device and driver combination do not like TKIP at all and neither does ole Chili. I realize that router manufacturers suggest the lowest common denominator so that when Grandma shows up with her circa-2001 laptop, she can connect. Unfortunately, all the auto modes cause the driver to struggle to keep up with a frequently changing landscape.

    Please, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

    Then set your regulatory domain explicitly. Check yours:
    Code:
    sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:
    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:
    Code:
    gksudo gedit /etc/default/crda
    Use nano or kate or leafpad if you don't have the text editor gedit.

    Change the last line to read:
    Code:
    REGDOMAIN=IS
    Proofread carefully, save and close the text editor.

    Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/...pv6-ignore.png This example is for ethernet, but you want wireless.

    If these changes do not help, please try:
    Code:
    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=8
    If it helps, make it permanent:
    Code:
    sudo -i
    echo "options iwlwifi 11n_disable=8"  >>  /etc/modprobe.d/iwlwifi.conf
    exit
    Any improvement?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  4. #4
    Join Date
    May 2017
    Beans
    19

    Re: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

    OK, thanks for the reply. I shall look through what you said. My router comes from deutsche telekom and has security set to wpa/wpa2 (which I can change) and encryption to tkip/aea - the interactive help in the router admin says that this is unchangeable.

    It was working fine with 15.04 through to 16.10 - same hardware. My laptop is not even 1 year old. Some update happens... and it breaks - this happened to 16.04 too. I can install the factory version of ubuntu 16.10 that came with the laptop and it works fine - until I let some update through and then i have this problem. It definately seems to be a software problem. I'll report back when I have gone through the rest of your reply. Thanks again

  5. #5
    Join Date
    May 2017
    Beans
    19

    Re: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

    ok... none of the things helped. I'll try a fedora live cd and see if it is the same. Otherwise I guess I shall need to go back to ubuntu 16.10 and turn off updates

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 17.04 iwlwifi: Microcode SW error detected. Restarting 0x2000000

    I suggest that you try the live session of 16.10 and see what firmware version is loading:
    Code:
    sudo lshw -C network
    Here is a sample from my machine:
    *-network
    description: Wireless interface
    product: Wireless 7260
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlp3s0
    version: 83
    serial: xx:c5:d4:0e:64:xx
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlwifi driverversion=4.10.0-20-generic firmware=17.459231.0 ip=192.168.0.120 latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:30 memory:f0400000-f0401fff
    Then compare the same information for 17.04 and, if you wish, Fedora.

    Perhaps the firmware file you have is corrupt.
    Code:
    ls -al /lib/firmware | grep 8000
    From my 17.04 machine:
    Code:
    -rw-r--r--  1 root root 1745176 Dec  1 16:24 iwlwifi-8000C-13.ucode
    -rw-r--r--  1 root root 2351636 Dec  1 16:24 iwlwifi-8000C-16.ucode
    -rw-r--r--  1 root root 2394060 Dec  9 16:17 iwlwifi-8000C-21.ucode
    -rw-r--r--  1 root root 2120860 Mar 20 14:13 iwlwifi-8000C-22.ucode
    We wonder if the size of the files matches.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •