Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

  1. #1
    Join Date
    Apr 2017
    Beans
    14

    Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Recently I installed Ubuntu 16.04 on MSI GS63VR laptop with dual boot (with Windows 10). This laptop has Killer 1535 Wi-Fi adapter (QCA6174 to be specific). I followed instructions on their official site:

    Ubuntu 16.04

    The built in drivers should work without any changes, though you may need to update your wireless firmware:

    Code:
    wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.162_all.deb
    sudo dpkg -i linux-firmware*.deb
    sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci
    One remark though - the mentioned file does not exist anymore and thus info is a bit outdated. So I checked the whole list and used the latest available version instead.

    Even Wi-Fi networks are visible, unfortunately I can't connect to my home Wi-Fi. I checked the password multiple times, it's correct for sure.

    The relevant output of:

    Code:
    sudo lshw -c network
    is:

    Code:
    description: Wireless interface
    product: QCA6174 802.11ac Wireless Network Adapter
    vendor: Qualcomm Atheros
    physical id: 0
    bus info: pci@0000:3e:00.0
    logical name: wlp62s0
    version: 32
    serial: **:**:**:**:**:**
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ath10k_pci driverversion=4.8.0-36-generic firmware=WLAN.RM.2.0-00180-QCARMSWPZ-1 ip=***.***.**.* latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:132 memory:df200000-df3fffff
    The output of:

    Code:
    dmesg | grep ath10k
    is:

    Code:
    [    3.086898] ath10k_pci ****:**:**.*: enabling device (0000 -> 0002)
    [    3.087198] ath10k_pci ****:**:**.*: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
    [    3.372179] ath10k_pci ****:**:**.*: Direct firmware load for ath10k/pre-cal-pci-****:**:**.*.bin failed with error -2
    [    3.372184] ath10k_pci ****:**:**.*: Direct firmware load for ath10k/cal-pci-****:**:**.*.bin failed with error -2
    [    3.372360] ath10k_pci ****:**:**.*: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
    [    3.372361] ath10k_pci ****:**:**.*: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
    [    3.373277] ath10k_pci ****:**:**.*: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
    [    3.373277] ath10k_pci ****:**:**.*: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
    [    3.373623] ath10k_pci ****:**:**.*: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
    [    3.436610] ath10k_pci ****:**:**.*: board_file api 2 bmi_id N/A crc32 8c15898f
    [    5.561030] ath10k_pci ****:**:**.*: htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
    [    5.656429] ath10k_pci ****:**:**.* wlp62s0: renamed from wlan0
    The strange thing is that I can connect to my Android hotspot set on smartphone. Also other devices at home can connect to this Wi-Fi without any problems, and it works fine on Windows 10 on the same laptop. So I'm forced to use Android hotspot as a temporary workaround now.

    Here is the log of connection to Android hotspot:

    Code:
    [  107.007374] wlp62s0: authenticate with **:**:**:**:**:**
    [  107.057897] wlp62s0: send auth to **:**:**:**:**:** (try 1/3)
    [  107.059728] wlp62s0: authenticated
    [  107.061296] wlp62s0: associate with **:**:**:**:**:** (try 1/3)
    [  107.064661] wlp62s0: RX AssocResp from **:**:**:**:**:** (capab=0x411 status=0 aid=1)
    [  107.067985] wlp62s0: associated
    [  107.068042] IPv6: ADDRCONF(NETDEV_CHANGE): wlp62s0: link becomes ready
    And here is the log of connection to home Wi-Fi:

    Code:
    [  101.628172] wlp62s0: authenticate with **:**:**:**:**:**
    [  101.674946] wlp62s0: send auth to **:**:**:**:**:** (try 1/3)
    [  101.679850] wlp62s0: send auth to **:**:**:**:**:** (try 2/3)
    [  101.684955] wlp62s0: send auth to **:**:**:**:**:** (try 3/3)
    [  101.690259] wlp62s0: authentication with **:**:**:**:**:** timed out
    [  102.308700] IPv6: ADDRCONF(NETDEV_UP): wlp62s0: link is not ready
    I used:

    Code:
    dmesg | grep wlp62s0
    command to retrieve this information.

    Important note: Before posting this I searched a lot and tried what is suggested in similar questions. None of those advices worked for me.
    Many of them recommend to replace firmware files from kvalo/ath10k-firmware repo so I decided to give it a try too:

    Code:
    cd ~/programs/
    git clone https://github.com/kvalo/ath10k-firmware.git
    sudo rm -rf /lib/firmware/ath10k/QCA6174/
    sudo cp -r ath10k-firmware/QCA6174 /lib/firmware/ath10k/
    cd /lib/firmware/ath10k/QCA6174/hw2.1/
    sudo mv firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1 firmware-5.bin
    cd ../hw3.0
    sudo mv firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1 firmware-4.bin
    sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci
    reboot
    Unfortunately this did not help too.

    Important note: At some point of trial and error I managed to connect to home Wi-Fi but noticed a huge packet loss and bad connection speed. Then I was unable to load web pages at all. Currently I can't connect to home network at all.
    Any help and advices is appreciated. If you need more info, please let me know.

  2. #2
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Update 1: I disabled IPv6 using this method. Now these kind of errors - "IPv6: ADDRCONF(NETDEV_UP): wlp62s0: link is not ready" are gone, but authentication is still timing out:

    Code:
    [   93.019254] wlp62s0: authenticate with **:**:**:**:**:**
    [   93.065501] wlp62s0: send auth to **:**:**:**:**:** (try 1/3)
    [   93.070345] wlp62s0: send auth to **:**:**:**:**:** (try 2/3)
    [   93.075515] wlp62s0: send auth to **:**:**:**:**:** (try 3/3)
    [   93.083312] wlp62s0: authentication with **:**:**:**:**:** timed out
    Last edited by arogachev; April 16th, 2017 at 06:26 PM.

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    26,047
    Distro
    Ubuntu Development Release

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Let's have a look at:
    Code:
    sudo iwlist scan
    Just show us your home wifi, not all the neighbors. Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, B.Sc., M.Sc., M.A., Ph.D., Sc.D.

  4. #4
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    chili555, thanks for the reply. The output of
    Code:
    sudo iwlist scan
    is:

    Code:
    Cell 03 - Address: **:**:**:**:**:**
    
    Channel:3
    Frequency:2.422 GHz (Channel 3)
    Quality=33/70  Signal level=-77 dBm  
    Encryption key:on
    ESSID:"home"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s
    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=00000148c514fb6e
    Extra: Last beacon: 6408ms ago
    IE: Unknown: 000869646E65742D3134
    IE: Unknown: 010882840B160C121824
    IE: Unknown: 030103
    IE: Unknown: 050401020000
    IE: Unknown: 2A0100
    IE: Unknown: 32043048606C
    IE: Unknown: 2D1A2C181EFFFF000000000000000000000000000000000000000000
    IE: Unknown: 3D1603000000000000000000000000000000000000000000
    IE: WPA Version 1
        Group Cipher : CCMP
        Pairwise Ciphers (1) : CCMP
        Authentication Suites (1) : PSK
    IE: IEEE 802.11i/WPA2 Version 1
        Group Cipher : CCMP
        Pairwise Ciphers (1) : CCMP
        Authentication Suites (1) : PSK
    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
    IE: Unknown: DD1E00904C332C181EFFFF000000000000000000000000000000000000000000
    IE: Unknown: DD1A00904C3403000000000000000000000000000000000000000000
    IE: Unknown: DD0600E04C020160
    IE: Unknown: DD0E0050F204104A0001101044000102
    Last edited by arogachev; April 16th, 2017 at 06:02 PM.

  5. #5
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Update 2: I also asked this question on Ask Ubuntu and got advice by Jeremy31. I changed power management settings as suggested by Jeremy31 in this answer. Now sometimes the process goes a bit further:

    Code:
    [   76.352810] wlp62s0: authenticate with **:**:**:**:**:**
    [   76.400120] wlp62s0: send auth to **:**:**:**:**:** (try 1/3) 
    [   76.405250] wlp62s0: authenticated
    [   76.407644] wlp62s0: associate **:**:**:**:**:** (try 1/3) 
    [   76.418128] wlp62s0: RX AssocResp from **:**:**:**:**:** (capab=0x431 status=0 aid=2)
    [   76.421150] wlp62s0: associated 
    [  122.364346] wlp62s0: deauthenticating **:**:**:**:**:** by local choice (Reason: 3=DEAUTH_LEAVING)
    In other cases I get timeout like in Update 1.

  6. #6
    Join Date
    May 2014
    Location
    /home
    Beans
    10,963
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Post results for
    Code:
    iwconfig; iw reg get

  7. #7
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    jeremy 31, the result of:

    Code:
    ifconfig; iw reg get
    - when Wi-Fi is disconnected or when I'm trying to connect to home Wi-Fi:

    Code:
    enp61s0    no wireless extensions.
    
    lo    no wireless extensions.
    
    wlp62s0    IEEE 802.11  ESSID:off/any  
        Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
        Retry short limit:7   RTS thr:off   Fragment thr:off
        Power Management:off
              
    country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
        (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
        (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)
    - when I'm connected to Android Access Point:

    Code:
    enp61s0    no wireless extensions.
    
    lo    no wireless extensions.
    
    wlp62s0    IEEE 802.11  ESSID:"AndroidAP"  
        Mode:Managed  Frequency:2.462 GHz  Access Point: C0:BD:D1:EF:13:69   
        Bit Rate=1 Mb/s   Tx-Power=20 dBm   
        Retry short limit:7   RTS thr:off   Fragment thr:off
        Power Management:off
        Link Quality=67/70  Signal level=-43 dBm  
        Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
        Tx excessive retries:0  Invalid misc:16   Missed beacon:0
    
    country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
        (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
        (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)
    I guess it's somehow related with unspecified country?
    Last edited by arogachev; April 19th, 2017 at 08:21 AM.

  8. #8
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Update 3: Followed Jeremy's advice in comments for Ask Ubuntu question:

    Your post on UF shows that WPA and WPA2 are enabled on the router, can you disable WPA and leave just WPA2 encryption.
    After leaving just WPA2 encryption I was able to connect to home Wi-Fi once, but noticed pretty big packet loss and delays during ping. Then again authentication started to time out.

    Update 4:
    I set wireless regulatory domain to my country code (KZ, stands for Kazakhstan) as advised in this topic:

    Code:
    sudo iw reg set KZ
    Also I modified "/etc/default/crda" file to contain "REGDOMAIN=KZ" setting (default was empty).

    Again, was able to connect couple of times, but with big packet loss and delays during ping.

    Update 5:
    Another Jeremy's advice in comments for Ask Ubuntu question was:

    also try moving closer to the access point
    I came closely to the router and was surprised. As soon as I opened up the laptop's lid and entered password to unlock system, I was instantly connected to my home Wi-Fi. Then I started to testing connection quality and speed and it was good - small response rates, almost no packet loss.

    Once I came back to my room, results remained good for small amount of time and then again, big packet loss and delays and I even was disconnected.

    Then again, authentication was timing out and I was not able to connect again. And I noticed one thing that when I can connect, connection initially can be pretty good (first minute for example) then getting worse and worse.

    Now I'm not able to connect again.

    So, bottom line is:

    - Connection works good if I move laptop closer to the router. That means I have the option of moving router to other room. But, at the same time, I have the same ping results on the same laptop from the same distance using Windows, so I'm still thinking it's Ubuntu specific problem or drivers / router settings specific to Ubuntu. Also other devices such as my smartphone can connect to this network without any problems with the same distance.

    I'm confused a little bit.

    Update 6: Just for testing purposes I grabbed the laptop and came to doorway (about 1 meter closer to router). I was able to connect and connection was pretty good at this point. Once I came back to working table, connection became way worse. But again on Windows it works fine while laptop is placed on the working table.
    Last edited by arogachev; April 17th, 2017 at 04:05 PM.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    26,047
    Distro
    Ubuntu Development Release

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    Cell 03 - Address: **:**:**:**:**:**

    Channel:3
    Frequency:2.422 GHz (Channel 3)
    Quality=33/70 Signal level=-77 dBm
    Encryption key:on
    ESSID:"home"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s
    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    I came closely to the router and was surprised. As soon as I opened up the laptop's lid and entered password to unlock system, I was instantly connected to my home Wi-Fi. Then I started to testing connection quality and speed and it was good - small response rates, almost no packet loss.
    This suggests a few possibilities. First, and this may be a bit remote, is that one of the antenna wires is not securely attached to the wireless card. Can you check?

    The second is that the router may need to be rearranged to get a bit more range. Can it be on a higher shelf? A lower shelf? Are there obstructions that may be removed? Is reception improved if the router sits vertically rather than horizontally? Are there antennae that can be rearranged?

    Next, channel 3 is a rather unusual choice. If you selected it, I recommend a channel with less overlap; ideally 1, 6 or 11. http://www.metageek.com/training/res...ls-1-6-11.html If channel 3 was chosen by the router by auto channel selection then, again, I recommend a fixed channel, either 1, 6 or 11. You can get an idea of the congestion in your area with:
    Code:
    sudo nmcli dev wifi list
    Here is a sample from my machine:
    Code:
    *  SSID        MODE   CHAN  RATE       SIGNAL  BARS  SECURITY  
       GBR1        Infra  6     54 Mbit/s  79      ▂▄▆_  WPA2      
    *  GBR5        Infra  149   54 Mbit/s  67      ▂▄▆_  WPA2      
       nx2.4       Infra  6     54 Mbit/s  55      ▂▄__  WPA1 WPA2 
       MAHB Wi-Fi  Infra  11    54 Mbit/s  39      ▂▄__  WPA2      
       MAHB Wi-Fi  Infra  11    54 Mbit/s  30      ▂___  WPA2      
       MAHB Wi-Fi  Infra  11    54 Mbit/s  27      ▂___  WPA2
    Please notice that nobody uses channel 1. That's what I'd select if I were starting over.

    Finally, your router may have a setting to increase transmission power: https://www.howtogeek.com/wp-content...3/tx-power.png If so, please try increasing it in gentle steps. Increasing it to the maximum may stress the wireless radio in the router and shorten its life. I believe that one or two small steps may be fine.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, B.Sc., M.Sc., M.A., Ph.D., Sc.D.

  10. #10
    Join Date
    Apr 2017
    Beans
    14

    Re: Ubuntu 16.04 - Can't connect to home Wi-Fi with Killer 1535 (QCA6174)

    First, and this may be a bit remote, is that one of the antenna wires is not securely attached to the wireless card. Can you check?
    There are no problems with antennas on router. If you mean laptop's wi-fi card, unfortunately I can't disassemble it to verify that. But if it's fine on Windows, I don't think this is the issue.

    The second is that the router may need to be rearranged to get a bit more range. Can it be on a higher shelf? A lower shelf? Are there obstructions that may be removed? Is reception improved if the router sits vertically rather than horizontally? Are there antennae that can be rearranged?
    Router was given for free and set by provider employees (it's mounted on the wall, about meter and a half from the floor). Optical fiber is used for connection and it has fixed length so I can't move it anywhere without making request to provider. Such service is paid and I'm considering this option as a last resort only.

    The router model is ECI B-FOCuS 0-4G2PWM. There is almost no info and mentions of it in internet.

    Next, channel 3 is a rather unusual choice. If you selected it, I recommend a channel with less overlap; ideally 1, 6 or 11. http://www.metageek.com/training/res...ls-1-6-11.html If channel 3 was chosen by the router by auto channel selection then, again, I recommend a fixed channel, either 1, 6 or 11. You can get an idea of the congestion in your area with:
    The channel is set to "auto" in router settings so that's why channel 3 was selected. I tried changing it to fixed (1, 6, 11), this did not help much. Now I set it back to "auto" and it's on channel 1. I noticed signal strength is a bit improved after that.

    Finally, your router may have a setting to increase transmission power: https://www.howtogeek.com/wp-content...3/tx-power.png If so, please try increasing it in gentle steps. Increasing it to the maximum may stress the wireless radio in the router and shorten its life. I believe that one or two small steps may be fine.
    There are only 2 options in "Channel bandwidth" - 20 MHz and 40MHz (no mixed mode). The value was 20 MHz. I tried changing it to 40 MHz and connection became even worse. Another related option is set to 100% (forgot exact name, sorry).

    Update 7:
    I contacted provider support, they recommended to manually set address, network, gateway and DNS in connection properties and try to change router settings (mode, fixed channel for example). Default mode is "auto (b / g / n)" Tried to change to "b /g". That didn't help.

    Again, in Windows 10 I have no problems with Wi-Fi from the same exact spot, so I still believe it has something to do with Ubuntu specific settings or drivers.
    Last edited by arogachev; April 19th, 2017 at 08:51 AM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •