Results 1 to 5 of 5

Thread: Wifi Signal is very weak with Realtek RTL8723BE

  1. #1
    Join Date
    Mar 2017
    Beans
    1

    Wifi Signal is very weak with Realtek RTL8723BE

    Hello everyone,
    Please help, I finished installing Ubuntu 16.04 in my HP laptop that has Realtek RTL8723BE, but the wifi signal is very weak, I have to sit next to the modem to have decent sign, what shoul I do to solve this.
    Please help me
    Thanks

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    5,903
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Wifi Signal is very weak with Realtek RTL8723BE

    Thread moved to Networking & Wireless.
    Let's see if changing the ant_sel parameter makes an improvement
    Code:
    iwlist scan | egrep -i 'ssid|quality'
    That will show the Access Points and the reception, then we will unload the module and try the first parameter option
    Code:
    sudo modprobe -r rtl8723be
    Code:
    sudo modprobe rtl8723be ant_sel=1
    Code:
    iwlist scan | egrep -i 'ssid|quality'
    The results from the scan may be the same as original or better but we will check the last option for ant_sel

    Code:
    sudo modprobe -r rtl8723be
    Code:
    sudo modprobe rtl8723be ant_sel=2
    Code:
    iwlist scan | egrep -i 'ssid|quality'
    If ant_sel=1 was the best then do
    Code:
    echo "options rtl8723be ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723-ant-sel.conf
    If ant_sel=2 was the better option
    Code:
    echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723-ant-sel.conf

  3. #3
    Join Date
    Apr 2017
    Beans
    1

    Re: Wifi Signal is very weak with Realtek RTL8723BE

    The solution is spot on needed ant 1 and it must have been on ant 0 or ant 2 because signal was so weak. Have a HP Pavilion 15 with the RTL8723be. Thanks

  4. #4
    Join Date
    Apr 2017
    Beans
    2

    Wink Re: Wifi Signal is very weak with Realtek RTL8723BE

    1- install new module for realtek wifi cards where they solved the constant disconnects
    -install required packages
    sudo apt-get install build-essential git


    -git clone new realtek wifi modules
    git clone https://github.com/lwfinger/rtlwifi_new/


    -enter the directory
    cd rtlwifi_new


    -build it
    make


    -install
    sudo make install


    Now you can reboot or unload/load modules
    -unload modules
    sudo modprobe -r rtl8723be


    -load new module
    sudo modprobe rtl8723be


    2- firmware update.


    Download rtl8723befw.bin, copy it to /lib/firmware/rtlwifi/ and then reboot your laptop.
    -Disable the sleep feature of the driver:
    $ echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf


    3- Antena Test
    iwlist scan | egrep -i 'ssid|quality'


    sudo modprobe -r rtl8723be


    Check antena 1
    sudo modprobe rtl8723be ant_sel=1


    iwlist scan | egrep -i 'ssid|quality'


    sudo modprobe -r rtl8723be


    check antena 2
    sudo modprobe rtl8723be ant_sel=2


    iwlist scan | egrep -i 'ssid|quality'


    If ant_sel=1 was the best then do
    echo "options rtl8723be ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723-ant-sel.conf


    4- Also, I recommend that your regulatory domain be set explicitly. Check yours:


    sudo iw reg get


    -Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
    Mine is IN


    sudo iw reg set IN


    -To set it permanant
    gksudo gedit /etc/default/crda
    REGDOMAIN=IN

  5. #5
    Join Date
    Jun 2017
    Beans
    1

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •