Results 1 to 7 of 7

Thread: Server without GUI Not Booting

  1. #1
    Join Date
    Mar 2017
    Beans
    3

    Server without GUI Not Booting

    Ubuntu 16.04 LTS as a hyper-v VM guest. The server VM did not get shutdown cleanly and now will not boot at all. After connecting to the VM using hyper-v manager and starting the ubuntu VM, the screen stays black. I have restarted the physical server and the VM multiple times. Is there a keystone to boot ubuntu server in safe mode or to see the console logs? Without 1 of these, not sure how to get this VM up and running. Secure boot is NOT enabled. Never see GRUB....
    Last edited by f0rgiven; March 20th, 2017 at 09:58 PM.

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    12,893
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Server without GUI Not Booting

    Boot from alternate media, run fsck on each of the partitions (don't bother with swap).
    Try to reboot. If it doesn't work, report back here and I'll have more steps. Please be exact on the results. EXACT.

  3. #3
    Join Date
    Mar 2017
    Beans
    3

    Re: Server without GUI Not Booting

    I booted from the boot-repair iso and that did not even boot. Yes, I made the iso the first boot device. So then I booted from the ubuntu installation media. Walked through recover a broken system and ran fsck /dev/sda2. Came back as clean. Sda2 is NOT the EFI partition or the swap partition.

  4. #4
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    12,893
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Server without GUI Not Booting

    What about sda1 and sda3, 4, 5, 6, 7?

    Anyway, seems that grub was corrupted. Boot from alternate media, request to rescue the system, pick the correct / partition to mount as root. Then run grub-install /dev/sda followed by update-grub.

    If you have UEFI, I don't know what you need to do or if those commands will work. No UEFI used here. Sorry. There is an Ubuntu UEFI page somewhere that might help.

    You can review the prior boot-log files from this shell too.
    Last edited by TheFu; March 21st, 2017 at 04:48 AM.

  5. #5
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Server without GUI Not Booting

    Thread moved to Virtualisation.
    Forum DOs and DON'Ts
    Please use CODE tags
    Including your email address in a post is not recommended
    My Blog

  6. #6
    Join Date
    Mar 2017
    Beans
    3

    Re: Server without GUI Not Booting

    Sda1 is the "system/EFI" partition. Sda2 is "/" install. Sda3 is swap. I assume grub is installed by default on the "/" partition? This is UEFI. Given it is UEFI, should I even attempt grub-install /dev/sda followed by update-grub?

  7. #7
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    12,893
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Server without GUI Not Booting

    https://help.ubuntu.com/community/UEFI - but if you are running inside a VM, don't use UEFI. Use BIOS. The good stuff about UEFI is related to real hardware, not virtual hardware.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •