Results 1 to 8 of 8

Thread: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

  1. #1
    Join Date
    Mar 2017
    Beans
    4

    Question No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    Hello!

    I've been struggling for several days with this issue. According to many posts the HP Spectre x360 works great with 16.10 and it does but this is the only problem i have (although a big one). Plugging in the headphones make speakers mute (ok) but no sound ever comes out from the headphones. I have Dual Boot with Windows 10 with Fast Startup disabled and headphone works ok in Windows (last Realtek drivers installed) so hardware problem is discarded.

    Some more info
    • The laptop detects when the jack is connected and disables speakers. I can "see the sound" in headphones section with pavucontrol and all seems right with alsamixer, no muted stuff
    • Tried changes with hdaJackRetask, alsa-base.conf and alsa-mixer/paths/analog-output-headphones.conf but just trying my luck with those since it's not clear what should i change
    • I also tried reinstalling alsa and pulseaudio


    My alsa info http://www.alsa-project.org/db/?f=2b...7cd776c87009c6

    Any clues on this? I'm totally lost...

    Thanks everyione!

  2. #2
    Join Date
    Mar 2017
    Beans
    2

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    I had exactly the same problem with my Spectre x360. It got already frustrating until I found a suggestion here to add to /etc/modprobe.d/alsa-base.conf the following line
    Code:
    options snd-hda-intel model=auto
    restarted the machine, and now the headphones work fine.
    Last edited by davidquantum; March 5th, 2017 at 02:17 AM.

  3. #3
    Join Date
    Mar 2017
    Beans
    4

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    Thanks for the suggestion, that was one of the first things i tried. I even tried with model=laptop, hp or generic

    I tried it again now restarting too but no luck, we must have different Spectre models i guess...

  4. #4
    Join Date
    Mar 2017
    Beans
    2

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    You probably already have already done it, but just in case, I had to do those steps first as well: http://askubuntu.com/questions/71623...p-spectre-x360

  5. #5
    Join Date
    Mar 2008
    Location
    Waterloo, ON, Canada
    Beans
    13
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    Nothing to contribute to the solution, but just wanted to let the OP know they are not crazy: I have basically exactly the same setup (13-w030ca, ubuntu 16.10, windows dual boot with hardware working in windows) and the mentioned candidate solutions do not work for me either. Pllugging headphones in turns off speakers, but nothing comes through headphones. (same problem in kernels 4.8 and 4.10, however 4.10 gets auto-rotation working)

  6. #6
    Join Date
    Mar 2017
    Beans
    4

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    Thanks again davidquantum and pantherattack,

    I also read about the grub config but didn't want to mess around with grub since that solution mentioned a different sound card and Spectre model. Did you try that too, pantherattack?

    It really seems a problem with this later model... i couldn't care less about auto-rotation but i need music to program!

  7. #7
    Join Date
    Mar 2017
    Beans
    4

    Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    Has anyone tried some bluetooth headphones? That'd be another option but not sure if this model will have problems too!

    EDIT> BT headphones work ok.
    Last edited by destevez; March 9th, 2017 at 08:08 PM.

  8. #8
    Join Date
    Jun 2017
    Beans
    1

    Unhappy Re: No headphone sound in HP Spectre x360 13-w030ca Ubuntu 16.10

    So did anyone find a fix? I can't even use bluetooth earphones since my bluetooth doesn't work either :/ I'm still on kernel 4.8.6

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •