Results 1 to 3 of 3

Thread: Xsane "Failed to open device" on 64 bit ubuntu 16.10, but sane-utils work.

  1. #1
    Join Date
    Apr 2007
    Beans
    35

    Xsane "Failed to open device" on 64 bit ubuntu 16.10, but sane-utils work.

    I recently migrated to ubuntu 64 bit and everything is working fine except xsane. In xsane I'm getting the "Failed to open device`pixma:MX530_192.168.2.113`: Invalid argument." error. However, sane-find-scanner scanimage seem to work fine. Also, the Canon scangearmp tool works fine.

    This used to work on the 32bit version.

    I have a suspicion there is something wrong with the 64 bit installation of xsane. When I do a which on scanimage it shows as a 32bit executable whereas xsane is 64 bit. I've tried uninstalling and reinstalling but with the same results.
    Last edited by axe87; March 1st, 2017 at 02:26 PM.

  2. #2
    Join Date
    Apr 2007
    Beans
    35

    Re: Xsane "Failed to open device" on 64 bit ubuntu 16.10, but sane-utils work.

    I'm trying to completely purge sane and xsane but for some reason the sane-utils executables remain eventhough the package is apparently removed.

  3. #3
    Join Date
    Apr 2007
    Beans
    35

    Re: Xsane "Failed to open device" on 64 bit ubuntu 16.10, but sane-utils work.

    OK fixed, after managing to purge out the old 32 bit version of sane / xsane, I found the answer here http://askubuntu.com/questions/68864...15-04-to-15-10 and used the solution of copying in the experimental libs.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •