Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: I'm struggling with wifi on Ubuntu 16.04 server..

  1. #11
    Join Date
    Feb 2017
    Beans
    10

    Re: I'm struggling with wifi on Ubuntu 16.04 server..

    It is a physical host.
    I ran the following script: https://github.com/UbuntuForums/wireless-info in order to gather the infos necessary for troubleshooting a wireless connection.Please find attached the resulting txt file
    Looking forward to your hints.
    Marco
    Attached Files Attached Files

  2. #12
    Join Date
    Feb 2017
    Beans
    10

    Re: Get wireless working under Ubuntu Server 16.04

    Quote Originally Posted by chili555 View Post
    First, please confirm that your interface is indeed wlp5s0:
    Code:
    iwconfig
    Next, please amend the /etc/network/interfaces file to:
    Code:
    auto lo
    iface lo inet loopback
    
    auto wlp5s0
    iface wlp5s0 inet dhcp
    wpa-ssid NetworkName
    wpa-psk <your_key_in_plain_text>
    We will change to a static IP a bit later. It is cumbersome to locate a server with an ever-changing IP address.

    Now, restart the interface:
    Code:
    sudo ifdown wlp5s0 && sudo ifup -v wlp5s0
    The -v for verbose should produce some clues as to what is going wrong, if any.
    Hi,
    this is the output of :
    sudo ifdown wlp5s0 && sudo ifup -v wlp5s0
    ifdown: interface wlp5s0 not configured
    Parsing file /etc/network/interfaces.d/wlp5s0
    Configuring interface wlp5s0=wlp5s0 (inet)
    /bin/run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
    run-parts: executing /etc/network/if-pre-up.d/ethtool
    run-parts: executing /etc/network/if-pre-up.d/ifenslave
    + [ inet = meta ]
    + IF_BOND_SLAVES=
    + [ ]
    + [ ]
    + [ -z ]
    + exit
    run-parts: executing /etc/network/if-pr-up.d/iwconfig
    Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlp5s0 ; Operation already in progress.
    run-parts: /etc/network/if-pre-up.d/iwconfig exited with return code 250
    Failed to bring up wlp4s0

  3. #13
    Join Date
    Feb 2017
    Beans
    10

    Re: Get wireless working under Ubuntu Server 16.04

    Hi,
    iwconfig
    lo no wireless extensions
    wlp5s0 IEEE 802.11bgn ESSID:"Vodafone-11111111"
    Bit Rate=1 Mb/s Tx-Power=13 dBm
    Retry short limit:7 RTS thrff Fragmen thrff
    Power Managementff
    Link Quality=47/70 Signal level = -63 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:8 Missed beacon:0

    sudo cat /etc/network /interfaces

    source /etc/network/interfaces.d/*

    auto lo
    iface lo inet loopback

    auto enp3s0
    iface enp3s0 inet static
    address 192.168.1.3
    pre-up /sbin/ethtool -s enp3s0 speed 1000 duplex full

    allow-hotplug wlp5s0
    iface wlp5s0 inet dhcp
    wpa-ssid "Vodafone-11111111"
    wpa-psk "Psk_in_plain_text"

    sudo ifdown wlp5s0 && sudo ifup -v wlp5s0
    ifdown: interface wlp5s0 not configured
    Parsing file /etc/network/interfaces.d/wlp5s0
    Configuring interface wlp5s0=wlp5s0 (inet)
    /bin/run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
    run-parts: executing /etc/network/if-pre-up.d/ethtool
    run-parts: executing /etc/network/if-pre-up.d/ifenslave
    + [ inet = meta ]
    + IF_BOND_SLAVES=
    + [ ]
    + [ ]
    + [ -z ]
    + exit
    run-parts: executing /etc/network/if-pre-up.d/iwconfi
    Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlp5s0 ; Operation already in progress.
    run-parts: /etc/network/if-pre-up.d/iwconfig exited with return code 250
    Failed to bring up wulp5s0

  4. #14
    Join Date
    Feb 2017
    Beans
    10

    Re: Get wireless working under Ubuntu Server 16.04

    Please let me know what ever I have to check in order to understand why WIFI doesn't work
    Last edited by marco910; February 20th, 2017 at 02:17 PM.

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,730
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: I'm struggling with wifi on Ubuntu 16.04 server..

    This looks like you are connected:
    wlp5s0 IEEE 802.11bgn ESSID:"Vodafone-11111111"
    Bit Rate=1 Mb/s Tx-Power=13 dBm
    Retry short limit:7 RTS thrff Fragmen thrff
    Power Managementff
    Link Quality=47/70 Signal level = -63 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:8 Missed beacon:0
    But this looks like you are not:
    Failed to bring up wulp5s0
    Is there a typo here? In your file or just when you copied the results??

    Your /etc/network/interfaces is badly malformed for enp3s0. First, it asks both ethernet and wireless to start automatically; auto enp3s0. Second, it declares a static IP address but no netmask, gateway nor dns-nameservers. For now, until we sort out the wireless, I suggest that you comment out the ethernet, thus:
    Code:
    source /etc/network/interfaces.d/*
    
    auto lo
    iface lo inet loopback
    
    #auto enp3s0
    #iface enp3s0 inet static
    #address 192.168.1.3
    #pre-up /sbin/ethtool -s enp3s0 speed 1000 duplex full
    
    allow-hotplug wlp5s0
    iface wlp5s0 inet dhcp
    wpa-ssid "Vodafone-11111111"
    wpa-psk "Psk_in_plain_text"
    Detach the ethernet cable, reboot and show us:
    Code:
    iwconfig
    dmesg | grep wlp
    sudo ifdown wlp5s0 && sudo ifup -v wlp5s0
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #16
    Join Date
    Feb 2017
    Beans
    10

    Re: I'm struggling with wifi on Ubuntu 16.04 server..

    Hi,
    with this interface file now and with this wpa_supplicant.conf files, both ethernet and wifi connections work fine:

    marco@PC:~$ sudo cat /etc/network/interfaces

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    source /etc/network/interfaces.d/*

    # The loopback network interface
    auto lo
    iface lo inet loopback

    auto enp3s0
    iface enp3s0 inet dhcp
    pre-up /sbin/ethtool -s enp3s0 speed 1000 duplex full

    allow-hotplug wlp5s0
    iface wlp5s0 inet dhcp
    wpa-ssid "Vodafone-11111111"
    wpa-psk "Psk_in_plain_text"

    marco@PC:~$ sudo cat /etc/wpa_supplicant.conf
    network={
    ssid="Vodafone-11111111"
    psk=very_long_numeric_code # obtained through wpa_passphrase "Vodafone-11111111" Psk_in_plain_text
    key_mgmt=WPA-EAP WPA-PSK
    proto=RSN WPA
    pairwise=CCMP TKIP
    }

    THANK YOU VERY MUCH for your kind help.
    Marco
    Last edited by marco910; February 22nd, 2017 at 12:16 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •