Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Connecting to WPA & WPA2 enterprise Wi-Fi

  1. #11
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    23,343
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    I have to +1 this:
    That number of APs all using the same channels is a poor design.
    it is a nightmare for network manager.

  2. #12
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    12,902
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    Quote Originally Posted by wildmanne39 View Post
    I have to +1 this:

    it is a nightmare for network manager.
    Plus all those signals are about the same, bad, signal strength, so there isn't clear AP to connect with will always be in question by the NIC firmware. It will likely require futzing with some wifi NIC settings that we generally don't need to futz with to get any connection stable.

    If I were staying at this hotel, I'd talk to the general manager about this poor design. I'd explain that each AP using the same channel was like his wife talking to him about multiple different topics, from every direction, all the same-channel APs and he wouldn't know which to actually listen to.

    He probably doesn't know any better (he shouldn't need to know) and the company that put this in must have left it misconfigured. If they used a central wifi management system, the APs would self-correct for channel diversity using the best options possible automatically. Even the cheapest solutions from Ubiquiti do this.

    <rant>
    This is why I always travel with a portable wifi travel router and use the plugged in ethernet port in the room. My AP, my security and I'm behind a router I control. I have had to sit in a lobby to do work a few times because the wifi sucked and there wasn't any wired connection in the room. I always try to look overly relaxed - like a bum when I do this. Want to make the hotel feel the pain (of some guy in a bathrob and slippers hanging out in the lobby) that I'm feeling too.
    </rant>

  3. #13
    Join Date
    Jan 2017
    Beans
    10

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    Quote Originally Posted by TheFu View Post
    You moved? Or that AP isn't on?

    That number of APs all using the same channels is a poor design.
    I have been sitting next to the AP all the time apparently.


    Quote Originally Posted by wildmanne39 View Post
    Please do:
    Code:
    sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    The wireless file shows:
    Code:
    auto lo
    iface lo inet loopback
     
    auto wlan0
    iface wlan0 inet dhcp
    It also shows network manger is installed and running if that is the case them that file should only have the following in it:
    Code:
    auto lo
    iface lo inet loopback
    This command should reset that file:
    Code:
    echo -e "auto lo\niface lo inet loopback" | sudo tee /etc/network/interfaces
    If you still have trouble after doing the above commands please run the wireless script again and post the file again.
    Thanks
    Erm, so I ran the commands and nothing happened, I then deleted the old configuration in and now this box keeps popping up: http://imgur.com/a/SO0VD
    I'm certain the credentials are right because I use the same for other work related stuff.

    Also, here is the new wireless script: http://pastebin.com/apFGcArM

  4. #14
    Join Date
    Jan 2017
    Beans
    10

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    After further research I'm assuming that the problem has something to do with the fact that its WPA protected, should I try downloading another version of the wpa_supplicant?

  5. #15
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    12,902
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    I've never seen that issue. If you've connected to the wifi network, I would think the problem wasn't with authentication.

  6. #16
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    23,343
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Connecting to WPA & WPA2 enterprise Wi-Fi

    If your company does not use IPV6 then set that to ignore in network manager because it causes issues with all linux distributions. Please change network manager settings to match the screenshots.

    Let try a driver parameter:
    Code:
    echo "options iwlwifi 11n_disable=1 swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwldvm
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    Thanks
    Attached Images Attached Images

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •