Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: No Ethernet with Asus Prime Z270-A

  1. #1
    Join Date
    Mar 2013
    Beans
    32

    No Ethernet with Asus Prime Z270-A

    Hello!

    I've just build a new desktop PC with Asus Prime Z270-A motherboard and I do not have internet access, looks like there is no driver for it.

    Is there a way to manually install the driver for Intel I219-V Gigabit LAN?

    Thanks!

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: No Ethernet with Asus Prime Z270-A

    The necessary driver is included in all recent Ubuntu versions by default. If it didn't load as expected, there is some other problem. Please open a terminal and run and post:
    Code:
    lspci -nnk | grep 0200 -A2
    lsb_release -a
    dmesg | grep e100
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Mar 2013
    Beans
    32

    Re: No Ethernet with Asus Prime Z270-A

    lspci -nnk | grep 0200 -A2

    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8]
    Subsystem: AsusTek Computer Inc. Ethernet Connection (2) I219-V [1043:8672]
    Kernel modules : e10001

    lsb_release -a

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 16.04.1 LTS
    Release: 16.04
    Codename: xenial

    dmesg | grep e 100

    [0.776295] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
    [0.776295] e1000e: Copyright(c) 1999-2015 Intel Corporation
    [0.830903] e1000e 0000:00:1f.6: Interrupt Throttling Rate (int/sec) set to dynamic conservation mode
    [1.049935] e1000e 0000:00:1f.6: The NVM Checksum Is Not Valid
    [1.084914] e1000e: probe of 0000:00:1f.6 failed with error -5

    Thank you for your fast reply!

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: No Ethernet with Asus Prime Z270-A

    e1000e 0000:00:1f.6: The NVM Checksum Is Not Valid
    As you can see, the correct driver, e1000e, attempts to load, encounters an error and bails out. That's the 'something else is wrong' that I suspected.

    The fix is a bit complex: http://superuser.com/questions/11045...el-ethernet-co

    Before we get out the plasma cutters and go full geek mode, let's take a gamble that the newer driver in 16.10 might possibly work properly. Please download the 16.10 image, make a USB or DVD and try a live session. If the ethernet works, install it and we're done! If not, check again:
    Code:
    dmesg | grep e100
    If you get the same message about NVM checksum, we'll install the later driver after we amend it a bit.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #5
    Join Date
    May 2014
    Location
    /home
    Beans
    8,954
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: No Ethernet with Asus Prime Z270-A

    The code fix isn't in linux-next, in 4.4 source code look around line 7143 for the problem

    Link to the discussion with the Intel devs
    https://sourceforge.net/p/e1000/mail...m/#msg35211176
    Last edited by jeremy31; February 4th, 2017 at 10:39 PM.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: No Ethernet with Asus Prime Z270-A

    Quote Originally Posted by jeremy31 View Post
    The code fix isn't in linux-next, in 4.4 source code look around line 7143 for the problem

    Link to the discussion with the Intel devs
    https://sourceforge.net/p/e1000/mail...m/#msg35211176
    Yep. I hope this will compile on the OP's 4.4 kernel. It does not on my 4.8 due to, I understand, gcc incompatibilities.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #7
    Join Date
    Mar 2013
    Beans
    32

    Re: No Ethernet with Asus Prime Z270-A

    Hey, thanks for your replies!

    I had a look on that discussion though it is a little too complicated for me to fully understand.

    As jeremy31 pointed, the problem is not dependent of kernel, it is really an error in the NVM Checksum, very annoying and I am really interested to solve this on a hard way but I will need your help cause I really don't know where to start it.

    Anyway for a fast workaround and assuming the risk I've done this using bootutil:

    "chmod +x ./bootutil" "sudo ./bootutil64e -NIC 1 -defcfg"This made my LAN functional and I am able to access the internet now.

    On the other hand I am interested in how to solve this in a none risky way, can you please let me know what should I do?
    Do you think I should buy a new Network card as well as a backup?

    Thank you in advance for your help!

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,859
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: No Ethernet with Asus Prime Z270-A

    Hi,

    it seems we have the same problem on the German Forum:

    https://forum.ubuntuusers.de/topic/k.../#post-8791278

    I prepared the patched driver. Please find it attached with the amendment shown there in yellow (attached)
    Attached Files Attached Files

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,363
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: No Ethernet with Asus Prime Z270-A

    On the other hand I am interested in how to solve this in a none risky way, can you please let me know what should I do?
    I'm not at all sure that the method you used is risky. After all, it is outlined on Intel's own site: http://www.intel.com/content/www/us/...000005790.html

    My suggestion is to use it and not worry. I see no evidence that it is likely to revert. Hasn't it survived a few reboots?

    If you feel uncomfortable, PCIe gigabit cards are relatively inexpensive, so a backup may be a good investment.
    Last edited by chili555; February 5th, 2017 at 03:06 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  10. #10
    Join Date
    Mar 2013
    Beans
    32

    Re: No Ethernet with Asus Prime Z270-A

    Thank you praseodym , if it ever happens again I will used the patched driver!

    Hey chili555, it survived multiple reboots and is still working. Thank you for your help and advises, will put them to good use!

    See you around!

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •