Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: My Experience Installing and Using Linux on my Lenovo 110s

  1. #1
    Join Date
    Jan 2017
    Beans
    0

    My Experience Installing and Using Linux on my Lenovo 110s

    (I don't know where exactly to post this, but I felt this was the correct place. Just want to share my pleasant experience.)

    Good day Ubuntu Forums,

    I love the ease of use of Unity and the customizability of Linux. I wish I could ditch Microsoft products, but programs like Office always pose a major challenge I don’t feel like overcoming at this time. Windows 7 was the last operating system I truly loved Microsoft for, and since then, I have felt disenfranchised by the company’s designers. Mouse and keyboard users should always come first and people shouldn’t worry about popups on their operating system telling them to use a certain web browser.

    I am using a Lenovo 110s-11IBR, and I have to say, it is an excellent cheap Linux laptop. It is the successor to the Lenovo 100s, which last time I installed Ubuntu, didn’t have good support. But, the 110s has all features working that I have tested. I haven’t tested the Bluetooth, but it is recognized, so I think it works. I had to edit the BIOS settings a bit to get Ubuntu’s GRUB bootloader to be recognized. Besides this small quirk, this sub $200 laptop is excellent for Ubuntu 16.04, and I don’t think I want to return to cluttered Windows 10 on this machine. I have several hours of battery life and it is a very portable, cheap workhorse. Plus, it runs much better on Ubuntu than Windows 10. If you wish to buy this PC, I have instructions below to install Ubuntu on the machine. I have limited knowledge of the OS, and if I make any mistakes, feel free to correct me.

    Instructions on Installing Windows on a Lenovo 110s-11IBR

    What You Need

    1. Lenovo 110s-11IBR (Make sure you have the right model, old model may not work at all)
    2. USB Wifi Dongle or any other internet connectivity sources
    3. USB drive with 64-bit Ubuntu 16.04 LTS OS


    BIOS Settings
    1. Press F2 repeatedly upon booting the computer.
    2. Go to the ’Configuration Tab’ and make sure the following options are as such:
      1. USB Legacy – Enabled
      2. Wireless – Enabled
      3. Hotkey Mode – Selection does not matter, changes FN requirement for functions
      4. Intel Virtual Technology – Selection does not matter, allows VM to run within OS
      5. BIOS Flash Back – Disable (Default selection, May not matter with Install)

    3. Go to the ‘Security Tab’ and make sure the following options are as such:
      1. Intel Platform Trust Technology – Disabled

    4. Go to the ‘Boot Tab’ and make sure the following options are as such:
      1. Boot Mode – Legacy Support
      2. Boot Priority – UEFI First
      3. USB Boot – Enabled (Very Important to Enable)
      4. PXE Boot to Lan – Selection does not matter, allows machine to boot via Networking

    5. Go to the ‘Exit Tab’ and make sure the following options are as such:
      1. OS Optimized Defaults – Disabled

    6. Press ‘Exit Saving Changes’


    Installing Ubuntu

    1. Once you restart the computer, insert your Ubuntu 16.04 USB Disk and Press F12 repeatedly.
    2. Boot from your USB flash drive and make sure you are in the UEFI enabled Ubuntu installer.
    3. Install Ubuntu as usual wiping the entirety of the drive.
    4. Reboot into Ubuntu and make sure you have the USB Wifi Dongle installed and connect to your network.
    5. Open up a terminal and run ‘sudo apt-get update’ then ‘sudo apt-get upgrade’
    6. Upon restart, the machine should be running perfectly with the integrated Wi-Fi chip working along with all other futures.
    7. Customize Ubuntu and Unity to your desires.
    Attached Images Attached Images
    Last edited by matthewj15; February 13th, 2017 at 12:47 AM.

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    12,979
    Distro
    Lubuntu 18.04 Bionic Beaver

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Thanks for posting.

    If you add a brief post to the compatibility thread, possibly linking to this one, there is a better chance that people will find it.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  3. #3
    Join Date
    Oct 2011
    Beans
    2

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Thanks for posting this matthewj15! I'm been using Linux as my main OS since 2012 (Linux Mint KDE), with Windows 7 installed in VirtualBox for those rare times I need it. Two days ago I bought an Ideapad 110s. I was thinking about leaving Windows 10 on it to "keep up with the times" but after two days of using it, "It's Linux Time!" I'm traveling right now but will follow your well written instructions as soon as I get home next week with LM Mate. I'll let you know how it went.

  4. #4
    Join Date
    Oct 2011
    Beans
    2

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Worked perfectly! Didn't need to use my USB wi-fi dongle. Ubuntu installed using 10GBs less HDD space than Windows 10 and it uses half the amount of RAM when running. Thanks again!

  5. #5
    Join Date
    Oct 2011
    Beans
    2

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    OOps. Spoke too soon. Neither the touchpad, nor the touchpad buttons are working. I just noticed it. I rarely use it (I'm a mouse guy) so I don't know if it hasn't been working since the installation or if it just recently stopped working. Any ideas?

  6. #6
    Join Date
    Jun 2017
    Beans
    0

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    matthewj15,

    Thank you so much for your findings. I was having a hard time with the installation, but now it works perfectly.

    Cheers!

  7. #7
    Join Date
    Jul 2017
    Beans
    0

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Hi thank you very much for your post, I hesitated to buy a Lenovo 110S (because with a low cost configuration I did not want windows) but with your post I bought it ! So thank you.

    I installed with success a Xubuntu 16.04.02 LTS ... but I still have a problem : the bluetooth is unstable when the Wifi connection is activated (the bluetooth is stable is the Wifi connection is not used).

    For information, I formatted the ssd drive and I replaced Windows by Ubuntu.

    Here my Bios configuration :
    - Wireless : Enabled
    - Hotkey Mode : Enabled
    - Intel Virtual Technology : Enabled
    - BIOS Back Flash : Disabled
    - Security
    - Intel Platform Trust Technology : Disabled
    - Secure Boot : Disabled
    - Boot
    - Boot Mode : UEFI
    - USB Boot : Enabled
    - PXE Boot to LAN : Disabled
    - Exit
    - OS Optimized Defaults : Disable

    I installed using a DVD drive from the ubuntu iso image, but i tried also using a usb key generated using the tool named Unetbooin. And before repairing the Wifi connection I used an usb network adaptor.

    After the installation the wifi adaptor wasn't detected automatically, I fixed the problem with these commands :
    $ rmmod ath10k_pci
    $ rm -r /lib/firmware/ath10k
    $ mkdir /lib/firmware/ath10k
    $ wget http://archive.ubuntu.com/ubuntu/poo..._1.167_all.deb
    $ dpkg -i linux-firmware_1.167_all.deb
    $ modprobe ath10k_pci
    $ reboot now

    So after reboot, the wifi connection is up.
    But the bluetooth connection still unstable.
    $ dmesg | grep error
    [ 5.103365] EXT4-fs (mmcblk0p2): re-mounted. Opts: errors=remount-ro
    [ 6.391298] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
    [ 6.391337] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2

    And sometimes the service bluetoothd crashs.

    I identified the adaptor :
    $ lspci | grep "Network controller"
    Qualcomm Atheros Device 0042 (rev 31)

    I tried a lot of thread regarding https://github.com/kvalo/ath10k-firmware.git but without success.

    Do you have any idea to this issue ?

    Thank you in advance !

    Best regards
    Last edited by bobalu; July 3rd, 2017 at 08:34 PM.

  8. #8
    Join Date
    Jul 2017
    Beans
    0

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Hi Guys,

    I am a windows developer and I have played with the Microsoft technology stack for years and to be truthful, I don't mind the direction Microsoft is taking. However, I am aware of the hardware requirements need to for me to do my job, and of course the cost of that hardware. Currently I am finding myself playing with .net core more and more so I thought I would look at what was required to create a minimalist .net core development environment so I started looking at Linux. A second, lesser reason for looking at Linux is that Docker seems to be a little unstable on Windows 10.

    I have never played with Linux. I obvious know of it but work has never taken me in that direction. When I cam across this thread, I had just seen the Lenovo 110s in a local computer shop. They were trying to get rid of them because the 32gb drive was just not enough once you ran a significant update so I thought, what the hell, lets give this a shot.

    Using bobalu's bios configuration and ubuntu 17.04 desktop for amd 64, I had the OS up and configured in 40 minutes. That is from opening an unsealed box to logging into the OS. I did not pass the windows install and I did not collection $200. That is astonishing. Almost everything just appears to work. The only problem I have is connecting my Logitech MX Anywhare 2 via Bluetooth. I will post again when I figure it out.

    @matthewj15, thanks for starting this thread and the steps required to install the OS.

    To any other Windows .net core devs out there, this is a viable solution moving forward.

    Thanks again guys.

  9. #9
    Join Date
    Aug 2017
    Beans
    1

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Hello all!

    I'd like to share my experience in successfully installing a flavour on my Lenovo Ideapad 110s.

    short version:

    Goes to store and buys ethernet over usb dongle.
    inserts to usb port on computer, connects ethernet cable to dongle.
    Insert created bootable usb (you should have this made prior to doing all this).
    In bios (f2 on bootup): Security tab>Secure Boot : Disabled (don't forget to save and exit).
    In boot manager (f12 on bootup), select usb with image.
    and go through the motions of any normal installation.
    Log in, open terminal, sudo apt-get update && sudo apt-get upgrade.
    done = happy camper.


    Long version:

    I first started out by creating a bootable usb from the installed windows. I first tried Debian, ran into the whole "non free driver" deal with wifi, then it didn't even recognize my card. I moved on to Lubuntu. I would go through the motions of connecting to wifi, creating a user name, password, and upon installation, it crashed stating it could not install kernel, boot loader.
    I moved on to ubuntu gnome and to my surprise it installed fully. I logged in then realized that I couldn't update it. My wifi bar appears connected to my network. I disconnect and connect to another, connects successfully but still nothing. Checked the browser, no connection. I was confused. I did some backtracking and noticed that on all my installations it was always to the default location of New York.

    Aha moment in place, I then realize it's not really connecting to the internet, no data is coming through even though it appears so. It all started to make sense, especially when debian couldn't even figure out the name of my network card.

    Luckily there's an electronics store not too far and picked up an ethernet over usb dongle. Came home, inserted usb to computer, inserted ethernet cable to dongle, power on,f12 to boot manager, selected my flavour and boom, it knows my location upon installation. I knew I was good from here.
    Last edited by dayvkaos; August 12th, 2017 at 07:43 PM.

  10. #10
    Join Date
    Oct 2017
    Beans
    0

    Re: My Experience Installing and Using Linux on my Lenovo 110s

    Hi ..Matthew ...can u tell me the process of getting the ubuntu 16.04 usb disk the whole process do i have to buy it or is it free...Sorry but this is a first for me to do ..Its been a bit you might not get this but if anyone else reads this your help will be appreciated thanks

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •