Results 1 to 7 of 7

Thread: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

  1. #1
    Join Date
    Sep 2013
    Beans
    7

    flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    I was curious if others were seeing this issue recently. Back on Dec 13th, a new flash plugin version was released. I was doing a new install of Lubuntu 14.04.1 LTS i386 version today and installed the Lubuntu-restricted-extras metapackage. One of the items it installs is flashplugin-installer. I noticed after installing completed without error, that the flash plugin was still not installed (went to https://helpx.adobe.com/flash-player.html).

    So, I purged the flashplugin-installer and reinstalled:

    Code:
     admin@pc1:~$ sudo apt-get purge flashplugin-installer
    admin@pc1:~$ sudo apt-get install flashplugin-installer
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      cifs-utils linux-headers-3.13.0-32 linux-headers-3.13.0-32-generic
      localechooser-data python3-pyqt4 python3-sip
    Use 'apt-get autoremove' to remove them.
    Suggested packages:
      x-ttcidfont-conf ttf-bitstream-vera ttf-dejavu ttf-xfree86-nonfree xfs
    The following NEW packages will be installed:
      flashplugin-installer
    0 upgraded, 1 newly installed, 0 to remove and 410 not upgraded.
    Need to get 0 B/6,792 B of archives.
    After this operation, 140 kB of additional disk space will be used.
    Preconfiguring packages ...
    Selecting previously unselected package flashplugin-installer.
    (Reading database ... 207293 files and directories currently installed.)
    Preparing to unpack .../flashplugin-installer_24.0.0.186ubuntu0.14.04.1_i386.deb ...
    Unpacking flashplugin-installer (24.0.0.186ubuntu0.14.04.1) ...
    Processing triggers for update-notifier-common (0.154.1ubuntu1) ...
    flashplugin-installer: downloading http://archive.canonical.com/pool/pa....1.orig.tar.gz
    Setting up flashplugin-installer (24.0.0.186ubuntu0.14.04.1) ...
    admin@pc1:~$
    After this, it still was not installed despite no error message, so I repeated the purge and install process. On the third time around doing this, it finally installed. Notice at the end how it is slightly different where at says it is installing and then was installed?

    Code:
    admin@pc1:~$ sudo apt-get install flashplugin-installer 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      cifs-utils linux-headers-3.13.0-32 linux-headers-3.13.0-32-generic
      localechooser-data python3-pyqt4 python3-sip
    Use 'apt-get autoremove' to remove them.
    Suggested packages:
      x-ttcidfont-conf ttf-bitstream-vera ttf-dejavu ttf-xfree86-nonfree xfs
    The following NEW packages will be installed:
      flashplugin-installer
    0 upgraded, 1 newly installed, 0 to remove and 410 not upgraded.
    Need to get 0 B/6,792 B of archives.
    After this operation, 140 kB of additional disk space will be used.
    Preconfiguring packages ...
    Selecting previously unselected package flashplugin-installer.
    (Reading database ... 207293 files and directories currently installed.)
    Preparing to unpack .../flashplugin-installer_24.0.0.186ubuntu0.14.04.1_i386.deb ...
    Unpacking flashplugin-installer (24.0.0.186ubuntu0.14.04.1) ...
    Processing triggers for update-notifier-common (0.154.1ubuntu1) ...
    flashplugin-installer: downloading http://archive.canonical.com/pool/pa....1.orig.tar.gz
    Installing from local file /tmp/tmpYgR1jv.gz
    Flash Plugin installed.
    Setting up flashplugin-installer (24.0.0.186ubuntu0.14.04.1) ...
    admin@pc1:~$


    This is very repeatable for me on multiple computers too. If I purge the flashplugin-installer after a successful install and reinstall, I will have the same issues where I need to purge and reinstall a couple times.

    I thought this is odd so was curious if others have had this experience in the last couple of weeks?

    Thanks!
    Last edited by montyp2; January 5th, 2017 at 08:25 PM. Reason: code tags

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    I have not used the flashplugin-installer package for quite a while.

    In future try enabling the canonical-partner repos and then install adobe-flashplugin package which seems more successful.
    If you do that and then install restricted-extras package I think the need for flashplugin-installer is already satisfied.
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  3. #3
    Join Date
    Sep 2013
    Beans
    7

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    Thanks ajgreeny for the suggestion. That does seem to install more reliably than the flashplugin-installer package.


  4. #4
    Join Date
    Dec 2007
    Location
    Somerset, UK
    Beans
    59
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    Quote Originally Posted by montyp2 View Post
    Thanks ajgreeny for the suggestion. That does seem to install more reliably than the flashplugin-installer package.

    Adobe_flashplugin no longer loads, nor Adobe_flash_properties_gtk.
    It seems this may be the reason flashplugin_installer is not working.
    Files are missing.
    Happens with 16.04 as well.
    Messages from Synaptic with Lubuntu 16.04:
    W: Failed to fetch http://archive.canonical.com/ubuntu/...04.1_amd64.deb
    404 Not Found [IP: <removed>]
    W: Failed to fetch http://archive.canonical.com/ubuntu/...04.1_amd64.deb
    404 Not Found [IP: <removed>]
    There has also been a problem with ttf-mscorefonts_installer for some weeks, with Lubuntu 16.04, all the MS font file download calls return Error 404.
    The lubuntu_restricted_extras package in 16.04 calls flashplugin_installer even if you have adobe_flashplugin installed (but broken because of the missing download).
    You just keep getting messages to perform additional downloads that are incomplete, for both flashplugin and mscorefonts. When you try to run the additional commands, they fail with 404 errors for the download files.
    engineer [v.t. ; v.i.] : to bring about or cause to happen by the use of devious means

  5. #5
    Join Date
    Sep 2013
    Beans
    7

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    Thanks nadrach for the reply.
    I had the same issue with adobe_flashplugin. After enabling the partners repository and running sudo apt-get update, it failed to connect to one of the download servers. I then tried through synaptic and it worked to install it. I would think Synaptic and apt-get should work the same, so maybe it was shear dumb luck it worked for me from synaptic.

    I noticed that about the msfonts in 16.04 as well. You probably already had this, but for the msfonts issues, this fixed it for me: http://askubuntu.com/questions/54367...fonts-problems

  6. #6
    Join Date
    Dec 2007
    Location
    Somerset, UK
    Beans
    59
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    Just tried on Lubuntu 14.04 machine, using apt-get:
    Err http://archive.canonical.com/ubuntu/ trusty/partner adobe-flash-properties-gtk i386 1:20161213.1-0ubuntu0.14.04.1
    404 Not Found [IP: <removed>]
    Err http://archive.canonical.com/ubuntu/ trusty/partner adobe-flashplugin i386 1:20161213.1-0ubuntu0.14.04.1
    404 Not Found [IP: <removed>
    E: Failed to fetch http://archive.canonical.com/ubuntu/....04.1_i386.deb 404 Not Found [IP: <removed>]

    E: Failed to fetch http://archive.canonical.com/ubuntu/....04.1_i386.deb 404 Not Found [IP: <removed>]
    Is this missing files on the server, missing files, or malformed request?
    Ie: should there be a space in:
    engineer [v.t. ; v.i.] : to bring about or cause to happen by the use of devious means

  7. #7
    Join Date
    Dec 2007
    Location
    Somerset, UK
    Beans
    59
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: flashplugin-installer (24.0.0.186ubuntu0.14.04.1) randomly fails on install

    Just on the offchance, I tried the two direct download links in the "E:Failed to fetch" messages in my previous post, and Lo!, manual download of both packages. I am going to try with 16.04
    Installed simply by right-clicking for GDebi on the two downloaded package files.
    Ignore the complaint about the same package being available via a software channel.
    Someone else can provide the answer as to why the software channel route is not working, but I am fixed for the moment.
    engineer [v.t. ; v.i.] : to bring about or cause to happen by the use of devious means

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •