Page 17 of 19 FirstFirst ... 71516171819 LastLast
Results 161 to 170 of 190

Thread: HOWTO: Set your system up for Wake On LAN (WOL)

  1. #161
    Join Date
    Aug 2008
    Location
    Washington DC
    Beans
    2,186
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by rklauco View Post
    Same here, I'm affraid. Also, if I do suspend and the power runs out, the WoL does not work.
    its normal, once the machine is completely dead the WoL intelligence of your device dies too -- it's in volatile RAM. I don't know if its like this on every machine, but have ran into in every machine I have tested. The solution is to use a UPS so that the box always has power.

    It limits WoL usefulness a bit or a least it forces you replace bad UPS batteries..

  2. #162
    Join Date
    Sep 2009
    Beans
    48

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I can see why it would happen after a complete shut down and loss of power.In my BIOS the only WOL option is by USB,however by editing the files as indicated in this thread I was able to activate WOL from standby. why can't I do. WOL from hibernate or normal shut down?can I edit any files to enable this?

  3. #163
    Join Date
    Nov 2010
    Beans
    1

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Im not an expert so dont quote me on this
    i believe that you are able to use wake on lan in standby becuase the os its self is still running, with most processes stopped. So due to the way you have set it up, it can still listen to requests with that 1 per cent of cpu that is running

    On the other hand when you shutdown or hibernate the machine turns off completely (for those that are technical, it turns of completely from the OS's point of view) and the os stops running thus it can not listen for the request. The only way to enable it in this situation is by making the BIOS listen for requests then start the computer.

    easy analogy; when the computer is suspended, it is sleeping and you can prod it awake (if set up properly)

    when the computer is shutdown or hibernating, it is dead and is so until the BOIS revives it.

  4. #164
    Join Date
    Dec 2009
    Beans
    2
    Distro
    Ubuntu

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi, I've been reading this thread and http://ubuntuforums.org/showthread.php?t=814939, among other resources on the net, regarding WOL. I want to wake after shutdown, not hibernation, and so far, I've been unable to make it work. My setup is an old IBM netvista 6578 motherboard with a Realtek 8139C (chipset) network card. I'm running Ubuntu server 9.10 with the latest upgrades available. Manual from the motherboard says it supports WOL and I've enabled it in the BIOS. The network card does not have a connection for a dedicated cable, and the motherboard manual states that it can do WOL through the PCI bus.

    The configuration of the system is as follows

    Code:
    $ sudo lspci -tv
    
    -[0000:00]-+-00.0  Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub
               +-02.0  Intel Corporation 82815 Chipset Graphics Controller (CGC)
               +-1e.0-[0000:01]--+-08.0  Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
               |                 +-0d.0  Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller
               |                 \-0e.0  Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller
               +-1f.0  Intel Corporation 82801BA ISA Bridge (LPC)
               +-1f.1  Intel Corporation 82801BA IDE U100 Controller
               +-1f.2  Intel Corporation 82801BA/BAM USB Controller #1
               +-1f.3  Intel Corporation 82801BA/BAM SMBus Controller
               \-1f.5  Intel Corporation 82801BA/BAM AC'97 Audio Controller
    Code:
    $ sudo lspci -v
    
    00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
            Flags: bus master, fast devsel, latency 0
            Capabilities: [88] Vendor Specific Information <?>
            Kernel driver in use: agpgart-intel
            Kernel modules: intel-agp
    
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 01)
            Flags: bus master, fast devsel, latency 0
            Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
            I/O behind bridge: 00007000-00007fff
            Memory behind bridge: feb00000-febfffff
            Prefetchable memory behind bridge: 20000000-200fffff
            Kernel modules: shpchp
    
    01:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
            Subsystem: Kingmax Technology Inc Device 0203
            Flags: bus master, medium devsel, latency 208, IRQ 16
            I/O ports at 7800 [size=256]
            Memory at febff700 (32-bit, non-prefetchable) [size=256]
            Expansion ROM at ff000000 [disabled] [size=128K]
            Capabilities: [50] Power Management version 2
            Kernel driver in use: 8139too
            Kernel modules: epl, 8139too, 8139cp
    
    (some stuff removed for clarity)
    I've followed the ethtool stuff until I managed to get this after every boot:

    Code:
    Settings for eth0:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
            Advertised auto-negotiation: Yes
            Speed: 100Mb/s
            Duplex: Full
            Port: MII
            PHYAD: 32
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: g
            Current message level: 0x00000007 (7)
            Link detected: yes
    So far, the "g" here is supposed to enable the WOL. Checked to see if pci devices were enabled to wakeup the machine and got this

    Code:
    Device  S-state   Status   Sysfs node
    PS2K      S3     disabled  pnp:00:03
    UAR1      S5     disabled  pnp:00:05
    UAR2      S5     disabled  pnp:00:06
    USB0      S3     disabled  pci:0000:00:1f.2
    PCI2      S5     disabled  pci:0000:00:1e.0
    I guessed that PCI2 had to be enabled and since I couldn't find the network card, I went into the /sys/devices directories and realized they were all disabled. I then enabled them with

    Code:
    $ sudo su
    # echo PCI2 > /proc/acpi/wakeup
    # echo enabled > /sys/devices/pci0000\:00/0000\:00\:1e.0/power/wakeup 
    # echo enabled > /sys/devices/pci0000\:00/0000\:00\:1e.0/0000\:01\:08.0/power/wakeup
    which gives me

    Code:
    # cat /proc/acpi/wakeup
    Device    S-state      Status   Sysfs node
    PS2K      S3     disabled  pnp:00:03
    UAR1      S5     disabled  pnp:00:05
    UAR2      S5     disabled  pnp:00:06
    USB0      S3     disabled  pci:0000:00:1f.2
    PCI2      S5     enabled   pci:0000:00:1e.0
    
    #cat /sys/devices/pci0000\:00/0000\:00\:1e.0/power/wakeup 
    enabled
    
    #cat /sys/devices/pci0000\:00/0000\:00\:1e.0/0000\:01\:08.0/power/wakeup 
    enabled
    Up to this point I understand that the motherboard and the network card both support WOL, and by the commands above everything is already running. I've also modified the etc/init.d/halt script adding

    Code:
    # Modified on 2011-01-09 to try Wake-on-LAN
    # NETDOWN=yes
    NETDOWN=no
    But haven't run any update-rc.d or anything similar. (Is it needed?)

    With all this going, if I shutdown the server (with sudo shutdown -h now) it goes off and no light is blinking on the network card. I guess this might be the key issue here, but I'm not sure. Are the lights (ACT and LINK) supposed to be blinking all the time or only when they get traffic?

    As expected (but not desired) it doesn't wake up when magic packet is sent from other machines in the network (tried from a couple of machines with wakeonlan). Does anybody have an idea of how to troubleshoot this?

    Sorry for the long post and thanks in advance,

    Alberto

  5. #165
    Join Date
    Aug 2006
    Location
    Crakatinny, nea
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    OK, that's a doddle so thanks. Worked a treat.

    But seriously, the functionality seems very limited if I need to type wakeonlan bla:bla:bla:... into a shell whenever I need to wake a remote computer. It would be far better if simply by requesting a connection through an application the remote and asleep computer could be woken.

    Windows 7 does this quite intuitively and easily.

    IS similar functionality available in Linux? For example, if the mythserver is asleep and a remote myth frontend wants to access it, can that be done without opening a shell and typing "wakeonlan hardwaredevice"?

    The other thing I noticed with linux it seems to very prone to sending a PC to sleep even when it is in the middle of an intensive task such as file copying etc.



    Thanks
    Last edited by GuiGuy; April 13th, 2011 at 07:24 AM.
    The GuiGuy
    Free is only good when it works.

  6. #166
    Join Date
    May 2008
    Location
    Texas
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by JanHus View Post
    Hi everyone

    im new to ubuntu and the forums. I just got nomachine running and im rather pleased with that. Now wakeonlan is the next step. My hardware supports wake on lan and it is enabled in the bios. I was doing oke untill i stumbled at this problem:

    Hope you can help me out
    This is probably because ethtool is not installed on your system.

    sudo apt-get install ethtool

  7. #167
    Join Date
    May 2008
    Location
    Texas
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by GuiGuy View Post
    OK, that's a doddle so thanks. Worked a treat.

    But seriously, the functionality seems very limited if I need to type wakeonlan bla:bla:bla:... into a shell whenever I need to wake a remote computer. It would be far better if simply by requesting a connection through an application the remote and asleep computer could be woken.

    Windows 7 does this quite intuitively and easily.

    IS similar functionality available in Linux? For example, if the mythserver is asleep and a remote myth frontend wants to access it, can that be done without opening a shell and typing "wakeonlan hardwaredevice"?

    The other thing I noticed with linux it seems to very prone to sending a PC to sleep even when it is in the middle of an intensive task such as file copying etc.



    Thanks
    There's gwakeonlan available for install in the ubuntu repositories if you don't want to open a shell and go command line to wake the remote machine.

    As far as the other software (mythfrontend), it's probably possible to do that, but you'd need to do a small bit of scripting or configuration to set it up yourself or ask a feature request for the mythtv developers.

    I think that most people want their mythbackend running full time so that it can be recording, but if you don't then you could likely customize it.

    Another option if you want to leave your mythbackend off for several house because doesn't ever record before say 5pm and you don't get home until 6pm, your BIOS may allow the machine to alarm and wake itself up everyday at say 4:45.

  8. #168
    Join Date
    Aug 2006
    Location
    Crakatinny, nea
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by sn9ke.eyes View Post
    Another option if you want to leave your mythbackend off for several house because doesn't ever record before say 5pm and you don't get home until 6pm, your BIOS may allow the machine to alarm and wake itself up everyday at say 4:45.
    The backend is sorted nicely. It suspends 5 minutes if it isn't recording or if a remote user isn't accessing one of the DBTV cards. It wakes up twenty minutes before a scheduled recording.

    Were it falls apart is on the wakeonlan, which is tedious and low on WAF. The other issue is that it will suspend even when users are accessing video or music files from their front ends, the backend will go to suspend. I've tried the scripts that are supposed to prevent this but they haven't worked for me and I don't have the depth of knowledge to write my own. So I usually have to take the backend off suspend when users are watching recordings or listening to music. At this point I am looking at my neighbour's Win Home Server with some envy. But then, it probably isn't as much "fun", right?

    Let's call it a work in progress....
    The GuiGuy
    Free is only good when it works.

  9. #169
    Join Date
    Aug 2006
    Location
    Crakatinny, nea
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by sn9ke.eyes View Post
    Another option if you want to leave your mythbackend off for several house because doesn't ever record before say 5pm and you don't get home until 6pm, your BIOS may allow the machine to alarm and wake itself up everyday at say 4:45.
    The backend is sorted nicely. It suspends 5 minutes if it isn't recording or if a remote user isn't accessing one of the DBTV cards. It wakes up twenty minutes before a scheduled recording.

    Where it falls apart is on the wakeonlan, which is tedious and low on WAF. The other issue is that it will suspend even when users are accessing video or music files from their front ends, the backend will go to suspend. I've tried the scripts that are supposed to prevent this but they haven't worked for me and I don't have the depth of knowledge to write my own. So I usually have to take the backend off suspend when users are watching recordings or listening to music. At this point I am looking at my neighbour's Win Home Server with some envy. But then, it probably isn't as much "fun", right?

    Let's call it a work in progress....
    The GuiGuy
    Free is only good when it works.

  10. #170
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by rsriram22 View Post
    I believe my LAN chipset supports WOL, but my BIOS does not. (weird!). Here are the details:

    1) lspci returns:

    01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)

    2) BIOS has following settings:
    PME event wake up - enabled
    acpi suspend type - S1 or S3 (S3 is selected)
    power on by ring - enabled
    resume by alarm- disabled.

    Does that mean that i cannot wake up the system from S5 at all.. I thought I d clarify this before I tweak ubuntu..

    thanks!

    Ubuntu 9.10 x64 on Gigabyte ga g41m es2h


    Quote Originally Posted by rsriram22 View Post
    How do I enable WOL in BIOS -- I have mentioned all the options under ACPI in my earlier post...

    Somewhere else I read that if the LAN port light blinks after complete shutoff (S5), WOL is enabled.. In my case,no lights blink after S5..

    Any clues?
    I just wanted to answer you cause i had the exact same configuration as you and the one that answered you didnt seem to read your post at all. After some time messing up with this i finally made it.
    At first i thought the same as you, i had that bios settings and i didnt see any lights on the nic when pc was off but after some thinking i realize something. I read somewhere that the mobo needs to be pci 2.2 to support wol from nic without extra cable, i knew my mobo was, but what happens if the nic wasnt? (my pc is old). And that was exactly the problem, i installed another nic that i had on a newer pc and it worked like a charm.

    I hope this could help some others too, before giving up, look at your NIC and try with another (newer one). And check if your mobo is pci 2.2 compliant.

Page 17 of 19 FirstFirst ... 71516171819 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •