Results 1 to 2 of 2

Thread: 16.04: Jmicron Gigabit NIC does not work on 1000 mbps speed

  1. #1
    Join Date
    Dec 2008
    Beans
    26

    16.04: Jmicron Gigabit NIC does not work on 1000 mbps speed

    Hi,

    My laptop (Asus K42 JA) has a Jmicron Gigabit nic card, full name is below

    Code:
    lspci -nn | grep -i eth
    07:00.5 Ethernet controller [0200]: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller [197b:0250] (rev 03)
    and here is the ethtool output (Right now its forced to 100 mbps)

    Code:
    sudo ethtool enp7s0f5
    Settings for enp7s0f5:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Half 1000baseT/Full
            Supported pause frame use: No
            Supports auto-negotiation: Yes
            Advertised link modes:  100baseT/Full
            Advertised pause frame use: Symmetric Receive-only
            Advertised auto-negotiation: Yes
            Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                                 100baseT/Half 100baseT/Full
            Link partner advertised pause frame use: Symmetric Receive-only
            Link partner advertised auto-negotiation: Yes
            Speed: 100Mb/s
            Duplex: Full
            Port: MII
            PHYAD: 1
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pg
            Wake-on: g
            Current message level: 0x000020c6 (8390)
                                   probe link rx_err tx_err hw
            Link detected: yes
    It is supposed to work on max 1000 mbps but if I leave the card at 1000 mpbs with auto-negotiation, the link does not get detected at the other end. I have an Asus AC router and a Sonicwall Firewall, both supporting 1000 mbps, The same ports on both Asus and Sonicwall does work on 1000 mbps if I connect some other gigabit device to them.

    I have tried forcing the speed on the Ubuntu for the laptop nic to 100 mbps and this works fine, link gets detected and also works at 100 mbps. I used the below command from another thread to do so

    Code:
    sudo ethtool -s enp7s0f5 speed 100 duplex full autoneg on
    Even if I change the 100 to 1000 on the above command the link does not get detected.

    Is there anything else I could try?

    Edit: Changed multiple cable, even tried the cable which works at 1000 mbps on other devices

    Thanks
    Last edited by mahenkpatel; August 7th, 2016 at 12:38 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,632
    Distro
    Ubuntu Development Release

    Re: 16.04: Jmicron Gigabit NIC does not work on 1000 mbps speed

    I don't know any solution to your issue but I wonder if this may be the problem: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1497005
    I have sent an email to JMicron. There is an answer:

    The JMC25x/JMC26x Gigabit Ethernet Chip was mass production at 2008Y, at that time, the IEEE802.3az specification wasn’t ready. So this chip will have a connection issue while connecting to all the IEEE 802.3az enabled devices, that is, if the ‘Speed & Duplex’ feature sets to ”Auto Negotiation” mode or ”1Gbps/Full Duplex” mode, then the link function is abnormal, i.e. link down. Therefore our S/W engineer made a workaround - ASD(Auto-Speed-Down) function to force the LAN speed keeping in 100Mbps when the ‘Speed & Duplex’ feature has been set to “Auto Negotiation” mode or ”1Gbps/Full Duplex” mode.
    My suggestion is to use non-IEEE802.3az Gigabit equipment then your connection speed would keep as 1Gbps.
    I am sorry to say that I interpret this statement: My suggestion is to use non-IEEE802.3az Gigabit equipment then your connection speed would keep as 1Gbps, to mean, 'If you need gigabit speeds, get some other device.'
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •