Results 1 to 5 of 5

Thread: Should I uninstall xserver-xorg-video-intel on Sky Lake?

  1. #1
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,055
    Distro
    Ubuntu 16.04 Xenial Xerus

    Question Should I uninstall xserver-xorg-video-intel on Sky Lake?

    I was looking through synaptic and found a comment under the xserver-xorg-video-intel package (which I assume is the Intel video driver).

    It says:

    This package provides the driver for the Intel i8xx and i9xx family
    of chipsets, including i810, i815, i830, i845, i855, i865, i915, i945
    and i965 series chips.

    This package also provides XvMC (XVideo Motion Compensation) drivers
    for i810/i815 and i9xx and newer chipsets.

    This package is built from the X.org xf86-video-intel driver module.

    The use of this driver is discouraged if your hw is new enough (ca.
    2007 and newer). You can try uninstalling this driver and let the
    server use it's builtin modesetting driver instead.


    If I'm using a new laptop (2015, 6th generation Intel) with the Sky Lake video chipset (HD520), should I in fact uninstall this package?

    Thanks,
    ________________________________
    System76 Lemur Laptop
    Ubuntu Xenial Xerus LTS 16.04
    Linux Registered User #434330

  2. #2
    Join Date
    Feb 2011
    Beans
    17

    Re: Should I uninstall xserver-xorg-video-intel on Sky Lake?

    I just uninstalled and I don't see any loss of performance. And my cursor-problem with light-locker is solved.

    https://bugs.launchpad.net/ubuntu/+s...4/comments/261

    More... about intel drivers...
    http://forums.debian.net/viewtopic.p...128643#p617404

  3. #3
    Join Date
    Feb 2011
    Beans
    17

    Re: Should I uninstall xserver-xorg-video-intel on Sky Lake?


  4. #4
    Join Date
    Feb 2011
    Beans
    17

    Re: Should I uninstall xserver-xorg-video-intel on Sky Lake?

    Quote Originally Posted by bellera View Post
    I just uninstalled and I don't see any loss of performance. And my cursor-problem with light-locker is solved.

    https://bugs.launchpad.net/ubuntu/+s...4/comments/261

    More... about intel drivers...
    http://forums.debian.net/viewtopic.p...128643#p617404
    I have problems with Google Chrome if I remove xserver-org-video-all (in my case xserver-xorg-video-all-lts-xenial) packages. Chrome works very slow and many times I'v got error application at startup.

    Reinstalling the packages solves the problem with Chrome.

    I read at some places that graphics acceleration can cause problems using Chrome, http://www.pcadvisor.co.uk/how-to/in...hrome-3605455/

  5. #5
    Join Date
    Jan 2017
    Beans
    2

    Thumbs up Re: Should I uninstall xserver-xorg-video-intel on Sky Lake?

    Quote Originally Posted by bellera View Post
    I just uninstalled and I don't see any loss of performance. And my cursor-problem with light-locker is solved.

    https://bugs.launchpad.net/ubuntu/+s...4/comments/261

    More... about intel drivers...
    http://forums.debian.net/viewtopic.p...128643#p617404
    This solved the persistent issues I had with tearing / Skylake / i915 / i965. Once I removed xserver-xorg-video-intel, I no longer needed to use the 'TearFree' or CLUTTER_PAINT workarounds.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •