Results 1 to 10 of 10

Thread: DeVeDe vs. k9copy dependency hell in 16.04

  1. #1
    Join Date
    May 2008
    Beans
    152

    DeVeDe vs. k9copy dependency hell in 16.04

    I just performed a fresh install of Ubuntu Mate 16.04 and am trying to restore some of the lost functionality that earlier versions had in dealing with DVDs. The programs I primarily use are k9copy to backup DVD discs, and DeVeDe or DVD Styler to create DVDs.

    The original developer of k9copy stopped development some time ago, but the program has been picked up by others and is now "k9copy-reloaded." I found a ppa for it that seems to work:

    https://launchpad.net/~tomtomtom/+archive/ubuntu/k9copy

    However, when k9copy is installed, the package "libavcodec-ffmpeg-extra56" is uninstalled and "libavcodec-ffmpeg56" is installed in its place. (I assume this means there will be fewer codecs available to ffmpeg.)

    DeVeDe is in the standard Ubuntu repositories. However, if an attempt is made to install that, Synaptic (or apt-get) wants to remove libavcodec-ffmpeg56 that was pulled in by k9copy and replace it with libavcodec-ffmpeg-extra56. If this is done k9copy will also be removed.

    Code:
    # apt-get install devede
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      libavcodec-extra libavcodec-ffmpeg-extra56
    Suggested packages:
      mencoder
    The following packages will be REMOVED:
      k9copy libavcodec-ffmpeg56
    The following NEW packages will be installed:
      devede libavcodec-extra libavcodec-ffmpeg-extra56
    0 upgraded, 3 newly installed, 2 to remove and 12 not upgraded.
    Need to get 5,509 kB of archives.
    After this operation, 1,009 kB disk space will be freed.
    Do you want to continue? [Y/n] n
    Abort.
    Is there any way to resolve this such that both k9copy and DeVeDe can coexist and the extra codecs will be available? (Seems like it should be possible for k9copy to work with the "extras" codec package if that is a superset of the standard package. But it insists on having the less functional codec package installed. )

    I have not found a place yet to obtain DVD Styler binaries compatible with 16.04. I did find and install the Bombono DVD authoring program but am not familiar with it and don't know yet how it will work out.

  2. #2
    Join Date
    Nov 2008
    Location
    Berlin, Germany
    Beans
    75

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Until I can fix the dependencies and the new files will be in the launchpad repo you can try this workaround:

    Download the package
    Code:
    wget https://launchpad.net/~tomtomtom/+archive/ubuntu/k9copy/+files/k9copy_3.0.3-6~ppa~xenial_amd64.deb
    make a directory for the changes
    Code:
    mkdir -p k9copy/DEBIAN
    extract the control file
    Code:
    dpkg -e k9copy_3.0.3-6~ppa~xenial_amd64.deb k9copy/DEBIAN
    extract the content of the package
    Code:
    dpkg -x  k9copy_3.0.3-6~ppa~xenial_amd64.deb k9copy/
    change the dependency in control file
    Code:
    sed -i s/libavcodec-ffmpeg56/"libavcodec-ffmpeg56 | libavcodec-ffmpeg-extra56"/g k9copy/DEBIAN/control
    the packages hast to be rebuild
    Code:
    dpkg -b ./k9copy k9copy_3.0.3-6~ppa~xenial_amd64.deb
    At last the new package can be installed with
    Code:
    sudo dpkg -i k9copy_3.0.3-6~ppa~xenial_amd64.deb
    If you are using a 32 bit system change amd64 in this HowTo to i386.
    Last edited by tomtom1982; May 10th, 2016 at 07:23 AM.

  3. #3
    Join Date
    Feb 2008
    Location
    Land of fire and drought
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Thread moved to Multimedia Software.

  4. #4
    Join Date
    May 2008
    Beans
    152

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Quote Originally Posted by tomtom1982 View Post
    Until I can fix the dependencies and the new files will be in the launchpad repo you can try this workaround: ...
    Great, thanks!

    I just applied the workaround and it worked just fine, I now have k9copy installed along with devede and the extra codecs. (Now I'll have to see if I can find a way to run dvdstyler...)
    Last edited by cbraxton; May 10th, 2016 at 02:21 PM. Reason: Report success with workaround

  5. #5
    Join Date
    Jun 2007
    Beans
    17,218

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Quote Originally Posted by cbraxton View Post
    (Now I'll have to see if I can find a way to run dvdstyler...)
    wxsvg was removed from debian/ubuntu as nothing in their repos depended on.
    Last edited by mc4man; May 10th, 2016 at 09:27 PM.

  6. #6
    Join Date
    Nov 2008
    Location
    Berlin, Germany
    Beans
    75

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    I dputted the new version to canonical build servers.

    When

    Code:
    apt-cache show k9copy
    shows the version

    3.0.3-7~ppa~xenial

    the package with the corrected dependency will be available in the repo.

  7. #7
    Join Date
    May 2008
    Beans
    152

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Hi, just wanted to let you know it looks like there's a typographical error in the dependency for the "extras" library.

    Code:
    # apt-get install k9copy
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     k9copy : Depends: libavcodec-ffmpeg56 but it is not going to be installed or
                       livavcodec-ffmpeg-extra56 but it is not installable
    E: Unable to correct problems, you have held broken packages.
    The package is looking for "livavcodec..." when it should be "libavcodec..." Took me a while to see it!

  8. #8
    Join Date
    Nov 2008
    Location
    Berlin, Germany
    Beans
    75

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    grml

    Fixed in 3.0.3-8. Thanks for feedback.

  9. #9
    Join Date
    May 2008
    Beans
    152

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    Quote Originally Posted by tomtom1982 View Post
    grml

    Fixed in 3.0.3-8. Thanks for feedback.
    Thank you for your efforts in making k9copy available! I've made that kind of mistake many times myself, it's all too easy. It was driving me nuts until I took a real close look at the error message from apt-get.

    I've gone ahead and installed the latest revision from your PPA and it works just fine.

  10. #10
    Join Date
    Jul 2015
    Beans
    4

    Re: DeVeDe vs. k9copy dependency hell in 16.04

    This conflict between Devede and K9copy also existed in Ubuntu 15.10.

    In any case, I am running Ubuntu 16.04 now, and haven't tried to install Devede yet, but K9copy works beautifully. It now copies all audio tracks by default, so you don't have to go through and click on each one beforehand. Thank you, thank you, Tomtomtom!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •