Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

  1. #1
    Join Date
    Apr 2015
    Beans
    10

    A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    i have installed ubuntu 16.04 in my laptop.
    starting ubuntu is fast when i have LAN cabled connected.

    when LAN cable disconnected then it is taking around 5 minutes to get login screen.
    it was showing this message with timer on screen at that long time.
    "A start job is running for raise network interfaces (2 minutes of 5 mins 1 sec)"

    1) how can i skip this delay (5 mins for waiting network).
    like if there are some shortcut keys which i typed then the startup script should not wait for 5 mins, it should directly skip the network interface checking and go to login screen.

    or
    2) how can i permanently stop network interface check only when LAN cable not connected.

    Thanks
    Thani

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    Do you want my guess?

    The system is set up to make a wired connection to the router and to do that automatically. But is cannot complete the task because the ethernet cable is disconnected. So, it tries again and again until finally some part of the OS gets the message.

    There should be an icon on the top panel for the Network Manager. With the cable connected the icon will be two arrows going in the opposite direction. With the cable disconnected the icon will look like an upside down cone. Click on the icon; select Edit Connections; Select Wired Connection; Click Edit; Go to the General tab and untick the box labelled "Automatically connect to this network when it is available."

    In future when you want to make a wired connection to the router, then Click on the Network Manager icon and untick & re-tick Enable Networking. That should prompt Network Manager to start making the wired connection to the router.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Apr 2015
    Beans
    10

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    there is no "Wired Connection" in that dialog panel.
    my ubuntu is 16.04

    Last edited by thaniyarasu-gmail; May 5th, 2016 at 10:30 AM.

  4. #4
    Join Date
    Jun 2006
    Location
    Houston, TX
    Beans
    1,302
    Distro
    Ubuntu 6.06

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    Don't feel bad... I started testing Ubuntu Server 16.04 today and this bit me too. And there is no Network Manager, so it is probably something in the new systemd network services. Sorry, but I do not have a fix yet.

  5. #5
    Join Date
    May 2010
    Location
    uk
    Beans
    9,324
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    Hi

    You may want to read this.

    https://www.freedesktop.org/wiki/Sof...NetworkTarget/

    I would be looking to disable

    Code:
    systemd-networkd-wait-online.service
    or

    Code:
    NetworkManager-wait-online.service
    Look to see which ones are enabled with...

    Code:
    systemctl status systemd-networkd-wait-online.service
    Code:
    systemctl status NetworkManager-wait-online.service
    Disable one and, if it does not fix it, re-enable it and disable the other one.

    Here's an example

    Code:
    sudo systemctl disable systemd-networkd-wait-online.service
    Code:
    sudo systemctl enable systemd-networkd-wait-online.service
    When enabled (and from the website above)

    This will ensure that all configured network devices are up and have an IP address assigned before boot continues.
    Please post back if either work and post which one does work.

    Kind regards
    Last edited by matt_symes; May 5th, 2016 at 06:20 PM.
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  6. #6
    Join Date
    May 2016
    Beans
    2

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    You can reduce the timeout for the job that is trying to raise the network interfaces in the following file.

    Code:
    /etc/systemd/system/network-online.targets.wants/networking.service
    Simply edit the file

    Code:
    sudo vi /etc/systemd/system/network-online.targets.wants/networking.service
    You can change the following line to your preference.

    Code:
    21:TimeoutStartSec=5min
    You will need to reload the daemon as well.

    Code:
    sudo systemctl daemon-reload

    Note: If any of your specified network interfaces fail to respond in your new timeout, it will not be raised. This failure will be indicated at boot when this job is ran.
    Last edited by senpai2; May 13th, 2016 at 01:48 PM.

  7. #7
    Join Date
    Jun 2006
    Location
    Houston, TX
    Beans
    1,302
    Distro
    Ubuntu 6.06

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    Quote Originally Posted by senpai2 View Post
    You can reduce the timeout for the job that is trying to raise the network interfaces in the following file.

    Code:
    /etc/systemd/system/network-online.targets.wants/networking.service
    Simply edit the file

    Code:
    sudo vi /etc/systemd/system/network-online.targets.wants/networking.service
    You are a wonderful person! That worked! Other then that path is actually a link to /lib/systemd/system/networking.service but that was the key!

    Code:
    21:TimeoutStartSec=30sec

  8. #8
    Join Date
    Apr 2015
    Beans
    10

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    i am ok with

    21:TimeoutStartSec=30sec

    Thanks

  9. #9
    Join Date
    Jun 2016
    Beans
    2

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    Quote Originally Posted by houstonbofh View Post
    Don't feel bad... I started testing Ubuntu Server 16.04 today and this bit me too. And there is no Network Manager, so it is probably something in the new systemd network services. Sorry, but I do not have a fix yet.
    The fix for Ubuntu Server is pretty simple: Change the line in /etc/network/interfaces that reads, "auto {Your ethernet adapter's name here}" to "allow-hotplug {Your ethernet adapter's name here}".
    It's waiting for a DHCP reply, if my Wireshark-Fu is correct.

    In my case, that looks like:
    Code:
    #Original Line
    auto ens34
    iface ens34 inet dhcp
    
    #New line
    allow-hotplug ens34
    iface ens34 inet dhcp
    It's reasonable to suggest that setting a static IP would do it too.

    I don't know the equivalent in the GUI stuff.

    If you are indeed rolling with a PC that is hotplugging ethernet (like a laptop), this is the most correct fix, as it informs the system that this network shouldn't be required on startup, and, if you wanted, you could still configure another network that is auto that *is* required on startup.
    Last edited by physicist1616; June 30th, 2016 at 01:20 AM.

  10. #10
    Join Date
    Jul 2016
    Beans
    1

    Re: A start job is running for raise network interfaces (5 mins 1 sec) in ubuntu16.04

    That seems to be not just a workaround, but the actual solution. To me at least
    It seems to me that this is the way that network connections used to work when specifying auto.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •