Results 1 to 6 of 6

Thread: Samba UID /GID issue

  1. #1
    Join Date
    Apr 2016
    Beans
    3

    Samba UID /GID issue

    Hello All

    First time poster so sorry if i post in the wrong place / its a repeat (I did check couldn't seem to find the answer).

    I have two virtual machines using samba 4.1.6 (Come on apt repository). One is setup as a DC and the other is a domain joined file server. Now for typical day to day use this works fine, domain clients can log on and access the file server drives (Mapped through GPO).

    But I have a strange issue where the clients access to the file server will periodically drop out (seemingly random times) and come back again 5 minutes later. I have logging on per machine (Only level 1) and i can see an interesting when looking at the machine log file that says.

    [2016/03/25 12:33:55.602091, 1] ../source3/smbd/sec_ctx.c:85(become_gid)
    WARNING: using gid -1 is a security risk


    I tried googling it and couldn't find any results.

    Anybody got any ideas?

    Thanks

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Samba UID /GID issue

    Moved to the Server Platforms sub-forum

  3. #3
    Join Date
    Nov 2008
    Location
    Boston MetroWest
    Beans
    16,326

    Re: Samba UID /GID issue

    Show us the contents of smb.conf inside of [code][/code] tags.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4
    Join Date
    Apr 2016
    Beans
    3

    Re: Samba UID /GID issue

    Sure here is the conf file file, not all of the shares but the one in question

    Code:
    [global]
    
           netbios name = fileserver0
           security = ADS
           workgroup = MYREALM
           realm = MYREALM.NET
    
           log file = /var/log/samba/%m.log
           log level = 1
    
           socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    
           dedicated keytab file = /etc/krb5.keytab
           kerberos method = secrets and keytab
           winbind refresh tickets = yes
    
           winbind trusted domains only = no
           winbind use default domain = yes
           winbind enum users  = yes
           winbind enum groups = yes
    
    
           vfs objects = acl_xattr
           map acl inherit = yes
           store dos attributes = yes
    
    
    [Profiles$]
            path = /data/Profiles$
            read only = no
            browseable = yes
    
    [TFS]
            path = /datastore/design
            available = yes
            valid users = "+MYREALM.net\Domain Users"
            read only = no
            browseable = yes
            public = no
            writable = yes
            create mask = 0777
            directory mask = 0777

  5. #5
    Join Date
    Nov 2008
    Location
    Boston MetroWest
    Beans
    16,326

    Re: Samba UID /GID issue

    Boy that is an arcane error! My version of smbd runs as root:root, so uid=gid=0. I don't know how gid could get decremented to -1.

    I think you need to post this on the Samba Bugzilla forum. I looked, and though I saw some things that might be related, no one reported your "gid(-1)" error there. This could be a real bug that only the Samba developers can fix.

    Have you tried increasing the server's verbosity by adding a "log level" directive? See "man smb.conf" for details.
    Last edited by SeijiSensei; April 12th, 2016 at 04:40 AM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Apr 2016
    Beans
    3

    Re: Samba UID /GID issue

    Thanks for the reply!

    This is a strange one

    I have submit this bug in the suggested forum

    The link to the bug report for any future reference is https://bugzilla.samba.org/show_bug.cgi?id=11828

    Thanks Again
    Dan

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •