Results 1 to 10 of 171

Thread: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

Threaded View

  1. #1
    Join Date
    Mar 2016

    Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Hi all,

    Thanks to the splendid work detailing how to run Ubuntu 15.10 on the Dell XPS 15 9550 (started by @jchedstrom and followed up by many others) and the latest specific posts on running Ubuntu 16.04 beta (by @Rommel_Lapuz, and others), I decided to open a new thread on the forum for the Ubuntu 16.04 version, share my experience, and discuss any pending issues.

    UPDATE 2016/04/20: I just found another great information resource on running Linux on the XPS15 9550:

    My hardware configuration is (my system shipped mid february):

    • Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
    • 32G DDR4 RAM
    • SSD hard disk (not the usual SAMSUNG reported by others): THNSN51T02U7 NVMe TOSHIBA 1024GB
    • Intel HD530
    • NVIDIAGeForce GTX 960M

    I required a working system with dual boot Ubuntu and Windows 10 (Home edition in my case), and this is what I did:
    0. Update the BIOS to the latest version provided by DELL:

    • I did this from Windows
    • Reboot and enter BIOS (Press F2 when the DELL logo shows up)
    • "Restore to BIOS defaults" before continuing.
    • Exit to reboot

    1. Boot in windows and create recovery disk from the Windows box, in case something goes wrong.
    2. Repartition SSD:

    • I repartitioned from my original Windows Installation with "Minitool Partition Wizard Free" as I was used to it, but you can do this using gparted without problems, using the /dev/nvme0n1 disk.
      • My XPS came with:

    Partition | Capacity | FileS | Type | Status
    *:ESP | 500.00 MB | FAT32 | GPT (EFI System partition) | Active & Boot
    *: | 128.00 MB | Other | GPT (Reserved partition) | None
    C:OS | 941.18 MB | NTFS | GPT (Data partition) | System
    *:WINRETOOLS | 450.00 MB | NTFS | GPT (Recovery partition) | None
    *:Image | 11.63 BB | NTFS | GPT (Recovery partition) | None

    • I resized the windows partition (C:OS) to 100Gb (97.66 in the partition tool)
    • The new partition design is (I didn't bothered with separated / /var /home, etc. partitions):

    Partition | Capacity | FileS | Type | Status
    *:ESP | 500.00 MB | FAT32 | GPT (EFI System partition) | Active & Boot
    *: | 128.00 MB | Other | GPT (Reserved partition) | None
    C:OS | 97.66 MB | NTFS | GPT (Data partition) | System
    *: | 843.52 MB | Unused| GPT (Data partition) | None
    *:WINRETOOLS | 450.00 MB | NTFS | GPT (Recovery partition) | None
    *:Image | 11.63 BB | NTFS | GPT (Recovery partition) | None

    3. Disable fast boot option in windows:

    • In Windows 10, run "Control Panel | Hardware and sound | Power Options | Choose what the power buttons do", and at the bottom you'll see "Shutdown settings", with "Turn o fast startup (recommended)", which I disabled.
    • I also had the "Hibernate" option disabled by default, and I let it that way

    4. Get ready for booting windows in Safe mode afterwards:

    • Tthis is required to allow successful boot after changing the RAID to AHCI SATA configuration)
    • While in Windows, WIN+R and execute "msconfig"
    • Go to "Boot" and select "Safe mode boot". I left "Minimal" selected

    5. Reboot and enter BIOS (Press F2 when the DELL logo shows up)

    • "Secure Boot" | "Secure Boot Enable": Change from "Enabled" to "Disabled"
    • "System Configuration" | "SATA Operation": Change from "RAID On" to "AHCI"
    • Apply changes and save everything, and finally "Exit", to reboot

    6. Enter windows. It will show up in Safe mode.

    • In my case I was not able to run msconfig with the WIN+R key, so that I pressed the "Start button" on screen, selected "All applications" and search for "Administrative Tools" and "System Configuration". Then go to the "Boot" tab again and unselect "Safe mode boot". Accept and shutdown.

    7. Insert 16.04 USB stick (the one I downloaded dated late february), reboot, and enter BIOS again.

    • Go to "General" | "Boot sequence", and move the USB stick entry to the top.
    • Apply, save eveything, and "Exit" to reboot.
    • In my system I had "Windows Boot Manager", and then the "THNSN51T02U7 NVMe TOSHIBA 1024GB".

    8. Enter ubuntu and run installation or run the installer in the Grub Menu.

    • I partitioned ALL the unused disk space in 16Gb SWAP (JIC ) and / (I know this is not wise, but that's it)

    • The system installed perfectly and I had wifi+touchpad+sleep+shutdown+reboot working out of the box, with a 4k display resolution and tiny sized for everything

    Desktop and additional issues/comments:

    • Function buttons working: mute, volume up and down, keyboard backlit (off, mid, high intensity), display brightness up and down).
    • I'm fan of the "Gnome flashback" desktop, but after installation it didn't work: I couldn't make to appear the right part of the top panel (that with notifiers, and the system menu), and neither the bottom panel with the application list showed up . If you have any clue, I'll really appreciate hints on this issue.
    • I finally decide to run the cinnamon desktop (given its suposedly reported ability to run hidpi natively). It works reasonbly well, but I still have some annoying issues. Mainly:
      • The battery information in the panel does not update!!! (UPDATE 2016/04/30 Updating to cinammon 3.0 fixed the problem (follow information on (just add ppa:embrosyn/cinnamon, update and upgrade))
      • The touchpad is "lost" sometimes (didn't look into this issue yet)

    • To avoid tiny fonts in the Grub screen, add GRUB_GFXMODE=1024x768 to /etc/default/grub and run sudo update-grub

    • Regarding the use of NVIDIA/intel:
      • From the applications menu, I selected "Preferences|Additional drivers", and selected to use the "NVIDIA binary driver - version 361.28 from nvidia-361 (privative, tested). Then apply changes.
      • I installed nvidia-prime
      • Now I can run nvidia-settings and select either NVIDIA GPU (Performance Mode) or Intel (Power Saving Mode).
      • Others reported various stories when using the PPA NVIDIA repositories. I didn't tested them yet.

    • Regarding Bluetooth support
      • Bluetooth seemed to be detected (according to the notification area), but it didn't actually work.
      • dmesg showed an error related to a firmware not found:
        ...Direct firmware load for brcm/BCM-0a5c-6410.hcd failed...
      • Following I downloaded the missing firmware file (thanks @ZombieMeat) at Dropbox and copied it to /lib/firmware/brcm/
      • Reboot and bluetooth is working (tested at least with a bluetooth speaker)

    • Problems with palm detection on the touchpad. deals with it
      • In my XPS, xinput reports having two touchpads (?):
        • DLL06E4:01 06CB:7A13 Touchpad id=13 [slave pointer (2)]
        • SynPS/2 Synaptics TouchPad id=15 [slave pointer (2)]

      • I played with id=15 first, without success, but with id=13, things seem to work. This is what I added to startup programs:
        • xinput set-prop 13 "Synaptics Palm Detection" 1
        • xinput set-prop 13 "Synaptics Palm Dimensions" 5, 5

      • If you still had problems with detection on edges, you can apply ideas shown in
      • I still have problems to avoid the palm to be undetected and I'm still investigating. If you happen to get usable parameters for the xinput props, please let me know:
        • Update 2016/04/05; I also added "/usr/bin/syndaemon -i 1 -K -d" to the startup applications to disable touchpad while typing. Still not fully tested if that makes a difference
        • Update 2016/04/30: Following I added file /etc/modprobe.d/synaptics.conf with "blacklist i2c-designware-platform" and now disable touchpad when typing works (still have to check if there are any additional side-effects)

    • Update 2016/04/05: Issues with the DA-200 USB-C to VGA,HDMI,USB,Ethernet dongle:
      • Ethernet only worked when the DA-200 was connected at boot time, and after each suspend-resume it didn't worked either. @jsla7527 at the 15.10 thread gives a solution to force usb-c rescanning. You need to run the following command after plugging anything into USB-C port:
        • sudo sh -c "echo 1 > /sys/bus/pci/rescan"

      • VGA works even whithout the rescan command, but I get random system freezes. Other people reported freezes with HDMI connections, but I haven't investigated this so far. Update 2016/05/17: I upgraded to kernel 4.6 (as I read that there were improvements in the skylake support for 9350, that I suspected could also benefit 9550) and the VGA connection of the DA-200 seems to work properly (no more flickering nor hangs up during the first two hours of test). I'm using the intel prime profile and will check later what if using nvidia.

    • Update 2016/04/20: Sensors detection (from
      • apt-get install lm-sensors
      • sensors-detect
      • Follow instructions and modify /etc/modules as instructed

    So, my pending not-fully-working issues are:

    • Palm detection: Working parameters are needed
    • Gnome flashback not working
    • Cinnamon: battery info in the panel notification area does not update
    • Touch pad: Breaks from time to time. Update 2016/04/05: No breaks from a couple of weeks ago. I guess 16.04 updates did the trick.
    • Update 2016/04/05: VGA connection through DA-200 randomly freezes the system.

    That's it for now. I'll try to do some power demands calculations and keep you posted (some results are already available from @bertusrex at the original 15.10 thread).

    Last edited by Javier_Macias-Guar; May 17th, 2016 at 03:48 PM. Reason: Update on DA200 VGA connection after upgrade to kernel 4.6

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts