Page 1 of 18 12311 ... LastLast
Results 1 to 10 of 171

Thread: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

  1. #1
    Join Date
    Mar 2016
    Beans
    11

    Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Hi all,

    Thanks to the splendid work detailing how to run Ubuntu 15.10 on the Dell XPS 15 9550 (started by @jchedstrom and followed up by many others) and the latest specific posts on running Ubuntu 16.04 beta (by @Rommel_Lapuz, and others), I decided to open a new thread on the forum for the Ubuntu 16.04 version, share my experience, and discuss any pending issues.

    UPDATE 2016/04/20: I just found another great information resource on running Linux on the XPS15 9550: http://wiki.yobi.be/wiki/Laptop_Dell_XPS_15

    My hardware configuration is (my system shipped mid february):

    • Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
    • 32G DDR4 RAM
    • SSD hard disk (not the usual SAMSUNG reported by others): THNSN51T02U7 NVMe TOSHIBA 1024GB
    • Intel HD530
    • NVIDIAGeForce GTX 960M


    I required a working system with dual boot Ubuntu and Windows 10 (Home edition in my case), and this is what I did:
    0. Update the BIOS to the latest version provided by DELL:

    • I did this from Windows
    • Reboot and enter BIOS (Press F2 when the DELL logo shows up)
    • "Restore to BIOS defaults" before continuing.
    • Exit to reboot

    1. Boot in windows and create recovery disk from the Windows box, in case something goes wrong.
    2. Repartition SSD:

    • I repartitioned from my original Windows Installation with "Minitool Partition Wizard Free" as I was used to it, but you can do this using gparted without problems, using the /dev/nvme0n1 disk.
      • My XPS came with:


    Partition | Capacity | FileS | Type | Status
    *:ESP | 500.00 MB | FAT32 | GPT (EFI System partition) | Active & Boot
    *: | 128.00 MB | Other | GPT (Reserved partition) | None
    C:OS | 941.18 MB | NTFS | GPT (Data partition) | System
    *:WINRETOOLS | 450.00 MB | NTFS | GPT (Recovery partition) | None
    *:Image | 11.63 BB | NTFS | GPT (Recovery partition) | None

    • I resized the windows partition (C:OS) to 100Gb (97.66 in the partition tool)
    • The new partition design is (I didn't bothered with separated / /var /home, etc. partitions):

    Partition | Capacity | FileS | Type | Status
    *:ESP | 500.00 MB | FAT32 | GPT (EFI System partition) | Active & Boot
    *: | 128.00 MB | Other | GPT (Reserved partition) | None
    C:OS | 97.66 MB | NTFS | GPT (Data partition) | System
    *: | 843.52 MB | Unused| GPT (Data partition) | None
    *:WINRETOOLS | 450.00 MB | NTFS | GPT (Recovery partition) | None
    *:Image | 11.63 BB | NTFS | GPT (Recovery partition) | None


    3. Disable fast boot option in windows:

    • In Windows 10, run "Control Panel | Hardware and sound | Power Options | Choose what the power buttons do", and at the bottom you'll see "Shutdown settings", with "Turn ohttp://ubuntuforums.org/newthread.php?do=newthread&f=332n fast startup (recommended)", which I disabled.
    • I also had the "Hibernate" option disabled by default, and I let it that way

    4. Get ready for booting windows in Safe mode afterwards:

    • Tthis is required to allow successful boot after changing the RAID to AHCI SATA configuration)
    • While in Windows, WIN+R and execute "msconfig"
    • Go to "Boot" and select "Safe mode boot". I left "Minimal" selected

    5. Reboot and enter BIOS (Press F2 when the DELL logo shows up)

    • "Secure Boot" | "Secure Boot Enable": Change from "Enabled" to "Disabled"
    • "System Configuration" | "SATA Operation": Change from "RAID On" to "AHCI"
    • Apply changes and save everything, and finally "Exit", to reboot

    6. Enter windows. It will show up in Safe mode.

    • In my case I was not able to run msconfig with the WIN+R key, so that I pressed the "Start button" on screen, selected "All applications" and search for "Administrative Tools" and "System Configuration". Then go to the "Boot" tab again and unselect "Safe mode boot". Accept and shutdown.

    7. Insert 16.04 USB stick (the one I downloaded dated late february), reboot, and enter BIOS again.

    • Go to "General" | "Boot sequence", and move the USB stick entry to the top.
    • Apply, save eveything, and "Exit" to reboot.
    • In my system I had "Windows Boot Manager", and then the "THNSN51T02U7 NVMe TOSHIBA 1024GB".

    8. Enter ubuntu and run installation or run the installer in the Grub Menu.

    • I partitioned ALL the unused disk space in 16Gb SWAP (JIC ) and / (I know this is not wise, but that's it)



    • The system installed perfectly and I had wifi+touchpad+sleep+shutdown+reboot working out of the box, with a 4k display resolution and tiny sized for everything


    Desktop and additional issues/comments:

    • Function buttons working: mute, volume up and down, keyboard backlit (off, mid, high intensity), display brightness up and down).
    • I'm fan of the "Gnome flashback" desktop, but after installation it didn't work: I couldn't make to appear the right part of the top panel (that with notifiers, and the system menu), and neither the bottom panel with the application list showed up . If you have any clue, I'll really appreciate hints on this issue.
    • I finally decide to run the cinnamon desktop (given its suposedly reported ability to run hidpi natively). It works reasonbly well, but I still have some annoying issues. Mainly:
      • The battery information in the panel does not update!!! (UPDATE 2016/04/30 Updating to cinammon 3.0 fixed the problem (follow information on http://www.webupd8.org/2016/04/how-t...in-ubuntu.html (just add ppa:embrosyn/cinnamon, update and upgrade))
      • The touchpad is "lost" sometimes (didn't look into this issue yet)

    • To avoid tiny fonts in the Grub screen, add GRUB_GFXMODE=1024x768 to /etc/default/grub and run sudo update-grub


    • Regarding the use of NVIDIA/intel:
      • From the applications menu, I selected "Preferences|Additional drivers", and selected to use the "NVIDIA binary driver - version 361.28 from nvidia-361 (privative, tested). Then apply changes.
      • I installed nvidia-prime
      • Now I can run nvidia-settings and select either NVIDIA GPU (Performance Mode) or Intel (Power Saving Mode).
      • Others reported various stories when using the PPA NVIDIA repositories. I didn't tested them yet.



    • Regarding Bluetooth support
      • Bluetooth seemed to be detected (according to the notification area), but it didn't actually work.
      • dmesg showed an error related to a firmware not found:
        ...Direct firmware load for brcm/BCM-0a5c-6410.hcd failed...
      • Following https://bbs.archlinux.org/viewtopic.php?id=204739 I downloaded the missing firmware file (thanks @ZombieMeat) at Dropbox and copied it to /lib/firmware/brcm/
      • Reboot and bluetooth is working (tested at least with a bluetooth speaker)





    • Problems with palm detection on the touchpad. http://stevenkohlmeyer.com/fixing-pa...-ubuntu-14-04/ deals with it
      • In my XPS, xinput reports having two touchpads (?):
        • DLL06E4:01 06CB:7A13 Touchpad id=13 [slave pointer (2)]
        • SynPS/2 Synaptics TouchPad id=15 [slave pointer (2)]

      • I played with id=15 first, without success, but with id=13, things seem to work. This is what I added to startup programs:
        • xinput set-prop 13 "Synaptics Palm Detection" 1
        • xinput set-prop 13 "Synaptics Palm Dimensions" 5, 5

      • If you still had problems with detection on edges, you can apply ideas shown in http://ubuntuforums.org/showthread.php?t=2153813
      • I still have problems to avoid the palm to be undetected and I'm still investigating. If you happen to get usable parameters for the xinput props, please let me know:
        • Update 2016/04/05; I also added "/usr/bin/syndaemon -i 1 -K -d" to the startup applications to disable touchpad while typing. Still not fully tested if that makes a difference
        • Update 2016/04/30: Following http://wiki.yobi.be/wiki/Laptop_Dell_XPS_15#Touchpad I added file /etc/modprobe.d/synaptics.conf with "blacklist i2c-designware-platform" and now disable touchpad when typing works (still have to check if there are any additional side-effects)


    • Update 2016/04/05: Issues with the DA-200 USB-C to VGA,HDMI,USB,Ethernet dongle:
      • Ethernet only worked when the DA-200 was connected at boot time, and after each suspend-resume it didn't worked either. @jsla7527 at the 15.10 thread gives a solution to force usb-c rescanning. You need to run the following command after plugging anything into USB-C port:
        • sudo sh -c "echo 1 > /sys/bus/pci/rescan"

      • VGA works even whithout the rescan command, but I get random system freezes. Other people reported freezes with HDMI connections, but I haven't investigated this so far. Update 2016/05/17: I upgraded to kernel 4.6 (as I read that there were improvements in the skylake support for 9350, that I suspected could also benefit 9550) and the VGA connection of the DA-200 seems to work properly (no more flickering nor hangs up during the first two hours of test). I'm using the intel prime profile and will check later what if using nvidia.

    • Update 2016/04/20: Sensors detection (from http://wiki.yobi.be/wiki/Laptop_Dell_XPS_15#Sensors):
      • apt-get install lm-sensors
      • sensors-detect
      • Follow instructions and modify /etc/modules as instructed



    So, my pending not-fully-working issues are:

    • Palm detection: Working parameters are needed
    • Gnome flashback not working
    • Cinnamon: battery info in the panel notification area does not update
    • Touch pad: Breaks from time to time. Update 2016/04/05: No breaks from a couple of weeks ago. I guess 16.04 updates did the trick.
    • Update 2016/04/05: VGA connection through DA-200 randomly freezes the system.


    That's it for now. I'll try to do some power demands calculations and keep you posted (some results are already available from @bertusrex at the original 15.10 thread).


    Javi
    Last edited by Javier_Macias-Guar; May 17th, 2016 at 03:48 PM. Reason: Update on DA200 VGA connection after upgrade to kernel 4.6

  2. #2
    Join Date
    Aug 2011
    Beans
    10

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    THANKS A LOT MAN!
    I am about to buy this laptop and I was wondering if ubuntu 16.04 fixes the problems I've been reading about and also I was unsure about how to dual boot; you have answered in great detail thanks!
    Last edited by Tazza101; March 20th, 2016 at 08:45 PM.

  3. #3
    Join Date
    Aug 2007
    Beans
    10

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Touchpad palm detection might work with kernel 4.5?
    https://github.com/advancingu/XPS13Linux/issues/3
    Last edited by holdfenytolvaj; March 21st, 2016 at 06:36 AM.

  4. #4
    Join Date
    Mar 2016
    Beans
    3

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    I've been running 16.04 for a couple of weeks now. I largely followed the same path as the OP using the instructions on the 15.10 thread, but used the non-tested 361 Nvidia driver as I found the tested version gave me lots of issues (go figure). I can swap between the GPUs okay and bluetooth works.

    The system is getting more stable everyday with only a couple of key issues, below. I find I'm getting ~6.5 hours life out the battery, or more, and this includes coding, compiling, some docker containers running and the usual supporting web and email - so okay; it includes multiple suspends (close lid) with no significant drain when suspended. That said I get nowhere near some of the values out of powertop (~5-6W) other report at idle; more like 11W+. But I'm happy enough with the battery life for my usage, though getting it up to the nearer 9-10 hours I can get on Windows would be great.

    Issues that are annoying:


    • After suspend I cannot power off or restart without commandline using -f;
    • The touchpad is still pretty rubbish, but (just about) liveable


    Thanks as always to all the contributors - it's great to see the community working so hard getting issues resolved and changing over the last couple of weeks from what was a marginally unusable installation into a robust system that I now use as my daily machine.

  5. #5
    Join Date
    Mar 2016
    Beans
    2

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Hi,

    I am using ubuntu 16.04 on the dell 9550 laptop, too. The hardware is basically the same as mentioned in the first post from . I can confirm that bluetooth does not work at the fist place but copying the firmware file will fix it and I was able to connect to my phone via bluetooth. Touchpad works for me altouh i can see 2 touchpads.
    But I am having troubles with my second monitor. I have an external monitor connected via HDMI and every time i power on the computer the whole system will freeze after I have logged on. I cannot move the mouse nor enter any keyboard commands. This happens with both grafikcards, Intel and the Nvidia. Does anyone have a solution for the problem? I have tried reinstalling and reconfiguration of the X server with no change in output. Is this a general skylake problem?

    uname -r
    4.4.0-13-generic
    X -version
    X.Org X Server 1.18.1
    Release Date: 2016-02-08
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.13.0-79-generic x86_64 Ubuntu
    xorg-server 2:1.18.1-1ubuntu4 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.33.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    sudo ubuntu-drivers devices
    vendor : NVIDIA Corporation
    model : GM107M [GeForce GTX 960M]
    driver : nvidia-361-updates - distro non-free
    driver : xserver-xorg-video-nouveau - distro free builtin
    driver : nvidia-361 - distro non-free recommended

    == cpu-microcode.py ==
    driver : intel-microcode - distro non-free

  6. #6
    Join Date
    Mar 2016
    Beans
    4

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Im running 16.04 and struggling with freezes if external monitor is connected with HDMI. Booting with connected monitor is not possible. Running nvidia-prime, mainly on Intel-GPU. Tested NVIDIA binary driver in version 358.16, 361.20 and 364.12 without success.

    Any hints for me?

    Thx
    Huaba

  7. #7
    Join Date
    Oct 2006
    Location
    Ayrshire.
    Beans
    55,000
    Distro
    Ubuntu Development Release

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Moved to the "Ubuntu Development Version" forum.

  8. #8
    Join Date
    Mar 2016
    Beans
    2

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Hello huaba-net,
    I have had the same problem like you. To disappoint you right away I don't have a perfect solution, just a dirty fix. My problem is the same, the system freezed at the log in screen when the monitor was connected via HDMI (Dell U2414h). No reaction to keyboard entries nor any loging in the kern.log or Xorg.log... However when the laptop booted up completely and I logged in, with the external monitor disconnected, everything worked fine. When I plugged it in while the system was running, the monitor was correctly recognized and it worked perfectly. But I did not what to connect and disconnect the HDMI cable every time I booted the system. So what I did was t active the nvidia card via the prime indicator http://www.webupd8.org/2014/01/prime...ly-switch.html. Connected my Second monitor and adjusted everything correctly. The I rebooted system and added the line "nouveau.modeset=1" to the grub command line and pressed F10. The kernel booted, both monitors where running and I was able to log in with no freezes. Right after logged in, I change the grub command line in /etc/default/grub to contain "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0" and ran an sudo update-grub. Now it works more or less like charm. Sometimes I get CRTC-63 error and left and right monitors are switched. Logging in and out will restore the settings.
    It is not possible for me to use the Intel card with both monitors connected.

  9. #9
    Join Date
    Mar 2016
    Beans
    1

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Hey guys,

    Firstly, thanks for all the hard work and info in this thread ant the 15.10 thread. I just got my XPS yesterday and got Ubuntu on with only minor trouble in a few hours. My main issue currently is the touchpad. But not with palm rejection. Basically if I am moving the cursor with my middle finger, then go to click with my pointer finger, many times the cursor jumps. It seems as though it thinks that my finger quickly moved from point to point and is like oh snap let me move there. I'm not sure if this is a pressure thing or a timing thing. But it is frustrating as all heck. Go to click something and randomly jump somewhere else, or worse, click something else. The other way for me to reproduce the jump is to simply tap with my middle immediately followed by my pointer tap. The further my fingers are apart the further it jumps. The direction between my fingers is also the direction. So it definitely seems like it isn't really recognizing both fingers or something.

    Any help would be appreciated. So far everything else seems to be working!

  10. #10
    Join Date
    Dec 2009
    Beans
    13

    Re: Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch)

    Same laptop as OP, installation went on without problems but network is not working. Really stuck, can't figure out how to solve this one.

    The Wifi is connected to the router according to the networking icon, no data is going through. If I reconnect to the router the network is ok for a few seconds and then new connections (as in TCP conns) are not accepted anymore. This means that I can't update Ubuntu because the Wifi will drop the connections and nothing will be downloaded. I tried with an external USB Wifi and ended up with the same result so I suspect that the problem is networking and not the card itself.
    The network card seems to be working, no logs that relates to networking as far as I can see and the driver and firmware for the card is in place.
    Network card is a Broadcom BCM43602
    Driver brcmfmac version 7.35.177.61

    I've been using the March 25 release of 16.04 Desktop amd64.

Page 1 of 18 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •