Results 1 to 4 of 4

Thread: problem booting ubuntu

Threaded View

  1. #1
    Join Date
    Sep 2010
    Beans
    10

    problem booting ubuntu

    I've been a long time Ubuntu user (8 years)
    I just bought a brand new laptop ACER ASPIRE V5-591G-588D. It came with no OS (just basic linpus with no GUI, instead of freedos). I want to have 2 OS - Windows 10 (just in case) and Ubuntu. First I installed Windows 10. During the install process I created 4 partitions. 2 for windows (1 for data and one for the windows himself) and 2 for ubuntu (1 for root and 1 for home). There was already 1 partition, which I'm pretty sure was the EFI. After creating the main windows partition it created one small (16 mb) MBR partition. The installation went well. After that I installed ubuntu (14.04.4). The installation went just fine, but it turned out that I can't boot into ubuntu. Every time it booted windows. I tried fixing the boot menus with easybcd, but it wasn't successful. I tried using boot-repair, efibootmgr reinstalling ubuntu several times but nothing worked. Then I wiped everything from the HDD and created a new partition table - GPT using gparted. It consists of:
    1. Boot partition (500 mb). I putted the boot flag on it. Filesystem FAT32
    2. unnallocated (reserved for windows)
    3. ubuntu root (30 gb)
    4. ubuntu home (~400 gb)
    5. linux-swap (8 gb)
    Then I proceeded with ubuntu installation, but it was still not booting. It says there is no boot media.
    My BIOS configuration is:
    UEFI: ON
    Secure boot: Disabled (tried both)
    Boot order: 1. Windows boot manager (even though there is no windows on the computer), 2.HDD0, 3.HDD1, 4.USB-HDD and so on. When I tried to lower the priority of windows boot manager, it still tries to boot in windows and continues to not see ubuntu at all. I can't erase this windows boot manager and I am starting to think that this option is part of the uefi firmware of the computer. In any case It just wants to boot windows and nothing else.
    I wonder why it shows windows boot manager if there is no windows at all. I expect to see ubuntu there (in the boot menu), but there is nothing and through all my reinstalls it never showed up.
    What's wrong with my installation? Is it the EFI partition or something in the BIOS config? If I use legacy bios instead of uefi the windows boot manager disappears. Then I might be able to install ubuntu, but no windows. The computer also does not support any older versions of windows.
    Last edited by ilia_avramov; March 13th, 2016 at 09:16 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •