Results 1 to 4 of 4

Thread: Unable to set Google Chrome as default Browser

  1. #1
    Join Date
    Dec 2005
    Beans
    9

    Unable to set Google Chrome as default Browser

    After the first installation of Google Chrome it automatically set the default web browser under Settings -> Details -> Default Applications to Google Chrome. I had to change this to Firefox as one of the application did not open links properly in Chrome.

    When I tried to set the default browser back to Google Chrome, there was no such option in Settings.



    If have tried to rectify the issue with the following commands:

    Code:
    sudo update-alternatives --config x-www-browser
    Code:
    cat ~/.local/share/applications/mimeapps.list
    
    [Default Applications]
    text/html=google-chrome.desktop
    x-scheme-handler/http=google-chrome.desktop
    x-scheme-handler/https=google-chrome.desktop
    x-scheme-handler/about=google-chrome.desktop
    x-scheme-handler/unknown=google-chrome.desktop
    Code:
    cat ~/.bashrc
    
    # Default Browser
    export BROWSER=/usr/bin/google-chrome
    Reinstall and purge all Google Chrome settings.

    Links still does not open in Google Chrome.

    What else can I try?
    Last edited by carelburger; March 8th, 2016 at 10:00 AM. Reason: Added Tags

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,540
    Distro
    Ubuntu

    Re: Unable to set Google Chrome as default Browser

    Set it in chrome.
    In chrome go to Edit menu, then preferences.
    The place to set chrome as the default is at the bottom.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Dec 2005
    Beans
    9

    Re: Unable to set Google Chrome as default Browser

    I have tried this before. It has no effect. Even if I change the default to Firefox it still thinks it is the default browser.

    Quote Originally Posted by deadflowr View Post
    Set it in chrome.
    In chrome go to Edit menu, then preferences.
    The place to set chrome as the default is at the bottom.

  4. #4
    Join Date
    Dec 2005
    Beans
    9

    Re: Unable to set Google Chrome as default Browser

    I was able to fix the issue.

    Code:
    gedit ~/.config/mimeapps.list
    Change all firefox.desktop to google-chrome.desktop.
    Last edited by carelburger; March 15th, 2016 at 10:51 AM. Reason: Found solution

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •