Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Getting error when trying to update Ubuntu

  1. #1
    Join Date
    Mar 2016
    Beans
    18

    Getting error when trying to update Ubuntu

    user@ip-10-153-174-8:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    apache2-utils apache2.2-bin firefox-locale-en g++-4.6 guile-1.8-libs libmpc2
    libstdc++6-4.6-dev linux-headers-3.2.0-37 linux-headers-3.2.0-37-virtual
    ttf-dejavu-core
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up keyboard-configuration (1.70ubuntu8) ...
    iconv: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory
    dpkg: error processing package keyboard-configuration (--configure):
    subprocess installed post-installation script returned error exit status 127
    Errors were encountered while processing:
    keyboard-configuration
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Getting error when trying to update Ubuntu

    1 not fully installed or removed.
    What were you doing that might have caused that comment? This will fix broken packages. Which may help.

    Code:
    sudo apt-get install -f
    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Getting error when trying to update Ubuntu

    Which version of Ubuntu are you using?

    I think the packages linux-headers-3.2.0-37 and linux-headers-3.2.0-37-virtual were from 12.04, precise but just want to be certain as you may have upgraded to another version but left those header packages installed.

  4. #4
    Join Date
    Mar 2016
    Beans
    18

    Re: Getting error when trying to update Ubuntu

    I tried "sudo apt-get install -f", but still received the same error.

    ajgreeny: I am using Ubuntu 14.04.4 LTS (GNU/Linux 3.13.0-79-generic x86_64)

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,286
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Getting error when trying to update Ubuntu

    Did you run "sudo apt-get update" before "sudo apt-get upgrade"? The update fetches the most current file lists from the repositories and should always be run before an upgrade.

    Run the "update" command, then try the "upgrade" again.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Mar 2016
    Beans
    18

    Re: Getting error when trying to update Ubuntu

    SeijiSensei, thanks for the suggestion.

    I did run a update before upgrade.

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,679
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Getting error when trying to update Ubuntu

    jay119; Hello ;

    Need to find out why the system is complaining about " keyboard-configuration " .
    Setting up keyboard-configuration (1.70ubuntu8) ...
    iconv: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory
    dpkg: error processing package keyboard-configuration (--configure):
    subprocess installed post-installation script returned error exit status 127
    Errors were encountered while processing:
    keyboard-configuration
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    We need to find out the origin of " libiconv.so.2 " What is it and where did it come from ? Presently I do not have a clue .

    Keeping in mind that :
    The following packages were automatically installed and are no longer required:
    apache2-utils apache2.2-bin firefox-locale-en g++-4.6 guile-1.8-libs libmpc2
    libstdc++6-4.6-dev linux-headers-3.2.0-37 linux-headers-3.2.0-37-virtual
    ttf-dejavu-core
    a virtual install may have something to do with this.

    So what is installed for "keyboard-configuration" ?
    Code:
    dpkg -l keyboard-configuration
    apt-cache policy keyboard-configuration
    sometime I wonder
    other times I want to find out
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  8. #8
    Join Date
    Mar 2016
    Beans
    18

    Re: Getting error when trying to update Ubuntu

    Bashing-om, thanks for your reponse. This is what I get when I run the commands.

    Code:
    user@ip-10-153-174-8:~$ dpkg -l keyboard-configuration
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    
    user@ip-10-153-174-8:~$ apt-cache policy keyboard-configuration
    keyboard-configuration:
      Installed: 1.70ubuntu8
      Candidate: 1.70ubuntu8
      Version table:
     *** 1.70ubuntu8 0
            500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
            100 /var/lib/dpkg/status
    iF  keyboard-confi 1.70ubuntu8  all          system-wide keyboard preferences
    Last edited by ajgreeny; March 8th, 2016 at 11:42 AM. Reason: Code tags added for clarity

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,679
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Getting error when trying to update Ubuntu

    jay119; Well ..

    Tough to make out with the results NOT within code tags:
    code tag tutorial:
    http://ubuntuforums.org/showthread.p...8#post12776168

    Is this what we are looking at ?
    iF keyboard-confi 1.70ubuntu8 a
    where 1.70ubuntu8 is the correct version.
    Then maybe see what the package manager does with terminal command:
    Code:
    sudo dpkg-reconfigure keyboard-configuration
    see if the system will fix it for us, or give us a hint at what it needs .

    what does it take
    to keep a package manager
    satisfied
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  10. #10
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,286
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Getting error when trying to update Ubuntu

    In case you don't know, libiconv translates between character sets. I can understand why a keyboard utility would need that library. There's a command-line program called iconv as well; see "man iconv" for details. I've used it to convert ISO-8859-1 files to UTF-8.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •