Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Strange networking problem

  1. #1
    Join Date
    Oct 2007
    Beans
    Hidden!

    Strange networking problem

    My Arch machine will not ping past my router. It receives an ip via DHCP, it can ping the router, but it won't go past that point.

    I'm using a Netgear wireless router but this particular machine is wired directly to the router. I have rebooted the cable modem, the router, and the machine, with no sucess.

    My wife's XP machine (also wired directly to the router) works fine as does my laptop on it's wireless connection.

    I logged into the router on my wife's machine and the router does list the Arch box as being connected.

    Any suggestions?
    Last edited by will1911a1; May 13th, 2008 at 01:23 PM. Reason: details

  2. #2
    Join Date
    May 2007
    Location
    East Yorkshire, England
    Beans
    Hidden!

    Re: Strange networking problem

    Does your router have an error log or something?
    Website | Blog | The Arch Hurd Project

    If you want to ask about something I posted, send a PM, as I don't watch many threads

  3. #3
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Strange networking problem

    Quote Originally Posted by Barrucadu View Post
    Does your router have an error log or something?
    It does have logs. I checked them and found nothing unusual.

  4. #4
    Join Date
    Aug 2005
    Beans
    6,024

    Re: Strange networking problem

    Do you have a default route? route -n should tell you

    In your /etc/rc.conf file did you remove the exclamation mark before gateway?

    Code:
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(gateway)
    The default is ROUTES=(!gateway) you need to remove the "!"

  5. #5
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Strange networking problem

    Quote Originally Posted by mips View Post
    Do you have a default route? route -n should tell you

    In your /etc/rc.conf file did you remove the exclamation mark before gateway?

    Code:
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(gateway)
    The default is ROUTES=(!gateway) you need to remove the "!"
    I have to get to work, but I'll double check that when I take my lunch break. I believe it's already done (everything's been working fine for weeks up till this point) but I'll have a look at it and get back to you.

    Thanks for the suggestion.

  6. #6
    Join Date
    May 2007
    Location
    East Yorkshire, England
    Beans
    Hidden!

    Re: Strange networking problem

    Did you install a kernel update recently? I did and things went a little dodgy with my video driver, and with HAL.
    Website | Blog | The Arch Hurd Project

    If you want to ask about something I posted, send a PM, as I don't watch many threads

  7. #7
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Strange networking problem

    Quote Originally Posted by Barrucadu View Post
    Did you install a kernel update recently? I did and things went a little dodgy with my video driver, and with HAL.
    Nope, no kernel updates lately.

  8. #8
    Join Date
    Nov 2006
    Location
    40.31996,-80.607213
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Strange networking problem

    Maybe a DNS problem? just a guess.
    "Security lies within the user of who runs the system. Think smart, live safe." - Dr Small
    Linux User #441960 | Wiki: DrSmall

  9. #9
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Strange networking problem

    Quote Originally Posted by Dr Small View Post
    Maybe a DNS problem? just a guess.
    That's another thing I want to check. I get off work in another hour or so and I'll be trying some stuff once I get home. I'll let you guys know how it turns out.

    I really appreciate the suggestions, by the way.

  10. #10
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Strange networking problem

    Looks like iptables was the culprit. I stopped it and everything went back to normal.

    I'm not sure what happened though. I haven't changed my iptables configuration lately and it's been working fine for weeks.

    Anyway thanks for the suggestions guys.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •