Results 1 to 4 of 4

Thread: Weak wifi signal after Ubuntu 14.04 install

  1. #1
    Join Date
    Nov 2015
    Beans
    2

    Weak wifi signal after Ubuntu 14.04 install

    I recently installed Ubuntu 14.04 on my Lenovo Z70-80. The laptop came pre-installed with a Qualcomm Atheros WirelessNIC for which linux drivers have not been written yet and I had no signal at all (wired worked, though). So I replaced it with an Intel 7265AC wireless card and now I have wifi, although I have to be very near whatever WAP I happen to be using or the signal is almost completely lost. I tried going through many of the workarounds and bugfixes I found in this forum and a few others until I got to a point I wasn't really sure of all the fixes I tried. So I just reinstalled Ubuntu 14.04 and the problem persists. If anyone could shed some light or point me in the right direction that would be great, thanks. I've attached the result of a script I found here on the forums that details my connections and hardware and whatnot.
    Please and Thank You.
    Attached Files Attached Files

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,792
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Weak wifi signal after Ubuntu 14.04 install

    Please run
    Code:
    echo "options iwlwifi wd_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    sudo iwconfig wlan0 power off

  3. #3
    Join Date
    Nov 2015
    Beans
    2

    Re: Weak wifi signal after Ubuntu 14.04 install

    praseodym,

    Thanks for your quick reply. The results of the second command "sudo modprobe -rfv iwlwifi" are: "
    Code:
    modprobe: FATAL: Module iwlwifi is in use.
    I continued with the list of commands you gave me and got no response from the third command.
    But the results of the fourth command are:
    Code:
    Error for wireless request "Set Power Management" (8B2C) : SET failed on device wlan ; No such device.
    Not sure if this helps at all. Can you also answer this question for me: What is the effect of this sequence of commands? Is it to disable, remove, and then reload the driver; and then turn off the power management for the wireless card? I just want to learn about this process. Thanks again.

  4. #4
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,792
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Weak wifi signal after Ubuntu 14.04 install

    Then reboot

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •